net(t)forum
net(t)work(s) - fli4l - eisfair

Startseite » fli4l » spline.fli4l » ich verzweifele an ppoe
ich verzweifele an ppoe [Beitrag #68620] Thu, 10 January 2019 10:35 Zum nächsten Beitrag gehen
Friedhold Schuster ist gerade offline  Friedhold Schuster
Beiträge: 372
Registriert: October 2011
Senior Member
Moin an die Fl4l Nutzer/Entwickler,

bei mir läuft noch (jetzt bitte nicht hauen) die 3.6.2 auf einem Wrap
seit weiss nicht wieviel Jahren...

Nun muß ich mich von der Telekom verabschieden und auf Krampf einen
neuen Router aufsetzen.

Zunächst versuche ich mit der 4.0.xxx einfach wieder wie vor Jahren die
configs so zu schreiben, das er das Build erstellt. Aber immer
Fehlermeldungen. Leider kann man unter Windows die Fehlermeldungen nicht
kopieren.

Meine Konfiguration:
DSL 16000er der Telekom, dann ein Speedport nur als Modem und dahinter
der Fli4l.

Opt:
base
ppp
pppoe



Die Fehlermeldung:
Error: CIRC_1_ClASS_1='ethernet' references an unknown circuit class....


Wo kann ich mich noch belesen? Bis 2013 habe ich einige Fli4l aufgebaut,
die heute noch laufen, aber mit der jetzigen Version verzweifle ich.


Dankeschön, was kann ich noch liefern?

LG
Re: ich verzweifele an ppoe [Beitrag #68637 ist eine Antwort auf Beitrag #68620] Thu, 10 January 2019 13:45 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
butterfly ist gerade offline  butterfly
Beiträge: 765
Registriert: March 2011
Senior Member
Moin Friedhold,

Am 10.01.19 um 10:35 schrieb Friedhold Schuster:
> Moin an die Fl4l Nutzer/Entwickler,
>
> bei mir läuft noch (jetzt bitte nicht hauen) die 3.6.2 auf einem Wrap
> seit weiss nicht wieviel Jahren...

*böseguckt* ;-)

> Nun muß ich mich von der Telekom verabschieden und auf Krampf einen
> neuen Router aufsetzen.

*winkewinke*

> Zunächst versuche ich mit der 4.0.xxx einfach wieder wie vor Jahren die
> configs so zu schreiben, das er das Build erstellt. Aber immer
> Fehlermeldungen. Leider kann man unter Windows die Fehlermeldungen nicht
> kopieren.

ja leider...

> Meine Konfiguration:
> DSL 16000er der Telekom, dann ein Speedport nur als Modem und dahinter
> der Fli4l.
>
> Opt:
> base
> ppp
> pppoe

ich dachte Telekom ist wech?!?

> Die Fehlermeldung:
> Error: CIRC_1_ClASS_1='ethernet' references an unknown circuit class....

sieht so aus als ob du eine Klasse bei den Circuits eine Klasse
referenzierst die es nicht gibt.
Sollte so in der Art aussehen:

CIRC{
CLASS{
[].NAME='internet-v4'
[].NAME='internet-v6'
}

[]{
NAME='DHCPv4-LAN'
TYPE='dhcp'
CLASS[]='internet-v4'
...
}
[]{
NAME='DHCPv6-LAN'
TYPE='dhcp'
CLASS[]='internet-v6'
...
}

oder übersetzt:

CIRC_CLASS_1_NAME='internet-v4'
CIRC_CLASS_2_NAME='internet-v6'

CIRC_1_NAME='DHCPv4-LAN'
CIRC_1_TYPE='dhcp'
CIRC_1_CLASS_1='internet-v4'
...
CIRC_2_NAME='DHCPv6-LAN'
CIRC_2_TYPE='dhcp'
CIRC_2_CLASS[]='internet-v6'
...

> Wo kann ich mich noch belesen? Bis 2013 habe ich einige Fli4l aufgebaut,
> die heute noch laufen, aber mit der jetzigen Version verzweifle ich.

Da wir mit der Doku noch nicht ganz auf dem aktuellen Stand sind wird
das leider ein wenig schwierig, aber du kannst dir für einen Überblick
die Doku der Entwickler Version her nehmen.

Du bist nur ein wenig aus der Übung... ;-)

> Dankeschön, was kann ich noch liefern?

hat schon gereicht denke ich, hoffe mein Ausschnitt reicht dir auch.

--
Grüße,
Sebastian
[fli4l-team]
  • Anhang: pEpkey.asc
    (Größe: 1.75KB, 3 mal heruntergeladen)


gesendet aus dem Forum:
http://forum.nettworks.org
Re: ich verzweifele an ppoe [Beitrag #68639 ist eine Antwort auf Beitrag #68620] Thu, 10 January 2019 15:44 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
LanSpezi
Beiträge: 1013
Registriert: August 2010
Senior Member
Hallo Friedhold,

Am Thu, 10 Jan 2019 10:35:48 +0100 schrieb Friedhold Schuster:

> bei mir läuft noch (jetzt bitte nicht hauen) die 3.6.2 auf einem Wrap
> seit weiss nicht wieviel Jahren...

man hast Du Mut ;)

> Nun muß ich mich von der Telekom verabschieden und auf Krampf einen
> neuen Router aufsetzen.

selber schuld - bei der Telekom weis man wenigsten woran man ist ;)

> Zunächst versuche ich mit der 4.0.xxx einfach wieder wie vor Jahren die
> configs so zu schreiben, das er das Build erstellt. Aber immer
> Fehlermeldungen. Leider kann man unter Windows die Fehlermeldungen nicht
> kopieren.

schau mal in die LOG-Dateien die im build

> Wo kann ich mich noch belesen? Bis 2013 habe ich einige Fli4l aufgebaut,
> die heute noch laufen, aber mit der jetzigen Version verzweifle ich.

Die Beispiele in der circuits.txt sowie pppoe.txt sollten wenn Du so viele
fli4l aufgebaut hast Doch erklärend sein, und auch die Infos die hier in
der Newsgroup geliefert wurden sollten helfen, oder einfach fragen


Gruß Peter
Re: ich verzweifele an ppoe [Beitrag #68648 ist eine Antwort auf Beitrag #68637] Fri, 11 January 2019 08:10 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Friedhold Schuster ist gerade offline  Friedhold Schuster
Beiträge: 372
Registriert: October 2011
Senior Member
Moin Sebastian und alle anderen

Am 10.01.2019 um 13:45 schrieb Sebastian Klein:
>> bei mir läuft noch (jetzt bitte nicht hauen) die 3.6.2 auf einem Wrap
>> seit weiss nicht wieviel Jahren...
> *böseguckt* ;-)
never change a running system.....

>> Nun muß ich mich von der Telekom verabschieden und auf Krampf einen
>> neuen Router aufsetzen.
> *winkewinke*

stimmt endlich

>> Meine Konfiguration:
>> DSL 16000er der Telekom, dann ein Speedport nur als Modem und dahinter
>> der Fli4l.
>>
>> Opt:
>> base
>> ppp
>> pppoe
> ich dachte Telekom ist wech?!?

noch nicht, noch 14 Tage...

danach Pyur-Primacom-Telecolumbus mit einem technicolor TC200

das kann man doch als Modem Nutzen und dann Fli4l dahinter, ist das dann
nicht auch pppoe?

>> Die Fehlermeldung:
>> Error: CIRC_1_ClASS_1='ethernet' references an unknown circuit class....
> sieht so aus als ob du eine Klasse bei den Circuits eine Klasse
> referenzierst die es nicht gibt.
> Sollte so in der Art aussehen:
>
> CIRC{
> CLASS{
> [].NAME='internet-v4'
> [].NAME='internet-v6'
> }
>
> []{
> NAME='DHCPv4-LAN'
> TYPE='dhcp'
> CLASS[]='internet-v4'
> ...
> }
> []{
> NAME='DHCPv6-LAN'
> TYPE='dhcp'
> CLASS[]='internet-v6'
> ...
> }
>
> oder übersetzt:
>
> CIRC_CLASS_1_NAME='internet-v4'
> CIRC_CLASS_2_NAME='internet-v6'
>
> CIRC_1_NAME='DHCPv4-LAN'
> CIRC_1_TYPE='dhcp'
> CIRC_1_CLASS_1='internet-v4'
> ...
> CIRC_2_NAME='DHCPv6-LAN'
> CIRC_2_TYPE='dhcp'
> CIRC_2_CLASS[]='internet-v6'
> ...

Oh Mann, was habe ich da verpasst? Wo sind die einfachen, verständlichen
..txt Configs hin?

so wars einfach: ;-)

OPT_PPPOE='yes'
PPPOE_NAME='flat'
PPPOE_USEPEERDNS='yes'
PPPOE_ETH='eth0'
PPPOE_TYPE='in_kernel'
PPPOE_DEBUG='no'
PPPOE_USER='t-online-com/xxxxxxxxxxxx@t-online-com.de'
PPPOE_PASS='12345678'
PPPOE_HUP_TIMEOUT='12000'
PPPOE_CHARGEINT='60'
PPPOE_TIMES='Mo-Su:00-24:0.0:Y'
PPPOE_FILTER='yes'
PPPOE_MTU='1492'
PPPOE_MRU='1492'

>> Wo kann ich mich noch belesen? Bis 2013 habe ich einige Fli4l aufgebaut,
>> die heute noch laufen, aber mit der jetzigen Version verzweifle ich.
> Da wir mit der Doku noch nicht ganz auf dem aktuellen Stand sind wird
> das leider ein wenig schwierig, aber du kannst dir für einen Überblick
> die Doku der Entwickler Version her nehmen.
>
> Du bist nur ein wenig aus der Übung...;-)

Ich glaube, ich werde mich wohl oder Übel mit dem TC200
auseinandersetzen. Eventuell macht der das, was ich will.

Welche Programmiersprache ist das, das gabs doch früher hier nicht:

CIRC{
> CLASS{
> [].NAME='internet-v4'
> [].NAME='internet-v6'
> }


>> Dankeschön, was kann ich noch liefern?
> hat schon gereicht denke ich, hoffe mein Ausschnitt reicht dir auch.

Dankeschön dennoch.

PS, ich weiss, es ist verpönt hier, aber die 3 Dateien (ppp pppoe
circuits) würde mir niemand zur Verfügung stellen (natürlich ohne
Zugangsdaten), bei dem die Einwahl bzw. das Build klappt?
Re: ich verzweifele an ppoe [Beitrag #68672 ist eine Antwort auf Beitrag #68648] Fri, 11 January 2019 18:11 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
butterfly ist gerade offline  butterfly
Beiträge: 765
Registriert: March 2011
Senior Member
Am 11.01.19 um 08:10 schrieb Friedhold Schuster:

>> ich dachte Telekom ist wech?!?
>
> noch nicht, noch 14 Tage...
>
> danach Pyur-Primacom-Telecolumbus mit einem technicolor TC200

ahhhh....

> das kann man doch als Modem Nutzen und dann Fli4l dahinter, ist das dann
> nicht auch pppoe?

sollte gehen...

>> sieht so aus als ob du eine Klasse bei den Circuits eine Klasse
>> referenzierst die es nicht gibt.
>> Sollte so in der Art aussehen:
>>
>> CIRC{
>>    CLASS{
>>      [].NAME='internet-v4'
>>      [].NAME='internet-v6'
>>    }
>>
>>    []{
>>      NAME='DHCPv4-LAN'
>>      TYPE='dhcp'
>>      CLASS[]='internet-v4'
>> ...
>>    }
>>   []{
>>     NAME='DHCPv6-LAN'
>>     TYPE='dhcp'
>>     CLASS[]='internet-v6'
>> ...
>>    }
>>
>> oder übersetzt:
>>
>> CIRC_CLASS_1_NAME='internet-v4'
>> CIRC_CLASS_2_NAME='internet-v6'
>>
>> CIRC_1_NAME='DHCPv4-LAN'
>> CIRC_1_TYPE='dhcp'
>> CIRC_1_CLASS_1='internet-v4'
>> ...
>> CIRC_2_NAME='DHCPv6-LAN'
>> CIRC_2_TYPE='dhcp'
>> CIRC_2_CLASS[]='internet-v6'
>> ...
>
> Oh Mann, was habe ich da verpasst? Wo sind die einfachen, verständlichen
> .txt Configs hin?

nichts hast du verpasst, die alten Configs gehen nach wie vor.
Die neuen haben nur den Vorteil das wenn man irgendwo eine Regel oder so
an beliebiger Stelle einbauen möchte, nicht die gesammte Nummerierung
ändern muß. Die neue Version wird beim Build in die Alte umgewandelt.

> so wars einfach:  ;-)
>
> OPT_PPPOE='yes'
> PPPOE_NAME='flat'
> PPPOE_USEPEERDNS='yes'
> PPPOE_ETH='eth0'
> PPPOE_TYPE='in_kernel'
> PPPOE_DEBUG='no'
> PPPOE_USER='t-online-com/xxxxxxxxxxxx@t-online-com.de'
> PPPOE_PASS='12345678'
> PPPOE_HUP_TIMEOUT='12000'
> PPPOE_CHARGEINT='60'
> PPPOE_TIMES='Mo-Su:00-24:0.0:Y'
> PPPOE_FILTER='yes'
> PPPOE_MTU='1492'
> PPPOE_MRU='1492'

ich übersetzte mal...

ppp.txt:

OPT_PPP='yes'

pppoe.txt:

OPT_PPP_ETHERNET='yes'

circuits.txt:

CIRC_1_NAME='flat'
CIRC_1_TYPE='ppp'
CIRC_1_PPP_TYPE='ethernet'
CIRC_1_ENABLED='yes'
CIRC_1_CLASS_N='1'
CIRC_1_CLASS_1='internet'
CIRC_1_PPP_ETHERNET_DEV='eth1'
CIRC_1_PPP_ETHERNET_TYPE='kernel'
CIRC_1_PPP_USERID='t-online-com/xxxxxxxxxxxx@t-online-com.de'
CIRC_1_PPP_PASSWORD='12345678'
CIRC_1_PPP_FILTER='yes'
CIRC_1_PPP_FILTER_EXPR=''
CIRC_1_PPP_VJ='yes'
CIRC_1_NETS_IPV4_N='1'
CIRC_1_NETS_IPV4_1='0.0.0.0/0'
CIRC_1_DEBUG='no'
CIRC_1_USEPEERDNS='yes'
CIRC_1_HUP_TIMEOUT='600'
CIRC_1_CHARGEINT='60'
CIRC_1_UP='yes'
CIRC_1_TIMES='Mo-Su:00-24:0.0:Y'

CIRC_CLASS_1_NAME='internet'

> PS, ich weiss, es ist verpönt hier, aber die 3 Dateien (ppp pppoe
> circuits) würde mir niemand zur Verfügung stellen (natürlich ohne
> Zugangsdaten), bei dem die Einwahl bzw. das Build klappt?

siehe oben... hoffe ich habe mich nicht vertan oder vertippt :-)

--
Grüße,
Sebastian
[fli4l-team]
  • Anhang: pEpkey.asc
    (Größe: 1.75KB, einmal heruntergeladen)


gesendet aus dem Forum:
http://forum.nettworks.org
Re: ich verzweifele an ppoe [Beitrag #68675 ist eine Antwort auf Beitrag #68648] Fri, 11 January 2019 19:36 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Uwe Zeppei ist gerade offline  Uwe Zeppei
Beiträge: 259
Registriert: July 2010
Senior Member
Am 11.01.2019 um 08:10 schrieb Friedhold Schuster:
> danach Pyur-Primacom-Telecolumbus mit einem technicolor TC200

Ich find da nur einen TC 7200 und das ist ein Kabelrouter. Hat man bei
Internet über Kabel auch PPPoE?

--
Viele Grüße
Uwe
Re: ich verzweifele an ppoe [Beitrag #68681 ist eine Antwort auf Beitrag #68675] Sat, 12 January 2019 12:28 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Ralph Mory ist gerade offline  Ralph Mory
Beiträge: 109
Registriert: May 2011
Senior Member
Uwe Zeppei schrieb:
> Am 11.01.2019 um 08:10 schrieb Friedhold Schuster:
>> danach Pyur-Primacom-Telecolumbus mit einem technicolor TC200
>
> Ich find da nur einen TC 7200 und das ist ein Kabelrouter. Hat man bei
> Internet über Kabel auch PPPoE?
>

nein

Der FLI "dahinter" wird als reiner Ethernet-Router mit DHCP-Client
benötigt...
Re: ich verzweifele an ppoe [Beitrag #68683 ist eine Antwort auf Beitrag #68681] Sun, 13 January 2019 09:17 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Friedhold Schuster ist gerade offline  Friedhold Schuster
Beiträge: 372
Registriert: October 2011
Senior Member
Moin,

Am 12.01.2019 um 12:28 schrieb Ralph Mory:
> Uwe Zeppei schrieb:
>> Am 11.01.2019 um 08:10 schrieb Friedhold Schuster:
>>> danach Pyur-Primacom-Telecolumbus mit einem technicolor TC200
>>
>> Ich find da nur einen TC 7200 und das ist ein Kabelrouter. Hat man bei
>> Internet über Kabel auch PPPoE?
>>
>
> nein
>
> Der FLI "dahinter" wird als reiner Ethernet-Router mit DHCP-Client
> benötigt...

Dankeschön,
ich habe gelesen, das man den TC 7200 als "Nur Modem" umschalten
(lassen) kann. Wie ist es dann?

Ich möchte auch von aussen auf den Router oder mein Netz zugreifen
können. Wie ist es bei einem Ethernet-Router hinter dem TC 7200, muss
man das Portforwarding im TC 7200 und auch dann im Fli4l einstellen?
Dies wollte ich durch TC 7200 als Modem und Fli4l dahinter umgehen.

Dankeschön
Re: ich verzweifele an ppoe [Beitrag #68688 ist eine Antwort auf Beitrag #68683] Sun, 13 January 2019 12:00 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Ralph Mory ist gerade offline  Ralph Mory
Beiträge: 109
Registriert: May 2011
Senior Member
Friedhold Schuster schrieb:
> Moin,
>

Moin

> ich habe gelesen, das man den TC 7200 als "Nur Modem" umschalten
> (lassen) kann. Wie ist es dann?

Nein, ein "nur Modem" im klassischen Sinn gibt es nicht. Es gibt kein
PPPoE, die Authentifizierung findet quasi über die MAC des TC7200 statt.
Deswegen sind diese ("Kabelmodems") auch nicht beliebig austauschbar.

Sofern der TC7200 diesen Betriebsmodus "nur Modem" überhaupt zuläßt (was
ich bezweifele), macht er für den Betrieb mit einem Fli auch keinen
Sinn. Der Fli bekäme dann evtl. nur eine andere IP, das ist alles.

>
> Ich möchte auch von aussen auf den Router oder mein Netz zugreifen
> können. Wie ist es bei einem Ethernet-Router hinter dem TC 7200, muss
> man das Portforwarding im TC 7200 und auch dann im Fli4l einstellen?

Ja, das müßte in beiden eingestellt werden.

Allerdings sind Kabel ISP für diese Belange meistens nicht sehr
kooperativ. Man bekommt entweder eine öffentliche IP, die man sich mit
anderen Kunden teilt (was für die normale Internetnutzung unerheblich
ist) oder eine "Sammeladresse" aus dem 100er Netz oder eben eine private
IP im Netz des ISP. In solchen Fällen müßte ein Forwarding beim ISP
eingerichtet werden, was ja nun nicht möglich ist...

Diese Verfahrensweise kann sich im Laufe der Zeit durchaus auch einmal
ändern. Ich hatte mal einen Fernzugriff erfolgreich eingerichtet, der
auch funktionierte. Ab einem bestimmten Zeitpunkt ging das dann aus den
eben beschriebenen Gründen aber nicht mehr..

>
> Dankeschön

aber gern :)
Re: ich verzweifele an ppoe [Beitrag #68704 ist eine Antwort auf Beitrag #68688] Sun, 13 January 2019 15:17 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Friedhold Schuster ist gerade offline  Friedhold Schuster
Beiträge: 372
Registriert: October 2011
Senior Member
Hallo Ralph,

Am 13.01.2019 um 12:00 schrieb Ralph Mory:
>> ich habe gelesen, das man den TC 7200 als "Nur Modem" umschalten
>> (lassen) kann. Wie ist es dann?
>
> Nein, ein "nur Modem" im klassischen Sinn gibt es nicht. Es gibt kein
> PPPoE, die Authentifizierung findet quasi über die MAC des TC7200 statt.
>  Deswegen sind diese ("Kabelmodems") auch nicht beliebig austauschbar.
>
> Sofern der TC7200 diesen Betriebsmodus "nur Modem" überhaupt zuläßt (was
> ich bezweifele), macht er für den Betrieb mit einem Fli auch keinen
> Sinn. Der Fli bekäme dann evtl. nur eine andere IP, das ist alles.

Ich hatte folgendes in der Bedienungsanleitung gelesen:

-----------
Routerzwang?

Nicht mit Tele Columbus!
Die Nutzung eines eigenen Routers an der Kabelbox ist möglich. Ein Anruf
bei unserem Kundenservice (siehe Kontaktinformationen) genügt und wir
schalten das Gerät –selbstverständlich kostenfrei– in den Modembetrieb.
Diese Einstellung können Sie bei Bedarf wieder aufheben lassen.
-----------

somit war ich der Meinung den TC 7200 als Modem und dahinter fli4l als
Router.

>> Ich möchte auch von aussen auf den Router oder mein Netz zugreifen
>> können. Wie ist es bei einem Ethernet-Router hinter dem TC 7200, muss
>> man das Portforwarding im TC 7200 und auch dann im Fli4l einstellen?
> Ja, das müßte in beiden eingestellt werden.

diesen doppelten Aufwand wollte ich mir sparen.

>
> Allerdings sind Kabel ISP für diese Belange meistens nicht sehr
> kooperativ. Man bekommt entweder eine öffentliche IP, die man sich mit
> anderen Kunden teilt (was für die normale Internetnutzung unerheblich
> ist) oder eine "Sammeladresse" aus dem 100er Netz oder eben eine private
> IP im Netz des ISP. In solchen Fällen müßte ein Forwarding beim ISP
> eingerichtet werden, was ja nun nicht möglich ist...
>
> Diese Verfahrensweise kann sich im Laufe der Zeit durchaus auch einmal
> ändern. Ich hatte mal einen Fernzugriff erfolgreich eingerichtet, der
> auch funktionierte. Ab einem bestimmten Zeitpunkt ging das dann aus den
> eben beschriebenen Gründen aber nicht mehr..

Somit kann ich mich sozusagen von der Idee verabschieden, irgendwie von
Aussen auf das Netz zu kommen (VPN oder so).

Bringt da ein Fl4l als reiner Ethernetrouter hinter dem Originalrouter
überhaupt noch Vorteile gegenüber dem "Kaufrouter" alleine?

Dankeschön
Re: ich verzweifele an ppoe [Beitrag #68705 ist eine Antwort auf Beitrag #68704] Sun, 13 January 2019 16:12 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Ralph Mory ist gerade offline  Ralph Mory
Beiträge: 109
Registriert: May 2011
Senior Member
Friedhold Schuster schrieb:
>
> Hallo Ralph,
>

[...]

> Ich hatte folgendes in der Bedienungsanleitung gelesen:
>
> -----------
> Routerzwang?
> –
> Nicht mit Tele Columbus!
> Die Nutzung eines eigenen Routers an der Kabelbox ist möglich. Ein Anruf
> bei unserem Kundenservice (siehe Kontaktinformationen) genügt und wir
> schalten das Gerät –selbstverständlich kostenfrei– in den Modembetrieb.
> Diese Einstellung können Sie bei Bedarf wieder aufheben lassen.
> -----------
>
> somit war ich der Meinung den TC 7200 als Modem und dahinter fli4l als
> Router.

Es ist trotzdem keine PPPoE-Verbindung und es trifft das zu, was ich
beschrieb.

Womit Telecolumbus (sie haben sich in PYUR umbenannt) "Werbung" macht,
ist einfach nur, daß man nicht mehr zwingend ein Gerät verwenden muß,
was sie stellen, sondern eines vom freien Markt nehmen kann (was
natürlich von denen freigeschaltet werden muß, da die Zuordnung zum
Kunden über die MAC des Gerätes erfolgt, wie schon gesagt...

>
>>> Ich möchte auch von aussen auf den Router oder mein Netz zugreifen
>>> können. Wie ist es bei einem Ethernet-Router hinter dem TC 7200, muss
>>> man das Portforwarding im TC 7200 und auch dann im Fli4l einstellen?
>> Ja, das müßte in beiden eingestellt werden.
>
> diesen doppelten Aufwand wollte ich mir sparen.
>

Würde in dem Fall nicht zu umgehen sein. Wäre aber eh nur dann möglich,
wenn man eine eigene individuelle öffentliche IP bekommt, die man mit
niemandem teilen muß...

>
> Somit kann ich mich sozusagen von der Idee verabschieden, irgendwie von
> Aussen auf das Netz zu kommen (VPN oder so).

Wenn sie (TC/PYUR) es nicht wollen, dann ja... Kabelanbieter sind wegen
ihrer Eigenart der Kunden-/IP-Verwaltung in der Hinsicht grundsätzlich
problematisch bzw. einfach ungeeignet.. zumindest auf der Basis von IP4

>
> Bringt da ein Fl4l als reiner Ethernetrouter hinter dem Originalrouter
> überhaupt noch Vorteile gegenüber dem "Kaufrouter" alleine?

Diese Entscheidung sollte jeder für sich treffen. Hängt wohl auch sehr
davon ab, welche Funktion(en) man dem Fli anvertrauen möchte...

>
> Dankeschön
>

...aber gerne...
Re: ich verzweifele an ppoe [Beitrag #68709 ist eine Antwort auf Beitrag #68704] Sun, 13 January 2019 17:02 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Hans Bachner ist gerade offline  Hans Bachner
Beiträge: 338
Registriert: August 2010
Senior Member
Hallo allseits,

Friedhold Schuster schrieb am 13.01.2019 um 15:17:
>
> Hallo Ralph,
>
> Am 13.01.2019 um 12:00 schrieb Ralph Mory:
>>> ich habe gelesen, das man den TC 7200 als "Nur Modem" umschalten
>>> (lassen) kann. Wie ist es dann?
>>
>> Nein, ein "nur Modem" im klassischen Sinn gibt es nicht.

Doch, die gibt es durchaus, wenn auch vermutlich nicht bei jedem Gerät.
Das Signal muss ja zwischen dem Medium TV-Kabel und dem Medium Ethernet
hin- und herkonvertiert werden, das macht das Kabelmodem.

>> Es gibt kein PPPoE,

stimmt

>> die Authentifizierung findet quasi über die MAC des TC7200 statt.

Zumindest hier beim lokalen Kabel-Anbieter nicht. Ich gehe davon aus,
dass das Kabelmodem beim Verbindungsaufbau die nötigen Daten für die
Authentifizierung mitschickt.

Ich habe etliche Jahre lang einen fli4l hinter einem Kabelmodem betreut.
Die einzige Einschränkung war, dass das Kabelmodem nur mit einer
MAC-Adresse am LAN-Anschluss kommunizierte - und zwar mit der ersten,
die es nach dem Booten entdeckte. Wenn man den Router tauschte, musste
man also das Kabelmodem kurz stromlos machen. Gab es Probleme, konnte
man auch ein Notebook/einen PC direkt ans Modem anstecken und nach einem
Reboot des Modems testen, ob überhaupt eine IP-Adresse zugewiesen wurde
bzw. falls ja, wie weit die Kommunikation funktionierte.

>> Deswegen sind diese ("Kabelmodems") auch nicht beliebig
>> austauschbar.
>>
>> Sofern der TC7200 diesen Betriebsmodus "nur Modem" überhaupt zuläßt
>> (was ich bezweifele), macht er für den Betrieb mit einem Fli auch
>> keinen Sinn. Der Fli bekäme dann evtl. nur eine andere IP, das ist alles.
>
> Ich hatte folgendes in der Bedienungsanleitung gelesen:
>
> -----------
> Routerzwang?
> –
> Nicht mit Tele Columbus!
> Die Nutzung eines eigenen Routers an der Kabelbox ist möglich. Ein Anruf
> bei unserem Kundenservice (siehe Kontaktinformationen) genügt und wir
> schalten das Gerät –selbstverständlich kostenfrei– in den Modembetrieb.
> Diese Einstellung können Sie bei Bedarf wieder aufheben lassen.
> -----------
>
> somit war ich der Meinung den TC 7200 als Modem und dahinter fli4l als
> Router.

So würde ich das auch interpretieren.

>>> Ich möchte auch von aussen auf den Router oder mein Netz zugreifen
>>> können. Wie ist es bei einem Ethernet-Router hinter dem TC 7200, muss
>>> man das Portforwarding im TC 7200 und auch dann im Fli4l einstellen?
>> Ja, das müßte in beiden eingestellt werden.
>
> diesen doppelten Aufwand wollte ich mir sparen.
>
>>
>> Allerdings sind Kabel ISP für diese Belange meistens nicht sehr
>> kooperativ. Man bekommt entweder eine öffentliche IP, die man sich mit
>> anderen Kunden teilt (was für die normale Internetnutzung unerheblich
>> ist) oder eine "Sammeladresse" aus dem 100er Netz oder eben eine
>> private IP im Netz des ISP. In solchen Fällen müßte ein Forwarding
>> beim ISP eingerichtet werden, was ja nun nicht möglich ist...
>>
>> Diese Verfahrensweise kann sich im Laufe der Zeit durchaus auch einmal
>> ändern. Ich hatte mal einen Fernzugriff erfolgreich eingerichtet, der
>> auch funktionierte. Ab einem bestimmten Zeitpunkt ging das dann aus
>> den eben beschriebenen Gründen aber nicht mehr..
>
> Somit kann ich mich sozusagen von der Idee verabschieden, irgendwie von
> Aussen auf das Netz zu kommen (VPN oder so).

Nicht unbedingt. Frag einmal beim Anbieter nach, ob du tatsächlich eine
(wenn auch dynamische) öffentliche IP-Adresse bekommst. Dann kannst du
dein Vorhaben umsetzen.

> Bringt da ein Fl4l als reiner Ethernetrouter hinter dem Originalrouter
> überhaupt noch Vorteile gegenüber dem "Kaufrouter" alleine?

Selbst wenn du keine öffentliche Adresse bekommst und Zugriff von
außen/Portforwarding daher nicht möglich ist, kannst du immer noch die
übrigen Funktionen des fli4l nutzen (Firewall, mehrere interne
Subnetze/VLANs, Traffic-Accounting, ...). Aber nach der obigen
Beschreibung solltest du ja das TC7200 als Modem betreiben können.

Viel Erfolg,
Hans.
Re: ich verzweifele an ppoe [Beitrag #68713 ist eine Antwort auf Beitrag #68620] Mon, 14 January 2019 02:03 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Friedrich Bartel ist gerade offline  Friedrich Bartel
Beiträge: 489
Registriert: July 2010
Senior Member
Am 10.01.2019 um 10:35 schrieb Friedhold Schuster:
>
> Wo kann ich mich noch belesen? Bis 2013 habe ich einige Fli4l aufgebaut,
> die heute noch laufen, aber mit der jetzigen Version verzweifle ich.
>
>
> Dankeschön, was kann ich noch liefern?
>
> LG

Meiner ist noch älter, 3.0.1, der hat schon drei Provider durch.
Mit welcher Begründung muss man einen neuen Fli4l aufsetzen?

Einfach die neuen Anmeldedaten in der DSL-Opt eingeben und gut ist.
Vorausgesetzt der neue Router fungiert als Modem.

OK, bei den VoIP Scheiß-Anschlussdingern ist das heute etwas anders.

Da sollte man Telefonie dem Router überlassen und den Fli4l als DHCP-
Client konfigurieren.


Andererseits.
Welchen Nutzen hat dieser Zoo hinter dem DSL-Modem heute noch?
Die meisten modernen Router bieten das meiste frei Haus und mit weniger
Watt pro Stunde.

Fridrich
Re: ich verzweifele an ppoe [Beitrag #68714 ist eine Antwort auf Beitrag #68713] Mon, 14 January 2019 08:43 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Friedhold Schuster ist gerade offline  Friedhold Schuster
Beiträge: 372
Registriert: October 2011
Senior Member
Hallo Fridrich,

Am 14.01.2019 um 02:04 schrieb Fridrich:

> Meiner ist noch älter, 3.0.1, der hat schon drei Provider durch.
> Mit welcher Begründung muss man einen neuen Fli4l aufsetzen?

hier lass ich mal die Fachleute sprechen. Bei mir war es Faulheit und
irgendwann ging dann Built-Erstellen nicht mehr.

> Einfach die neuen Anmeldedaten in der DSL-Opt eingeben und gut ist.
> Vorausgesetzt der neue Router fungiert als Modem.

ich habs noch einfacher gemacht, per SSH auf den Fli4l und direkt in der
rc.cfg und rc2.cfg geändert. Da ich meinen Fehler nicht fand, gings
nicht anders.

> OK, bei den VoIP Scheiß-Anschlussdingern ist das heute etwas anders.
>
> Da sollte man Telefonie dem Router überlassen und den Fli4l als DHCP-
> Client konfigurieren.
>
>
> Andererseits.
> Welchen Nutzen hat dieser Zoo hinter dem DSL-Modem heute noch?
> Die meisten modernen Router bieten das meiste frei Haus und mit weniger
> Watt pro Stunde.

Hier bin ich auch am grübeln und auf weitere Meinungen gespannt. Wobei
ich ungern fli4l aufgeben würde. Ich war seit Anfang an dabei (sogar,
als es noch nicht Eisfair gab) und habe mich immer wohl gefühlt.

Aber nun gibts kein ISDN mehr, Fax auch nicht und die Telefonie ist in
der Cloud incl. Anrufbeantworter und Fax.

Ich will dennoch nicht auf den Fli4l verzichten. Wenn das mit dem Modem
nicht klappen sollte, dann wenigstens als Ethernet-Router.

Kann man eigentlich beim Ethernet-Router 2 "Eingänge" wahlweise
schalten, zb. wenn Kabelanbieter nicht geht, dann auf den LTE-Router
umschalten?

Dankeschön
Re: ich verzweifele an ppoe [Beitrag #68718 ist eine Antwort auf Beitrag #68713] Mon, 14 January 2019 20:11 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
butterfly ist gerade offline  butterfly
Beiträge: 765
Registriert: March 2011
Senior Member
Am 14.01.19 um 02:04 schrieb Fridrich:
> Meiner ist noch älter, 3.0.1, der hat schon drei Provider durch.
> Mit welcher Begründung muss man einen neuen Fli4l aufsetzen?

Ah du nutzt also auch noch Windows XP produktiv, nur mal so zum Alter
deines fli4l. Und du fragst ernsthaft warum man den mal neu machen
sollte? Guck dir einfach nur mal an was an CVEs im Kernel behoben wurde,
ganz zu schweigen von den "restlichen" Programmen die so auf dem fli4l
werkeln.

Naja muß jeder selber wissen, aber du schließt schon deine Haustür ab
wenn du nicht zu Hause bist... ohne viele Worte dafür aber mit sehr viel
Kopfschütteln...

--
Grüße,
Sebastian
[fli4l-team]
  • Anhang: pEpkey.asc
    (Größe: 1.75KB, 0 mal heruntergeladen)


gesendet aus dem Forum:
http://forum.nettworks.org
Re: ich verzweifele an ppoe [Beitrag #68720 ist eine Antwort auf Beitrag #68713] Mon, 14 January 2019 21:03 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Uwe Zeppei ist gerade offline  Uwe Zeppei
Beiträge: 259
Registriert: July 2010
Senior Member
Moin!

Am 14.01.2019 um 02:04 schrieb Fridrich:
> Andererseits.
> Welchen Nutzen hat dieser Zoo hinter dem DSL-Modem heute noch?
> Die meisten modernen Router bieten das meiste frei Haus und mit weniger
> Watt pro Stunde.

Gründe, warum ich fli4l nutze, auch wenn ich dafür einen "Zoo" brauche
(ohne Sortierung nach Prio):
- ich bin nicht für die ganzen Plasterouter-Sicherheitslücken anfällig
- ich kann den Router recht fein granuliert konfigurieren, wenn ich will
- ich kann recht problemlos mehrere Netze hinter dem Router aufmachen
- ich kann OpenVPN nutzen und dies auch in unterschiedlichen Konfigurationen
- ich kann über OpenVPN verschiedene Router vernetzen und bin nicht auf
herstellerspezifische Lösungen angewiesen
- ich kann Standard-Hardware nutzen (x86/64 kompatibel) und gemäß meiner
Anforderungen aufrüsten (mehr Netzwerkports o.ä.)
- ich kann, dank der Opts, auch ungewöhnliche Dinge machen (z.B. meine
APC-USV über ein Opt ansprechen und nicht nur den Router, sondern auch
andere Rechner mit den Infos zum Zustand der USV versorgen)
- der Fli4l ist nur sehr eingeschränkt über Web konfigurierbar, man kann
mir also die Konfig nicht "aus der Ferne" zersägen
- UPnP wird verhindert
- TR-069 funzt nicht
- fli4l ist ziemlich aktuell, was Sicherheitslücken usw. angeht (sofern
man natürlich die Updates auch mal einspielt)
- ich hab super Support durch das Team und die Community

Als Hardware verwende ich aktuell Boards mit aufgelöteter CPU, deren
max. TDP bei 6 (ein neuer im Bau) bzw. 7 Watt liegen. Ich hab also mein
externes Modem plus Fli4l (derzeit beide mit ziemlich ineffizienten
Netzteilen, da will ich noch mal ran) plus an einem Anschluss eine
Fritte 7270 für VoIP, Fax und WLAN. WLAN ist aus Faulheit nicht im Fli4l
verbaut.

Die einzigen mir bekannten Router mit einer recht großen Flexibilität,
was z.B. zusätzliche Netze und VPN usw. angeht, sind von Lancom und
spielen in einer für mich nicht realisierbaren Preisklasse.

Just my 2 Cents. :-)

An dieser Stelle auch mal von mir ein dickes "Dankschön" an das
fli4l-Team und alle, die Unterstützung leisten!

--
Viele Grüße
Uwe
Re: ich verzweifele an ppoe [Beitrag #68726 ist eine Antwort auf Beitrag #68714] Mon, 14 January 2019 21:31 Zum vorherigen Beitrag gehen
LeSpocky ist gerade offline  LeSpocky
Beiträge: 610
Registriert: July 2010
Ort: Magdeburg
Senior Member

Moin,

Friedhold Schuster schrieb Montag, 14. Januar 2019, 08:43 (CET):
> Am 14.01.2019 um 02:04 schrieb Fridrich:
> > Meiner ist noch älter, 3.0.1, der hat schon drei Provider durch.
> > Mit welcher Begründung muss man einen neuen Fli4l aufsetzen?
>
> hier lass ich mal die Fachleute sprechen. Bei mir war es Faulheit und
> irgendwann ging dann Built-Erstellen nicht mehr.

Die Kiste hängt hoffentlich nicht am Internet? o.O

> > Welchen Nutzen hat dieser Zoo hinter dem DSL-Modem heute noch?

Hier:

* mehrere Netze
* _viele_ Nutzer (so ein Plastrouter kommt mit fünf Clients noch klar,
bei 50 raucht die eine oder andere Kiste schon ab)
* OpenVPN (und nicht nur eins)
* leistungsfähiger Paketfilter
* VLAN
* brauchbar konfigurierbares DNS auf dem Router
* freie Software!
* durch eigene Programme erweiterbar (bspw. für dyndns)
* aktuelle Software, wo auch Sicherheitslücken behoben werden, auch auf
alter Hardware
* …

> > Die meisten modernen Router bieten das meiste frei Haus und mit weniger
> > Watt pro Stunde.
>
> Hier bin ich auch am grübeln und auf weitere Meinungen gespannt. Wobei
> ich ungern fli4l aufgeben würde. Ich war seit Anfang an dabei (sogar,
> als es noch nicht Eisfair gab) und habe mich immer wohl gefühlt.

* Community … ;-)

> Aber nun gibts kein ISDN mehr, Fax auch nicht und die Telefonie ist in
> der Cloud incl. Anrufbeantworter und Fax.

Telefonie in der Cloud?

> Ich will dennoch nicht auf den Fli4l verzichten. Wenn das mit dem Modem
> nicht klappen sollte, dann wenigstens als Ethernet-Router.

Ist auch kein größeres Problem. Hab ich hier auf IGEL, ALIX und sogar
WRAP laufen, alles mit aktuellstem fli4l 4.0 …

> Kann man eigentlich beim Ethernet-Router 2 "Eingänge" wahlweise
> schalten, zb. wenn Kabelanbieter nicht geht, dann auf den LTE-Router
> umschalten?

Mit dem Circuit-System von fli4l 4.0 geht das. Derzeit nur mit manuellem
Umschalten, aber da der Quellcode ja frei ist, können wir das gemeinsam
auch ändern und verbessern.

Grüße
Alex

--
***** http://blog.antiblau.de/ *****************************
GnuPG-FP: C28E E6B9 0263 95CF 8FAF 08FA 34AD CD00 7221 5CC6
Vorheriges Thema: Informationen zu den wöchentlichen 3.10-Archiven vom 11.01.2019 (r54839)
Nächstes Thema: APU2 und Probleme mit Update der 4er-Version
Gehe zum Forum:
  


aktuelle Zeit: Mon Jan 21 04:53:39 CET 2019

Insgesamt benötigte Zeit, um die Seite zu erzeugen: 0.01475 Sekunden