net(t)forum
net(t)work(s) - fli4l - eisfair

Startseite » eisfair » spline.eisfair » Roundcube 1.4.7
Roundcube 1.4.7 [Beitrag #68623] Thu, 10 January 2019 11:13 Zum nächsten Beitrag gehen
Stefan Heidrich ist gerade offline  Stefan Heidrich
Beiträge: 567
Registriert: July 2010
Senior Member
Hallo Jürgen, hallo NG,

nach dem Update auf Roundcube 1.4.7 erhalte ich täglich folgende Mail:

Betreff:
fcron <root@www> chmod 0544 /var/www/htdocs/roundcube/bin/cleandb.sh;
/var/www/htdocs/roundcube/bin/cleandb.sh >/dev/null

Mailtext:
Job 'chmod 0544 /var/www/htdocs/roundcube/bin/cleandb.sh;
/var/www/htdocs/roundcube/bin/cleandb.sh >/dev/null' terminated (exit
status: 255) (mailing output)

Muss mir das etwas sagen?

Viele Grüße
Stefan
Re: Roundcube 1.4.7 [Beitrag #68624 ist eine Antwort auf Beitrag #68623] Thu, 10 January 2019 11:39 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Marcus Roeckrath ist gerade offline  Marcus Roeckrath
Beiträge: 11676
Registriert: August 2010
Senior Member
Hallo Stefan,

Stefan Heidrich wrote:

> Betreff:
> fcron <root@www> chmod 0544 /var/www/htdocs/roundcube/bin/cleandb.sh;
> /var/www/htdocs/roundcube/bin/cleandb.sh >/dev/null
>
> Mailtext:
> Job 'chmod 0544 /var/www/htdocs/roundcube/bin/cleandb.sh;
> /var/www/htdocs/roundcube/bin/cleandb.sh >/dev/null' terminated (exit
> status: 255) (mailing output)

Das Skript beendet sich mit Errorlevel 255, was fcron zur Fehlermail
veranlasst. Der Output wird aber durch >&dev/null ins Nirvana geschickt.

Führe doch mal

/var/www/htdocs/roundcube/bin/cleandb.sh

auf der Konsole aus und poste den Output.

--
Gruss Marcus


Gruß Marcus
Re: Roundcube 1.4.7 [Beitrag #68626 ist eine Antwort auf Beitrag #68624] Thu, 10 January 2019 11:53 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Stefan Heidrich ist gerade offline  Stefan Heidrich
Beiträge: 567
Registriert: July 2010
Senior Member
Hallo Marcus,

> Führe doch mal > /var/www/htdocs/roundcube/bin/cleandb.sh> auf der Konsole aus und
poste den Output.
wenn ich das händisch ausführe bekomme ich keine Anzeige / keinen
Output. Das Script läuft ohne (Fehler)Meldung durch.

Viele Grüße und Danke
Stefan
Re: Roundcube 1.4.7 [Beitrag #68628 ist eine Antwort auf Beitrag #68626] Thu, 10 January 2019 12:03 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Marcus Roeckrath ist gerade offline  Marcus Roeckrath
Beiträge: 11676
Registriert: August 2010
Senior Member
Hallo Stefan,

Stefan Heidrich wrote:

>> Führe doch mal > /var/www/htdocs/roundcube/bin/cleandb.sh> auf der
>> Konsole aus und
> poste den Output.
> wenn ich das händisch ausführe bekomme ich keine Anzeige / keinen
> Output. Das Script läuft ohne (Fehler)Meldung durch.

ls -la /var/www/htdocs/roundcube/bin/cleandb.sh

/var/www/htdocs/roundcube/bin/cleandb.sh ; echo $?

--
Gruss Marcus


Gruß Marcus
Re: Roundcube 1.4.7 [Beitrag #68630 ist eine Antwort auf Beitrag #68628] Thu, 10 January 2019 12:15 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Stefan Heidrich ist gerade offline  Stefan Heidrich
Beiträge: 567
Registriert: July 2010
Senior Member
Hallo Marcus,

> ls -la /var/www/htdocs/roundcube/bin/cleandb.sh
ls -la /var/www/htdocs/roundcube/bin/cleandb.sh
-r-xr--r-- 1 wwwrun nogroup 1475 Oct 23 13:12
/var/www/htdocs/roundcube/bin/cleandb.sh

> /var/www/htdocs/roundcube/bin/cleandb.sh ; echo $?

/var/www/htdocs/roundcube/bin/cleandb.sh ; echo $?
255

Viele Grüße
Stefan
Re: Roundcube 1.4.7 [Beitrag #68631 ist eine Antwort auf Beitrag #68630] Thu, 10 January 2019 12:33 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Marcus Roeckrath ist gerade offline  Marcus Roeckrath
Beiträge: 11676
Registriert: August 2010
Senior Member
Hallo Stefan,

Stefan Heidrich wrote:

>> ls -la /var/www/htdocs/roundcube/bin/cleandb.sh
> ls -la /var/www/htdocs/roundcube/bin/cleandb.sh
> -r-xr--r-- 1 wwwrun nogroup 1475 Oct 23 13:12
> /var/www/htdocs/roundcube/bin/cleandb.sh
>
>> /var/www/htdocs/roundcube/bin/cleandb.sh ; echo $?
>
> /var/www/htdocs/roundcube/bin/cleandb.sh ; echo $?
> 255

Laut

https://serverfault.com/questions/153634/php-exit-status-255-what-does-i t-mean

keinem speziellen Fehler zugeordnet ist, der eigentliche Error aber
womöglich "ins Nirvana" geht.

Kannst du bitte sagen, welche php-Version du einsetzt?

php5 oder php7?

--
Gruss Marcus


Gruß Marcus
Re: Roundcube 1.4.7 [Beitrag #68632 ist eine Antwort auf Beitrag #68631] Thu, 10 January 2019 12:45 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Stefan Heidrich ist gerade offline  Stefan Heidrich
Beiträge: 567
Registriert: July 2010
Senior Member
Hallo Marcus,

> Kannst du bitte sagen, welche php-Version du einsetzt? > php5 oder php7?
nur noch php7. Nachdem damit alles lief habe ich mich von der 5er
Version komplett getrennt.

Viele Grüße
Stefan
Re: Roundcube 1.4.7 [Beitrag #68633 ist eine Antwort auf Beitrag #68632] Thu, 10 January 2019 12:57 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Marcus Roeckrath ist gerade offline  Marcus Roeckrath
Beiträge: 11676
Registriert: August 2010
Senior Member
Hallo Stefan,

Stefan Heidrich wrote:

>> Kannst du bitte sagen, welche php-Version du einsetzt? > php5 oder php7?
> nur noch php7. Nachdem damit alles lief habe ich mich von der 5er
> Version komplett getrennt.

Ich habe noch php5 und kann das nun versuchen zu reproduzieren.

Vielleicht hat Jürgen eine Idee, wie wir dem Error 255 eine textliche
Ursache entlocken können.

Die Vorversion 1.4.6 hat noch ohne die Fehlemeldung funktionbiert.

--
Gruss Marcus


Gruß Marcus
Re: Roundcube 1.4.7 [Beitrag #68635 ist eine Antwort auf Beitrag #68633] Thu, 10 January 2019 13:32 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Stefan Heidrich ist gerade offline  Stefan Heidrich
Beiträge: 567
Registriert: July 2010
Senior Member
Hallo Marcus,

> Die Vorversion 1.4.6 hat noch ohne die Fehlemeldung funktionbiert.
ja, bei mir auch. Ich habe den Fehler erst seit dem Update.

Viele Grüße
Stefan
Re: Roundcube 1.4.7 [Beitrag #68638 ist eine Antwort auf Beitrag #68635] Thu, 10 January 2019 13:51 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Marcus Roeckrath ist gerade offline  Marcus Roeckrath
Beiträge: 11676
Registriert: August 2010
Senior Member
Hallo Stefan,

Stefan Heidrich wrote:

>> Die Vorversion 1.4.6 hat noch ohne die Fehlemeldung funktionbiert.
> ja, bei mir auch.

Da habe ich ein Missverständnis verursacht, denn da sollte ein ? hin; ich
setze roundcube garnicht ein.

> Ich habe den Fehler erst seit dem Update.

Ok, vielleicht kann Jürgen das Problem anhand der letzten Änderungen im
Paket eingrenzen.

--
Gruss Marcus


Gruß Marcus
Re: Roundcube 1.4.7 [Beitrag #68642 ist eine Antwort auf Beitrag #68623] Thu, 10 January 2019 18:59 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Juergen Edner ist gerade offline  Juergen Edner
Beiträge: 3083
Registriert: September 2010
Senior Member
Hallo Stefan,

> nach dem Update auf Roundcube 1.4.7 erhalte ich täglich folgende Mail:
>
> Betreff:
> fcron <root@www> chmod 0544 /var/www/htdocs/roundcube/bin/cleandb.sh;
> /var/www/htdocs/roundcube/bin/cleandb.sh >/dev/null
>
> Mailtext:
> Job 'chmod 0544 /var/www/htdocs/roundcube/bin/cleandb.sh;
> /var/www/htdocs/roundcube/bin/cleandb.sh >/dev/null' terminated (exit
> status: 255) (mailing output)
>
> Muss mir das etwas sagen?

aus dem Diskussionsverlauf habe ich bereits entnommen, dass Du PHP7
einsetzt. Nutzt Du eisfair-1 oder eisfair-64? Durch ein paar Last Minute
Änderungen in den PHP-Paketen hatten sich ein paar Fehler
eingeschlichen, die Sebastian zwar zwischenzeitlich größtenteils gelöst
hat, ich bin aber noch nicht ganz nachgekommen meine Pakete entsprechend
anzupassen.
Hast Du nach der Paketinstallation vielleicht noch einmal die
Konfiguration durchlaufen lassen? Bei der Installation selbst werden ja
viele Meldungen unterstützt - vielleicht ja zwischenzeitlich zu viele.

BTW: Bei mir läuft bis dato jede roundcube-Paketversion mit PHP7
fehlerfrei, sodass sich auch diese Problem bei Dir lösen lassen
sollte ;-)

Gruß Jürgen
--
Mail: juergen@eisfair.org
Re: Roundcube 1.4.7 [Beitrag #68651 ist eine Antwort auf Beitrag #68642] Fri, 11 January 2019 11:25 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Stefan Heidrich ist gerade offline  Stefan Heidrich
Beiträge: 567
Registriert: July 2010
Senior Member
Hallo Jürgen,

> aus dem Diskussionsverlauf habe ich bereits entnommen, dass Du PHP7 > einsetzt. Nutzt Du eisfair-1 oder eisfair-64?

noch ein eisfair-1.

> Hast Du nach der Paketinstallation vielleicht noch einmal die > Konfiguration durchlaufen lassen?

Habe ich gerade gemacht und beobachte, ob der Fehler heute Nacht wieder
auftritt.

> BTW: Bei mir läuft bis dato jede roundcube-Paketversion mit PHP7 > fehlerfrei, sodass sich auch diese Problem bei Dir lösen
lassen> sollte ;-)
Das ist fein; ich habe Hoffnung. ;-)

Viele Grüße und Danke
Stefan
Re: Roundcube 1.4.7 [Beitrag #68656 ist eine Antwort auf Beitrag #68651] Fri, 11 January 2019 12:11 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Juergen Edner ist gerade offline  Juergen Edner
Beiträge: 3083
Registriert: September 2010
Senior Member
Hallo Stefan,

>> aus dem Diskussionsverlauf habe ich bereits entnommen, dass Du PHP7 >
>> einsetzt. Nutzt Du eisfair-1 oder eisfair-64?
>
> noch ein eisfair-1.

ok.

>> Hast Du nach der Paketinstallation vielleicht noch einmal die >
>> Konfiguration durchlaufen lassen?
>
> Habe ich gerade gemacht und beobachte, ob der Fehler heute Nacht wieder
> auftritt.

Bitte prüfe noch einmal die Konfiguration des php7-cli-Paketes. Ich
empfehle grundsätzlich dort die gleichen Einstellungen vorzunehmen
wie auch beim apache2_php7/php7-fpm-Paket.
Viele Anwender glauben, dass alles ok sein sollte, wenn ich die Web-
Parameter korrekt gesetzt habe, das clean-Skript wird jedoch vom CLI
gestartet, sodass dort natürlich andere Parameter zum Einsatz kommen können.

Gruß Jürgen
--
Mail: juergen@eisfair.org
Re: Roundcube 1.4.7 [Beitrag #68662 ist eine Antwort auf Beitrag #68656] Fri, 11 January 2019 14:50 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Marcus Roeckrath ist gerade offline  Marcus Roeckrath
Beiträge: 11676
Registriert: August 2010
Senior Member
Hallo Jürgen,

Juergen Edner wrote:

>> Habe ich gerade gemacht und beobachte, ob der Fehler heute Nacht wieder
>> auftritt.
>
> Bitte prüfe noch einmal die Konfiguration des php7-cli-Paketes. Ich
> empfehle grundsätzlich dort die gleichen Einstellungen vorzunehmen
> wie auch beim apache2_php7/php7-fpm-Paket.
> Viele Anwender glauben, dass alles ok sein sollte, wenn ich die Web-
> Parameter korrekt gesetzt habe, das clean-Skript wird jedoch vom CLI
> gestartet, sodass dort natürlich andere Parameter zum Einsatz kommen
> können.

Da hast du natürlich vollkommen recht, aber wir kämen dem Fehler auch auf
die Sprünge, wenn statt des nichtssagenden Error 255 Fehlermeldungen durch
das php-Skript ausgegeben würden.

Error 255 meint wohl:

255 is an error, I could reproduce that same exit code by having a fatal
error.

This means that somehow your error reporting is hidden, there are some
possible causes for this:

- error_reporting is not defined and php reports no error at all

- An @ (error suppression operator) hides the output of the error
STDERR is redirected somewhere else (php -f somefile.php 2>/dev/null,
remove the redirection)

- This could still be an internal error due to missing dependencies and
that a fatal error has the same exit code as a program crash.

Hast du eine Idee, wo das Error-Reporting in diesem Skriptaufruf unterbunden
wurde? Global in php7?

--
Gruss Marcus


Gruß Marcus
Re: Roundcube 1.4.7 [Beitrag #68663 ist eine Antwort auf Beitrag #68662] Fri, 11 January 2019 15:55 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Juergen Edner ist gerade offline  Juergen Edner
Beiträge: 3083
Registriert: September 2010
Senior Member
Hallo Marcus,

> Da hast du natürlich vollkommen recht, aber wir kämen dem Fehler auch auf
> die Sprünge, wenn statt des nichtssagenden Error 255 Fehlermeldungen durch
> das php-Skript ausgegeben würden.
>
> Error 255 meint wohl:
>
> 255 is an error, I could reproduce that same exit code by having a fatal
> error.

als Erstes würde ich hingehen und mit "fcrontab -e" den Aufruf des
Skriptes bearbeiten und das ">/dev/null" durch eine Umlenkung in eine
Datei ersetzen. So könnte man schauen wo es klemmt.
In den meisten Fällen gab es in der Vergangenheit Probleme weil ein
Datenbanktreiber nicht geladen bzw. gefunden wurde oder nicht auf
die Datenbank zugegriffen werden konnte, siehe hierzu:

PHP7CLI_EXT_MYSQL='yes'
PHP7CLI_EXT_MYSQL_SOCKET='/run/mysql/102/mysql.sock'
PHP7CLI_EXT_MYSQL_HOST='localhost'
PHP7CLI_EXT_MYSQL_PORT='3306'

Denkbar wäre auch noch eine fehlende Cache-Konfiguration, deshalb
schrieb ich man solle die Konfigurationen abgleichen bzw. anpassen.

Gruß Jürgen
--
Mail: juergen@eisfair.org
Re: Roundcube 1.4.7 [Beitrag #68664 ist eine Antwort auf Beitrag #68663] Fri, 11 January 2019 16:10 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Marcus Roeckrath ist gerade offline  Marcus Roeckrath
Beiträge: 11676
Registriert: August 2010
Senior Member
Hallo Jürgen,

Juergen Edner wrote:

> als Erstes würde ich hingehen und mit "fcrontab -e" den Aufruf des
> Skriptes bearbeiten und das ">/dev/null" durch eine Umlenkung in eine
> Datei ersetzen. So könnte man schauen wo es klemmt.

Leider nein, weil - siehe meine Diskussion mit ihm - auch der direkte Aufruf
des Skripts auf der Kommandozeile ohne das >/dev/null nichts außer dem 255
meldet.

> In den meisten Fällen gab es in der Vergangenheit Probleme weil ein
> Datenbanktreiber nicht geladen bzw. gefunden wurde oder nicht auf
> die Datenbank zugegriffen werden konnte, siehe hierzu:

Und deshalb möchte ich ja gerne sehen, was dem Skript nicht passt.

--
Gruss Marcus


Gruß Marcus
Re: Roundcube 1.4.7 [Beitrag #68666 ist eine Antwort auf Beitrag #68664] Fri, 11 January 2019 16:51 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Juergen Edner ist gerade offline  Juergen Edner
Beiträge: 3083
Registriert: September 2010
Senior Member
Hallo Marcus,

> Leider nein, weil - siehe meine Diskussion mit ihm - auch der direkte Aufruf
> des Skripts auf der Kommandozeile ohne das >/dev/null nichts außer dem 255
> meldet.
>
>> In den meisten Fällen gab es in der Vergangenheit Probleme weil ein
>> Datenbanktreiber nicht geladen bzw. gefunden wurde oder nicht auf
>> die Datenbank zugegriffen werden konnte, siehe hierzu:
>
> Und deshalb möchte ich ja gerne sehen, was dem Skript nicht passt.

Wünsche zu haben ist immer schön, ob diese aber erfüllt werden ;-)
Wie geschrieben, würde ich erst einmal die php7-cli Konfiguration
entsprechend der von mir genannten Punkte abklopfen. Wenn es dort
schon hakt, was ich vermute, braucht man auch keine Meldungen
angezeigt zu bekommen.
Da das Skript nur einen PHP-Funktionsaufruf durchführt, empfehle
ich als nächstes das Setzen der folgenden beiden Parameter:

ROUNDCUBE_DO_DEBUG='yes'
ROUNDCUBE_DEBUGLEVEL='8'

Anschließend sollte man detailliertere Logmeldungen in
/var/roundcube/log finden, die hoffentlich bei der Ursachenforschung helfen.

Gruß Jürgen

--
Mail: juergen@eisfair.org
Re: Roundcube 1.4.7 [Beitrag #68668 ist eine Antwort auf Beitrag #68666] Fri, 11 January 2019 17:22 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Marcus Roeckrath ist gerade offline  Marcus Roeckrath
Beiträge: 11676
Registriert: August 2010
Senior Member
Hallo Jürgen,

Juergen Edner wrote:

>> Und deshalb möchte ich ja gerne sehen, was dem Skript nicht passt.
>
> Wünsche zu haben ist immer schön, ob diese aber erfüllt werden ;-)

Wünsche?

Was würdest du sagen, wenn mein avm-fritz-toolbox.sh bei einem Problem sagt:

Ätschibätsch: Fehler!!! Ich sag aber nicht welchen! 255

> Da das Skript nur einen PHP-Funktionsaufruf durchführt, empfehle

cleandb ruft clisetup und dann eine Funktion aus rcmail_utils auf, die nun
erst die wirkliche Arbeit macht.

> ich als nächstes das Setzen der folgenden beiden Parameter:
>
> ROUNDCUBE_DO_DEBUG='yes'
> ROUNDCUBE_DEBUGLEVEL='8'

Stimmt, da sollte er mal in Roundcube-Log schauen, vielleicht wurde da auch
schon bisher etwas geloggt.

> Anschließend sollte man detailliertere Logmeldungen in
> /var/roundcube/log finden, die hoffentlich bei der Ursachenforschung
> helfen.

Exakt.

--
Gruss Marcus


Gruß Marcus
Re: Roundcube 1.4.7 [Beitrag #68679 ist eine Antwort auf Beitrag #68656] Sat, 12 January 2019 07:30 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Stefan Heidrich ist gerade offline  Stefan Heidrich
Beiträge: 567
Registriert: July 2010
Senior Member
Hallo Jürgen, hallo Marcus,

> Bitte prüfe noch einmal die Konfiguration des php7-cli-Paketes. Ich
> empfehle grundsätzlich dort die gleichen Einstellungen vorzunehmen
> wie auch beim apache2_php7/php7-fpm-Paket.
> Viele Anwender glauben, dass alles ok sein sollte, wenn ich die Web-
> Parameter korrekt gesetzt habe, das clean-Skript wird jedoch vom CLI
> gestartet, sodass dort natürlich andere Parameter zum Einsatz kommen können.

hier lag der Hund begraben. Ich wusste gar nicht, dass ich in php7-cli
noch etwas konfigurieren musste. Nachdem ich auch hier die
mySQL-Datenbank eingetragen habe funktioniert es:

# /var/www/htdocs/roundcube/bin/cleandb.sh ; echo $?
0 records deleted from 'contacts'
0 records deleted from 'contactgroups'
0 records deleted from 'identities'
0

Viele Grüße udn herzlichen Dank euch beiden
Stefan
  • Anhang: pEpkey.asc
    (Größe: 2.45KB, einmal heruntergeladen)
Re: Roundcube 1.4.7 [Beitrag #68682 ist eine Antwort auf Beitrag #68679] Sat, 12 January 2019 21:14 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Marcus Roeckrath ist gerade offline  Marcus Roeckrath
Beiträge: 11676
Registriert: August 2010
Senior Member
Hallo Stefan,

Stefan Heidrich wrote:

>> Bitte prüfe noch einmal die Konfiguration des php7-cli-Paketes. Ich
>> empfehle grundsätzlich dort die gleichen Einstellungen vorzunehmen
>> wie auch beim apache2_php7/php7-fpm-Paket.
>> Viele Anwender glauben, dass alles ok sein sollte, wenn ich die Web-
>> Parameter korrekt gesetzt habe, das clean-Skript wird jedoch vom CLI
>> gestartet, sodass dort natürlich andere Parameter zum Einsatz kommen
>> können.
>
> hier lag der Hund begraben.

Hatte Jürgen den richtigen Riecher. :-))

> Ich wusste gar nicht, dass ich in php7-cli
> noch etwas konfigurieren musste. Nachdem ich auch hier die
> mySQL-Datenbank eingetragen habe funktioniert es:

Hier werden die Einstellungen vorgenommen, die die Ausführung von
php-Programmen auf der Kommandozeile und nicht im Browser betreffen.

Danke für die Rückmeldung.

--
Gruss Marcus


Gruß Marcus
Re: Roundcube 1.4.7 [Beitrag #69479 ist eine Antwort auf Beitrag #68663] Wed, 13 February 2019 00:46 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Gasparov Taxena ist gerade offline  Gasparov Taxena
Beiträge: 35
Registriert: May 2018
Member
Hallo Jürgen,

Am 11.01.19 um 15:55 schrieb Juergen Edner:
> als Erstes würde ich hingehen und mit "fcrontab -e" den Aufruf des
> Skriptes bearbeiten und das ">/dev/null" durch eine Umlenkung in eine
> Datei ersetzen. So könnte man schauen wo es klemmt.
> In den meisten Fällen gab es in der Vergangenheit Probleme weil ein
> Datenbanktreiber nicht geladen bzw. gefunden wurde oder nicht auf
> die Datenbank zugegriffen werden konnte, siehe hierzu:
>
> PHP7CLI_EXT_MYSQL='yes'
> PHP7CLI_EXT_MYSQL_SOCKET='/run/mysql/102/mysql.sock'
> PHP7CLI_EXT_MYSQL_HOST='localhost'
> PHP7CLI_EXT_MYSQL_PORT='3306'
>
> Denkbar wäre auch noch eine fehlende Cache-Konfiguration, deshalb
> schrieb ich man solle die Konfigurationen abgleichen bzw. anpassen.

bei mir war für die email-Meldungen von fcron die fehlende Cache-Konfiguration; mit
PHP7CLI_EXT_CACHE='redis'
bleiben die Meldungen aus.

Gerade weil es keine Variable PHP5CCPP_EXT_CACHE (sowie PHP5CCPP-Variablen für die DBen gibt) wäre bei der
Installation von php7-cli ein diesbezüglicher Hinweis (Harmonisierung der Variablen der Pakete php7-cli,
apache2_php7 und php5_ccpp evtl. notwendig) hilfreich. *grübel* Oder ein Warnhinweis in
roundcoube-Konfiguration, falls PHP7CLI_EXT_CACHE und PHP7CLI_EXT_MYSQL nicht gesetzt sind?

Dank
Taxi
Re: Roundcube 1.4.7 [Beitrag #69485 ist eine Antwort auf Beitrag #69479] Wed, 13 February 2019 09:23 Zum vorherigen Beitrag gehen
Juergen Edner ist gerade offline  Juergen Edner
Beiträge: 3083
Registriert: September 2010
Senior Member
Hallo Taxi,

> bei mir war für die email-Meldungen von fcron die fehlende Cache-Konfiguration; mit
> PHP7CLI_EXT_CACHE='redis'
> bleiben die Meldungen aus.
>
> Gerade weil es keine Variable PHP5CCPP_EXT_CACHE (sowie PHP5CCPP-Variablen für die DBen gibt) wäre bei der
> Installation von php7-cli ein diesbezüglicher Hinweis (Harmonisierung der Variablen der Pakete php7-cli,
> apache2_php7 und php5_ccpp evtl. notwendig) hilfreich. *grübel* Oder ein Warnhinweis in
> roundcoube-Konfiguration, falls PHP7CLI_EXT_CACHE und PHP7CLI_EXT_MYSQL nicht gesetzt sind?

danke für die Anregung, es gibt immer Spielraum um die Abläufe noch
zu optimieren. In den PHP7-Paketen wurden die Parameter bereits von
Sebastian angeglichen.
Das php5_ccpp-Paket wird aber keine Anpassung mehr erfahren und über
kurz oder lang von Pack-Eis verschwinden, da PHP5 schon länger nicht
mehr unterstützt und gepflegt wird.

Gruß Jürgen

--
Mail: juergen@eisfair.org
Vorheriges Thema: [eis64] fehlende Abhängigkeit bei Samba / Ghostscript?
Nächstes Thema: MAC Adresse ändern
Gehe zum Forum:
  


aktuelle Zeit: Sun Mar 24 23:25:09 CET 2019

Insgesamt benötigte Zeit, um die Seite zu erzeugen: 0.05853 Sekunden