net(t)forum
net(t)work(s) - fli4l - eisfair

Startseite » fli4l » spline.fli4l » HUP timeout 0 FLI legt aber dennoch auf.
HUP timeout 0 FLI legt aber dennoch auf. [Beitrag #68012] Fri, 30 November 2018 15:37 Zum nächsten Beitrag gehen
kay ist gerade offline  kay
Beiträge: 539
Registriert: July 2016
Senior Member
Hallo

ich bin noch bei FLI 3.10.12 und nutze DSL mit PPPOE_HUP_Timeout='0'
Aber immer wieder mal legt der FLI dennoch auf. Eben wieder und das
merkwürdige daran ist das ein timeout wegen inaktivität mir sehr
unwahrscheinlich vorkommt.

Kann es daran liegen das ich PPPOE_FILTER an hab, aber keine
Filtereinträge? Hat die PPPOE_TYPE='in_kernel' hier evtl. relevanz?

In der Doku fand ich eine Symptombeschreibung zur NF_MSS Option die mir
bekannt vor kommt. Die Option war nicht drin. Ich hab sie jetzt mal mit
'1412' belegt eingetragen, Debug aktiviert und werde gleich mal neu
starten.

Wie bekomme ich eigentlich raus ob der Provider (T-Com) eine Vorgabe für
Maximum-Segmentsize macht, und wie die lautet?


Kay

--
Sent via SN (Eisfair-1)
Re: HUP timeout 0 FLI legt aber dennoch auf. [Beitrag #68028 ist eine Antwort auf Beitrag #68012] Sat, 01 December 2018 10:47 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Jill Leyden ist gerade offline  Jill Leyden
Beiträge: 18
Registriert: January 2011
Junior Member
Am 30.11.2018 um 15:37 schrieb Kay Martinen:
> Hallo
>
> ich bin noch bei FLI 3.10.12 und nutze DSL mit PPPOE_HUP_Timeout='0'
> Aber immer wieder mal legt der FLI dennoch auf. Eben wieder und das
> merkwürdige daran ist das ein timeout wegen inaktivität mir sehr
> unwahrscheinlich vorkommt.
>
> Kann es daran liegen das ich PPPOE_FILTER an hab, aber keine
> Filtereinträge? Hat die PPPOE_TYPE='in_kernel' hier evtl. relevanz?
>
> In der Doku fand ich eine Symptombeschreibung zur NF_MSS Option die mir
> bekannt vor kommt. Die Option war nicht drin. Ich hab sie jetzt mal mit
> '1412' belegt eingetragen, Debug aktiviert und werde gleich mal neu
> starten.
>
> Wie bekomme ich eigentlich raus ob der Provider (T-Com) eine Vorgabe für
> Maximum-Segmentsize macht, und wie die lautet?
>
>
> Kay
>

Bin auch bei der Telekom. Nicht der Fli4l legt auf, sondern die Telekom.
Bei mir war früher alle 24 Stunden auch die Zwangstrennung.

Als ich noch echtes ISDN und eine kleine DSL-Leitung hatte gab es
unplanmäßige Trennungen nicht oft, 1-2 mal im Jahr.
Der neue VDSL-Schrott mit VoIP kann in mancher Woche fast jeden Tag die
Verbindung unterbrechen. Auch mehrmals am Tag.

Bei mir ist es der Speedport Router. Der findet seinen IPV6-DNS nicht
oder hängt sich auf, wenn er einige Stunden oder 2 Tage in Betrieb ist
und eine Seite anläuft.

IPV6 habe ich an der PC Netzwerkkarte deaktiviert, weil ich den Rechner
nicht gern nach außen personifiziere und der Rechner auch kaum Seiten
findet, weil der Router seine Arbeit nicht richtig macht.

Beim alten Fli4l habe ich diese Einstellung benutzt

PPPOE_MTU='1450' # set MTU for PPPOE connection 1492
PPPOE_MRU='1492' # set MRU for PPPOE connection

Die Vorgaben gab es im Internet zu allen Providern.
Der Fli4l ist seit einem Jahr stillgelegt. Weil der Speedport keine ISDN
Buchsen hat, folglich so einiges nicht funktioniert.


Fridrich
Re: HUP timeout 0 FLI legt aber dennoch auf. [Beitrag #68032 ist eine Antwort auf Beitrag #68028] Sat, 01 December 2018 20:18 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
kay ist gerade offline  kay
Beiträge: 539
Registriert: July 2016
Senior Member
Am 01.12.2018 um 10:47 schrieb Jill Leyden:
> Am 30.11.2018 um 15:37 schrieb Kay Martinen:
>>
>> ich bin noch bei FLI 3.10.12 und nutze DSL mit PPPOE_HUP_Timeout='0'
>
> Bin auch bei der Telekom. Nicht der Fli4l legt auf, sondern die Telekom.
> Bei mir war früher alle 24 Stunden auch die Zwangstrennung.

Mift! Du hast Recht. Ich schaute eben nach längere Zeit mal ins
Verbindungslog. Und jetzt fällt mir auf/ein das ich früher immer die
Trennung um mitternacht per cron machen ließ. Das muß ich irgendwann bei
einem Versionswechsel verschlumpft haben und das log zeigt das teils gg.
3 uhr nachts, teils gg. 15:30 die Zwangstrennung zuschlug (nach 23:59:xx
Onlinezeit) -> Frage geklärt!

>
> Als ich noch echtes ISDN und eine kleine DSL-Leitung hatte gab es
> unplanmäßige Trennungen nicht oft, 1-2 mal im Jahr.

Hier auch, so selten.

> Der neue VDSL-Schrott mit VoIP kann in mancher Woche fast jeden Tag die
> Verbindung unterbrechen. Auch mehrmals am Tag.

Toller Fortschritt oder? Da bin ich gespannt was mir mit Hybrid für
ungemach droht. Bis jetzt hänge ich auf einem RAM Port der mir bis zu
2Mbit liefern kann. Wenn die den beim Wechsel raus werfen würden bliebe
auf der Strecke nur noch bis zu 0,4Mbit als Maximum und die LTE-Strecke
muß den Löwenanteil wuppen. Was wieder an vielem hängen kann...


> Bei mir ist es der Speedport Router. Der findet seinen IPV6-DNS nicht
> oder hängt sich auf, wenn er einige Stunden oder 2 Tage in Betrieb ist
> und eine Seite anläuft.

Wäre doch schön; und praktisch; wenn man einen Speedport per script
automatisch neu starten lassen könnte oder? Leider werden die Teile wohl
nur ein Webinterface haben. Aber kein ssh o.a. also wird es wohl nicht
gehen, oder nur mit umständlichstem gebastel.

Mein D-Link Modem hat wenigsten Telnet aber das kann ich dafür nicht
mehr verwenden.

> IPV6 habe ich an der PC Netzwerkkarte deaktiviert, weil ich den Rechner
> nicht gern nach außen personifiziere und der Rechner auch kaum Seiten
> findet, weil der Router seine Arbeit nicht richtig macht.

Der FLI sollte IPv6 doch blockieren (können) wenn du es nicht nutzt. Und
wenn du keinen tunnel dafür einrichtest dürfte IPv6 im LAN egal sein
weil es eh nicht raus kann. Oder?

Personifizieren können die Tracker deinen PC eh wenn du damit im Web
surftst. Da brauchen die nicht unbedingt IPv6.

> Beim alten Fli4l habe ich diese Einstellung benutzt
>
> PPPOE_MTU='1450'        # set MTU for PPPOE connection  1492
> PPPOE_MRU='1492'        # set MRU for PPPOE connection

Das sieht anders aus als bei mir.

> Die Vorgaben gab es im Internet zu allen Providern.

Echt, wo das? Und für alle gleich oder je nach dem?

> Der Fli4l ist seit einem Jahr stillgelegt. Weil der Speedport keine ISDN
> Buchsen hat, folglich so einiges nicht funktioniert.

Es gibt ja ISDN-Adapter. Aber wenn es eh via VoIP rein kommt nützt es
weniger als früher.


Kay

--
Sent via SN (Eisfair-1)
Re: HUP timeout 0 FLI legt aber dennoch auf. [Beitrag #68033 ist eine Antwort auf Beitrag #68032] Sat, 01 December 2018 20:37 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
LanSpezi
Beiträge: 1024
Registriert: August 2010
Senior Member
Hi Kay,

Am Sat, 1 Dec 2018 20:18:11 +0100 schrieb Kay Martinen:

> Am 01.12.2018 um 10:47 schrieb Jill Leyden:
>> Am 30.11.2018 um 15:37 schrieb Kay Martinen:
>>>
>>> ich bin noch bei FLI 3.10.12 und nutze DSL mit PPPOE_HUP_Timeout='0'
>>
>> Bin auch bei der Telekom. Nicht der Fli4l legt auf, sondern die Telekom.
>> Bei mir war früher alle 24 Stunden auch die Zwangstrennung.
>
> Mift! Du hast Recht. Ich schaute eben nach längere Zeit mal ins
> Verbindungslog. Und jetzt fällt mir auf/ein das ich früher immer die
> Trennung um mitternacht per cron machen ließ. Das muß ich irgendwann bei
> einem Versionswechsel verschlumpft haben und das log zeigt das teils gg.
> 3 uhr nachts, teils gg. 15:30 die Zwangstrennung zuschlug (nach 23:59:xx
> Onlinezeit) -> Frage geklärt!

ich habe bei mir
EASYCRON_1_COMMAND='fli4lctrl hangup pppoe; sleep 5; fli4lctrl dial pppoe'
EASYCRON_1_CUSTOM=''
EASYCRON_1_TIME='3 1 * * *'

und somit einen festen Zeitpunk für die Zwangstrennung

>> Der neue VDSL-Schrott mit VoIP kann in mancher Woche fast jeden Tag die
>> Verbindung unterbrechen. Auch mehrmals am Tag.

kann ich hier nicht nachvollziehen (ohne den EASYCRON hatte ich meist
1Woche ohne Trennung)

> Mein D-Link Modem hat wenigsten Telnet aber das kann ich dafür nicht
> mehr verwenden.

ich hab das Vigor130 im Einsatz (als Modem konfiguriert - PPPOE macht der
fli4l)

> Es gibt ja ISDN-Adapter. Aber wenn es eh via VoIP rein kommt nützt es
> weniger als früher.

ich hab dafür hier eine Auerswald Compact 3000 Voip im Einsatz, die koppelt
analoge und ISDN Geräte an Voip.


Gruß Peter
Re: HUP timeout 0 FLI legt aber dennoch auf. [Beitrag #68035 ist eine Antwort auf Beitrag #68032] Sat, 01 December 2018 22:48 Zum vorherigen Beitrag gehen
Jill Leyden ist gerade offline  Jill Leyden
Beiträge: 18
Registriert: January 2011
Junior Member
Am 01.12.2018 um 20:18 schrieb Kay Martinen:
> Am 01.12.2018 um 10:47 schrieb Jill Leyden:
>>
>> Bin auch bei der Telekom. Nicht der Fli4l legt auf, sondern die Telekom.
>> Bei mir war früher alle 24 Stunden auch die Zwangstrennung.
>
> Mift! Du hast Recht. Ich schaute eben nach längere Zeit mal ins
> Verbindungslog. Und jetzt fällt mir auf/ein das ich früher immer die
> Trennung um mitternacht per cron machen ließ. Das muß ich irgendwann bei
> einem Versionswechsel verschlumpft haben und das log zeigt das teils gg.
> 3 uhr nachts, teils gg. 15:30 die Zwangstrennung zuschlug (nach 23:59:xx
> Onlinezeit) -> Frage geklärt!

Bei mir wird bei VDSL alle drei Tage nach 03:15h getrennt, vorausgesetzt
es gibt keine Störungen auf der Leitung.

Ich könnte das auch durchlaufen lassen, quasi als Feste IP, aber damit macht
man nur die Seitenbetreiber aufmerksam, die sammeln die IP Adressen.
Zudem ist der Router dann für Hacker interessant.

>
>> Der neue VDSL-Schrott mit VoIP kann in mancher Woche fast jeden Tag die
>> Verbindung unterbrechen. Auch mehrmals am Tag.
>
> Toller Fortschritt oder? Da bin ich gespannt was mir mit Hybrid für
> ungemach droht. Bis jetzt hänge ich auf einem RAM Port der mir bis zu
> 2Mbit liefern kann. Wenn die den beim Wechsel raus werfen würden bliebe
> auf der Strecke nur noch bis zu 0,4Mbit als Maximum und die LTE-Strecke
> muß den Löwenanteil wuppen. Was wieder an vielem hängen kann...

Habe man nach einigen Jahren bei Bekannten dieses Jahr angerufen. Die
hatten damals um die flotten 0,8 Mbit im Ortsteil. Dafür war das
Telefonieren nicht gestört.

Telekom konnte denen nur eine 1,5Mbit RAM anbieten, also Wackelleitung
und VoIP. Wollten sie nicht.

Jetzt haben sie LTE und eine gute Bandbreite.>
>
>> Bei mir ist es der Speedport Router. Der findet seinen IPV6-DNS nicht
>> oder hängt sich auf, wenn er einige Stunden oder 2 Tage in Betrieb ist
>> und eine Seite anläuft.
>
> Wäre doch schön; und praktisch; wenn man einen Speedport per script
> automatisch neu starten lassen könnte oder? Leider werden die Teile wohl
> nur ein Webinterface haben. Aber kein ssh o.a. also wird es wohl nicht
> gehen, oder nur mit umständlichstem gebastel.

Wozu automatisch starten lassen?

Bei einem solchen Soft-Reset fährt alles runter.
WLAN, Telefonie und Internet. Das Gerät ist dann 2 Minuten nicht
betriebsbereit.

Bei einer banalen Trennung und neu Einwahl vergehen Sekunden.
Das macht die Kiste selber, wenn sie entsprechend konfiguriert
wurde. Siehe fast am Schuss des Postings. Sicherheitsregeln.

Beim Speedport läuft auch ein Linux drauf.
Man kann den Port 22 im Webinterface freischalten.
Dazu muss man eine neue Portregel generieren.
Das Protokoll wäre tcp, Port 22 als Client oder/und öffentlich.
Danach muss man sich durch das dortige Linux hangeln.

>
> Mein D-Link Modem hat wenigsten Telnet aber das kann ich dafür nicht
> mehr verwenden.
>
>> IPV6 habe ich an der PC Netzwerkkarte deaktiviert, weil ich den Rechner
>> nicht gern nach außen personifiziere und der Rechner auch kaum Seiten
>> findet, weil der Router seine Arbeit nicht richtig macht.
>
> Der FLI sollte IPv6 doch blockieren (können) wenn du es nicht nutzt. Und
> wenn du keinen tunnel dafür einrichtest dürfte IPv6 im LAN egal sein
> weil es eh nicht raus kann. Oder?

Der Fli hier ist seit der Umstellung 02/17 auf die schnellere Leitung
stillgelegt.Ist noch ein alter 3.0.1 mit vielen alten opts, die auf den
neuen Versionen
gar nicht mehr existieren oder in anderen opts integriert sind.
Da habe ich damals auch kein IPv6 opt installiert.

Wir wurden hier schon von den Entwicklern oft gefragt, ob wir nicht
modernisieren wollten. Jedes mal ändern sich die Firewallregeln oder es
migrieren gern genutzte opts bzw. sie fallen ganz weg.

Zudem lief dort auch ein Squid, wegen der kleinen Leitung. Wird auch nicht
gern gesehen. Der Fli4l sollte eine reine Routerfunktion sein.

Dazu hätte man auf dem PC ein Linux installieren müssen, entsprechend
Arbeitsspeicher rein, den Fli und einen Eis in jeweils eine VM packen und
gut wäre es gewesen.

Der alte Fli konnte nur IPv4. Hat eine PCI-ISDN-Karte. Das war die
ganzen Jahrepraktisch wenn jemand anrief, hatte man die Nummer und den
Namen auf dem
PC-Monitor. Dazu hatte er einen AB.

Ich kann den Imonc und den ISDN Monitor nicht nutzen, weil dieser Speedport
nur 2 analoge Telefonanschlüsse hat,andenen zwei Tgelefone sitzen.
Für das größere Modell mit ISDN Port
wollten sie 80 Euro Draufgeld oder höhere monatliche Mietgebühr.

>
> Personifizieren können die Tracker deinen PC eh wenn du damit im Web
> surftst. Da brauchen die nicht unbedingt IPv6.

Dagegen haben wir im Browser entsprechende Tools und Cookies werden
bei jedem schließen des Browsers gelöscht.
IPv6 ist noch unnötig.
Solange die Telekom ihre fehlerhaften Programmierungen in den Routern
nicht ändern will oder kann, bleibt es aus.

>
>> Beim alten Fli4l habe ich diese Einstellung benutzt
>>
>> PPPOE_MTU='1450'        # set MTU for PPPOE connection  1492
>> PPPOE_MRU='1492'        # set MRU for PPPOE connection
>
> Das sieht anders aus als bei mir.
>
>> Die Vorgaben gab es im Internet zu allen Providern.
>
> Echt, wo das? Und für alle gleich oder je nach dem?

Nicht gleich, teils unterschiedlich. Vermutlich heute unerheblich, weil
das Einstellen an der MTU bei den schnelleren Angeboten heute nichts an
Effektivität bringt. Standard ist 1500. Spielt bei einer 16er oder 50er
Leitung keine Musik.
> http://www.nwlab.net/art/mtu/mtu.html

War damals eben so.
>
>> Der Fli4l ist seit einem Jahr stillgelegt. Weil der Speedport keine ISDN
>> Buchsen hat, folglich so einiges nicht funktioniert.
>
> Es gibt ja ISDN-Adapter. Aber wenn es eh via VoIP rein kommt nützt es
> weniger als früher.

Der Anschluss hat 5 Rufnummern. Uns gings dabei um 2 Leitungen,
verschiedenen
zu zuordneten Rufnummern und ein analoges Fax zum benutzen.
Ankommende Faxe gingen papierlos auf den Fli4l.

Mit einem Router mit ISDN-Buchsen wäre das wieder kein Problem,
den Fli mit der ISDN-Karte dran zu hängen.
Ehrlich gesagt der ganze Zoo ist jetzt stromlos. Faxn muss keiner mehr.
NTBA, AVM-ISDN Telefonanlage mit 4 Analoganschlüssen. Fli4l-PC. Zz.
alten WLAN-Router als Accesspoint für WLAN. Alles aus und teilweise
abgebaut, weil auch schon sehr alt.

Der heutige Router macht keinen Lärm, keine große Hitze, frisst wenig Strom.
Irgendwann kommt eine gekaufte Frizbox mit ISDN Buchsen ins Hau. Dann wird
vielleicht der alte PC neu aufgesetzt oder wir steigen auf die kleinen
ARM Platinen um. Die brauchen auch nur ein paar Watt.
Theoretisch könnte man einen alten NAS dafür knechten.

Nochmal zu den Trennungszeiten bei der Telekom.
Alte DSL Anschlüsse (DSL2000 bis 6000) alle 24 Stunden.

Es ist auch nicht nötig den timeout auf 5 Sekunden einzustellen.
Es kommt immer eine neue IP nach der Trennung vom Provider.
Hatten Jahrelang den Timeout auf 0.

Der Router meldet ab und wählt gleich darauf wieder ein, bekommt die
neue IP.
Hatten unseren auf jeweils 12 Stunden also 2 IPs am Tag eingestellt.
Morgens und 6:00h und Abends um 18:00h. Telefon lief ja damals
störungsfrei und abhörsicher getrennt über den Splitter.

VDSL Telekom: Entweder Sicherheitsstufe 1 alle 24 Stunden (IPV4),
Sicherheitsstufe 2, alle 3 Tage Trennung und neue IPv4 und IPv6 Adresse.

Oder Sicherheitsstufe 0, keine Trennung. Also Hackerparadis aus aller Welt.

>
>
> Kay
>

J & F
Vorheriges Thema: Informationen zu den wöchentlichen 3.10-Archiven vom 30.11.2018 (r54516)
Nächstes Thema: stubby für fli4l
Gehe zum Forum:
  


aktuelle Zeit: Sat Feb 23 00:10:18 CET 2019

Insgesamt benötigte Zeit, um die Seite zu erzeugen: 0.01506 Sekunden