net(t)forum
net(t)work(s) - fli4l - eisfair

Startseite » eisfair » spline.eisfair » nextcloud 1.5.4 update fehlgeschlagen - Webverzechnis leer
nextcloud 1.5.4 update fehlgeschlagen - Webverzechnis leer [Beitrag #68586] Tue, 08 January 2019 22:56 Zum nächsten Beitrag gehen
Adrian.T ist gerade offline  Adrian.T
Beiträge: 5
Registriert: December 2015
Junior Member
Hallo zusammen,

das nextcloud 1.5.4 Update hat bei mir leider nicht geklappt.
Nach der Installation ist das nextcloud Webverzeichnis leer, nur apps2 ist vorhanden:

eis # ls -l /var/www/htdocs/nextcloud/
total 4
drwxr-x--- 6 wwwrun nogroup 4096 Jan 5 16:47 apps2




Die nextcloud Config bringt folgende Fehler:

Activate configuration now (y/n) [yes]?
nextcloud version: v1.5.2
Database type : mysql (mariadb102)
Database server: localhost:3306
Trusted domain(s): XXXXXXXXXXXXXXXX
Apache2 SSL support: enabled
MySQL PHP7 support: enabled
MySQL support: enabled
MySQL binary logging: disabled
Mail support: enabled
APC PHP7 cache: enabled
PHP7-WEB memory limit: >= 512M
PHP7-CLI memory limit: >= 512M
PHP7-CLI configuration access: possible
PHP7-WEB IMAGICK module: not found (/usr/lib64/php7/extensions/imagick.so)
PHP7-CLI IMAGICK module: not found (/usr/lib64/php7/extensions/imagick.so)
PHP7-WEB INTL module: not found (/usr/lib64/php7/extensions/intl.so)
PHP7-CLI INTL module: not found (/usr/lib64/php7/extensions/intl.so)
PHP7-WEB OPCACHE module: not found (/usr/lib64/php7/extensions/opcache.so)
PHP7-CLI OPCACHE module: not found (/usr/lib64/php7/extensions/opcache.so)
PHP7-WEB PCNTL module: not found (/usr/lib64/php7/extensions/pcntl.so)
PHP7-CLI PCNTL module: not found (/usr/lib64/php7/extensions/pcntl.so)
PHP pre-requisites not met, fix it and re-run configuration!




Das lib64/php7 Verzeichnis ist nicht vorhanden:
eis # ls -l /usr/lib64/php7
ls: cannot access '/usr/lib64/php7': No such file or directory




Der gesamte Installationsverlauf:

Downloading required packages ...
=> [####################] apache2-data (2.1.0)... [ OK ]
=> [####################] apache2 (2.1.0)... [ OK ]
Done!
Installation of: apache2-data (2.1.0) ...
Successfully installed: apache2-data (2.1.0)!
Installation of: apache2 (2.1.0) ...
* Stopping Apache ... [ OK ]
Creating Apache2 configuration ...
activating modules...
done activating modules
/var/install/config.d/apache2_php7.sh: line 85: /usr/local/apache2/bin/httpd: No such file or directory

The installed package, 'apache2_php7', works only
for a Apache2 package that has been included
the httpd version '2.xx'.

Please install the recent version.

* Disabling subversion WebDAV access ... [ OK ]
* Starting Apache ... [ OK ]
Successfully installed: apache2 (2.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-common (1.1.0)... [ OK ]
=> [####################] apache2_php7 (1.1.0)... [ OK ]
Done!
Installation of: php7-common (1.1.0) ...
Successfully installed: php7-common (1.1.0)!
Installation of: apache2_php7 (1.1.0) ...
Creating (default) PHP7 configuration...
Creating Apache2 configuration ...
activating modules...
done activating modules
* Disabling subversion WebDAV access ... [ OK ]
* Stopping Apache ... [ OK ]
* Starting Apache ... [ OK ]
Successfully installed: apache2_php7 (1.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-apcu (1.1.0)... [ OK ]
Done!
Installation of: php7-apcu (1.1.0) ...
Successfully installed: php7-apcu (1.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-cli (1.1.0)... [ OK ]
Done!
Installation of: php7-cli (1.1.0) ...
Creating PHP7-CLI configuration ...
Successfully installed: php7-cli (1.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-imagick (1.1.0)... [ OK ]
Done!
Installation of: php7-imagick (1.1.0) ...
Successfully installed: php7-imagick (1.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-intl (1.1.0)... [ OK ]
Done!
Installation of: php7-intl (1.1.0) ...
Successfully installed: php7-intl (1.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-mysql (1.1.0)... [ OK ]
Done!
Installation of: php7-mysql (1.1.0) ...
Successfully installed: php7-mysql (1.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-pcntl (1.1.0)... [ OK ]
Done!
Installation of: php7-pcntl (1.1.0) ...
Successfully installed: php7-pcntl (1.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-pdflib (1.1.0)... [ OK ]
Done!
Installation of: php7-pdflib (1.1.0) ...
Successfully installed: php7-pdflib (1.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-redis (1.1.0)... [ OK ]
Done!
Installation of: php7-redis (1.1.0) ...
Successfully installed: php7-redis (1.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-xz (1.1.0)... [ OK ]
Done!
Installation of: php7-xz (1.1.0) ...
Successfully installed: php7-xz (1.1.0)!
Press ENTER to continue
Downloading required packages ...
=> [####################] php7-opcache (1.1.0)... [ OK ]
=> [####################] nextcloud (1.5.2)... [ OK ]
Done!
Installation of: php7-opcache (1.1.0) ...
Successfully installed: php7-opcache (1.1.0)!
Installation of: nextcloud (1.5.2) ...
nextcloud maintenance mode: enabled
nextcloud maintenance mode: enabled
removing program files ...
wait [ ................................................... ]
wait [ ................................................... ]
wait [ ................................................... ]
wait [ ................................................... ]
wait [ ................................................... ]
wait [ ................................................... ]
wait [ ................................................... ]
wait [ ................................................... ]
wait [ ....................... ]

loading previous configuration file ...
Successfully installed: nextcloud (1.5.2)!
Press ENTER to continue



Ich habe die Configs der pakete apache2, php7, php7-cli und mysql neu erstellt, alle sind jeweils ohne Fehler durchgelaufen.
Die nextcloud Config bleibt aber hängen.

Vorab vielen dank für Tipps.

Grüße
Adrian
Re: nextcloud 1.5.4 update fehlgeschlagen - Webverzechnis leer [Beitrag #68587 ist eine Antwort auf Beitrag #68586] Tue, 08 January 2019 23:25 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Holger Bruenjes ist gerade offline  Holger Bruenjes
Beiträge: 4694
Registriert: July 2010
Senior Member
Hallo Adrian

Am 08/01/2019 um 22.56 schrieb Adrian T:

> Ich habe die Configs der pakete apache2, php7, php7-cli und mysql neu
> erstellt, alle sind jeweils ohne Fehler durchgelaufen.
> Die nextcloud Config bleibt aber hängen.
>
> Vorab vielen dank für Tipps.

Als Sofortmassnahme in

/var/install/config.d/nextcloud.sh


suche nach '/usr/lib64/'

ca. Zeile 275

und entferne daraus die 64

/usr/lib/

Holger
Aw: Re: nextcloud 1.5.4 update fehlgeschlagen - Webverzechnis leer [Beitrag #68588 ist eine Antwort auf Beitrag #68587] Wed, 09 January 2019 00:04 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Adrian.T ist gerade offline  Adrian.T
Beiträge: 5
Registriert: December 2015
Junior Member
Hallo Holger,

es sieht jetzt zwar besser aus, aber die Config läuft trotzdem noch nicht fehlerfrei durch:


Activate configuration now (y/n) [yes]?
nextcloud version: v1.5.2
Database type : mysql (mariadb102)
Database server: localhost:3306
Trusted domain(s): XXXX
Apache2 SSL support: enabled
MySQL PHP7 support: enabled
MySQL support: enabled
MySQL binary logging: disabled
Mail support: enabled
APC PHP7 cache: enabled
PHP7-WEB memory limit: >= 512M
PHP7-CLI memory limit: >= 512M
PHP7-CLI configuration access: possible
PHP7-WEB IMAGICK module: enabled, but not loaded!
PHP7-CLI IMAGICK module: enabled
PHP7-WEB INTL module: enabled, but not loaded!
PHP7-CLI INTL module: enabled
PHP7-WEB OPCACHE module: enabled, but not loaded!
PHP7-CLI OPCACHE module: enabled
PHP7-WEB PCNTL module: enabled, but not loaded!
PHP7-CLI PCNTL module: enabled
PHP pre-requisites not met, fix it and re-run configuration!



Grüße
Adrian
Re: nextcloud 1.5.4 update fehlgeschlagen - Webverzechnis leer [Beitrag #68595 ist eine Antwort auf Beitrag #68588] Wed, 09 January 2019 09:46 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Juergen Edner ist gerade offline  Juergen Edner
Beiträge: 3057
Registriert: September 2010
Senior Member
Hallo Adrian,

> es sieht jetzt zwar besser aus, aber die Config läuft trotzdem
> noch nicht fehlerfrei durch:
>
> PHP7-WEB IMAGICK module: enabled, but not loaded!
> PHP7-CLI IMAGICK module: enabled
> PHP7-WEB INTL module: enabled, but not loaded!
> PHP7-CLI INTL module: enabled
> PHP7-WEB OPCACHE module: enabled, but not loaded!
> PHP7-CLI OPCACHE module: enabled
> PHP7-WEB PCNTL module: enabled, but not loaded!
> PHP7-CLI PCNTL module: enabled
> PHP pre-requisites not met, fix it and re-run configuration!

beim Erstellen der PHP7-Modulpakete wurde leider vergessen die
erforderliche Konfigurationsdatei einzupacken. Durch die heute
Nacht veröffentlichten Paketversion 1.1.1 sollte diese Problem
gelöst werden.
Darüber nutzt Du eisfair-64 (eisfair-1 hat dieses Problem nicht),
wo der Webserver fälschlicherweise seine Moduldateien in
/usr/lib/php7/20170718 an Stelle von /usr/lib/php7/extensions zu suchen
scheint.
Dies kannst Du ganz einfach prüfen, indem Du in der
apache2_php7-Konfiguration den Parameter PHP7_INFO='yes' setzt und dann
über den Webbrowser http://<server>/info.php abrufst. Dort sollte sich dann
der falsche Pfad unter "Scan this dir for additional .ini files"
finden.
Wenn dem so ist, kannst Du als Workaround folgenden symbolischen
Link setzen. Sobald Sebastian das Problem gelöst hat muss dann
dieser symbolische Link wieder entfernt werden.

ln -s /etc/php7/apache2/conf.d/eisfiar.ini /etc/php7/conf.d/eisfair.ini

Gruß Jürgen

--
Mail: juergen@eisfair.org
Aw: Re: nextcloud 1.5.4 update fehlgeschlagen - Webverzechnis leer [Beitrag #68617 ist eine Antwort auf Beitrag #68595] Wed, 09 January 2019 21:05 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Adrian.T ist gerade offline  Adrian.T
Beiträge: 5
Registriert: December 2015
Junior Member
Hallo Jürgen,

vielen Dank für deine Hilfe.
Jetzt läuft nextcloud wieder. Smile

Ausgabe von info.php war:
Scan this dir for additional .ini files /etc/php7/conf.d

Den Link konnte ich erst setzen, nachdem ich vorher /etc/php7/conf.d/eisfair.ini (die vom 2.1.18 war) gelöscht habe.

Gruß
Adrian
Re: nextcloud 1.5.4 update fehlgeschlagen - Webverzechnis leer [Beitrag #68618 ist eine Antwort auf Beitrag #68617] Wed, 09 January 2019 21:08 Zum vorherigen Beitrag gehen
Juergen Edner ist gerade offline  Juergen Edner
Beiträge: 3057
Registriert: September 2010
Senior Member
Hallo Adrian,

> vielen Dank für deine Hilfe.
> Jetzt läuft nextcloud wieder. :)
>
> Ausgabe von info.php war:
> Scan this dir for additional .ini files /etc/php7/conf.d
>
> Den Link konnte ich erst setzen, nachdem ich vorher
> /etc/php7/conf.d/eisfair.ini (die vom 2.1.18 war) gelöscht habe.

danke für die Rückmeldung. Sobald Sebastian das Problem mit dem
Erweiterungspfad im apache2_php7-Paket für eisfair-64 gelöst hat,
muss dieser Link dann wieder gelöscht werden.

Gruß Jürgen
--
Mail: juergen@eisfair.org
Vorheriges Thema: Neue Version von apache2_php7 und den php7-* Paketen
Nächstes Thema: [Eisfair-1] Apache 2, PHP 7: Syntax error beim Laden von Apache
Gehe zum Forum:
  


aktuelle Zeit: Sat Feb 23 00:06:46 CET 2019

Insgesamt benötigte Zeit, um die Seite zu erzeugen: 0.02375 Sekunden