net(t)forum
net(t)work(s) - fli4l - eisfair

Startseite » fli4l » spline.fli4l » Fli4l 4.0.0 auf WRAP/ALIX.2 Bootet nicht zu Ende
Fli4l 4.0.0 auf WRAP/ALIX.2 Bootet nicht zu Ende [Beitrag #68898] Tue, 22 January 2019 08:42 Zum nächsten Beitrag gehen
Friedhold Schuster ist gerade offline  Friedhold Schuster
Beiträge: 416
Registriert: October 2011
Senior Member
Hallo an alle,
weiter gehts, Schweißabwisch.....
ich ging davon aus, einen WRAP zu benutzen, aber es ist ein ALIX.
also

OPT_HWSUPP='yes'
HWSUPP_TYPE='pcengines-alix'

danach das Problem mit cron gelöst (schulterklopf).

hier meine alte 3.6 rc.cfg auf dem ALIX, die funktioniert:
------------------------------------------------------------
AUTO='99'
BASE='yes'
HOSTNAME='fli4l'
PASSWORD='xxxxx'
BOOT_TYPE='hd'
MOUNT_BOOT='rw'
BOOTMENU_TIME='20'
TIME_INFO='MEZ-1MESZ,M3.5.0,M10.5.0/3'
KERNEL_VERSION='2.6.16.62'
KERNEL_BOOT_OPTION='nokbd reboot=bios'
COMP_TYPE_KERNEL='lzma'
COMP_TYPE_ROOTFS='lzma'
COMP_TYPE_OPT='lzma'
IP_CONNTRACK_MAX=''
POWERMANAGEMENT='none'
..
..
..
OPT_MAKEKBL='no'
NET_DRV_N='2'
NET_DRV_1='via-rhine'
NET_DRV_1_OPTION=''
NET_DRV_2='ath_pci'
NET_DRV_2_OPTION='countrycode=276'
IP_NET_N='1'
IP_NET_1='172.18.2.99/24'
IP_NET_1_DEV='eth1'

------------------------------------------------------------

Dazu meine base.txt auf dem 4.0.0 (soll Ethernet-Router werden)

------------------------------------------------------------

HOSTNAME='fli4l'
PASSWORD='xxxxx'
BOOT_TYPE='hd'
LIBATA_DMA='disabled'
MOUNT_BOOT='rw'
BOOTMENU_TIME='20'
TIME_INFO='MEZ-1MESZ,M3.5.0,M10.5.0/3'
RTC_SYNC='hwclock'
KERNEL_VERSION='4.4.169'
KERNEL_BOOT_OPTION='nokbd reboot=bios'
COMP_TYPE_OPT='lzma'
IP_CONNTRACK_MAX=''
POWERMANAGEMENT='none'


NET_DRV[]='via-rhine'
{
OPTION=''
}
..
..
..
# Networks für Ethernet-Router:
OPT_IPV4='yes'
IP_NET[1]='172.18.1.99/24'
{
DEV='eth0'
}

IP_NET[2]='172.18.2.99/24'
{
DEV='eth1'
}
..
..
..
IP_ROUTE[]='0.0.0.0/0 172.18.1.1'
------------------------------------------------------------

Nun meine (für wichtig befundene) boot-Fehler und Meldungen auf dem Wrap:

PC Engines ALIX.2 v0.99h
640 KB Base Memory

261120 KB Extended Memory

01F0 Master 848A SanDisk SDCFHSNJC-004G
Phys C/H/S 7751/16/63 Log C/H/S 968/128/63

SYSLINUX 4.04 EDD 2011-04-18 Copyright (C) 1994-2011 H. Peter Anvin et al

SYSLINUX 4.04 2011-04-18 Copyright (C) 1994-2011 H. Peter Anvin et al


n <=> boot fli4l standard installation
Version: 4.0.0-r54860-testing

r <=> boot fli4l recover installation
Version: 3.6.2


Choose character from first column to select version and press ENTER

The standard installation will be automatically booted

Unknown keyword in configuration file: DEVICETREEDIR
Unknown keyword in configuration file: DEVICETREEDIR
Unknown keyword in configuration file: DEVICETREEDIR
boot:
Loading /kernel.....
Loading /rootfs.img....ready.
Linux version 4.4.169 (buildroot@buildroot) (gcc version 7.3.0
(Buildroot 2018.02.8) ) #1 SMP Mon Nov 26 23:40:00 CET 2018
KERNEL supported cpus:
Intel GenuineIntel
AMD AuthenticAMD
NSC Geode by NSC
Cyrix CyrixInstead
Centaur CentaurHauls
Transmeta GenuineTMx86
Transmeta TransmetaCPU
UMC UMC UMC UMC
x86/fpu: Legacy x87 FPU detected.
e820: BIOS-provided physical RAM map:
BIOS-e820: [mem 0x0000000000000000-0x000000000009ffff] usable
BIOS-e820: [mem 0x00000000000f0000-0x00000000000fffff] reserved
BIOS-e820: [mem 0x0000000000100000-0x000000000fffffff] usable
BIOS-e820: [mem 0x00000000fff00000-0x00000000ffffffff] reserved
Notice: NX (Execute Disable) protection missing in CPU!
DMI not present or invalid.
e820: last_pfn = 0x10000 max_arch_pfn = 0x100000
MTRR: Disabled
x86/PAT: MTRRs disabled, skipping PAT initialization too.
x86/PAT: Configuration [0-7]: WB WT UC- UC WB WT UC- UC
RAMDISK: [mem 0x0fe16000-0x0fffefff]
0MB HIGHMEM available.
256MB LOWMEM available.
mapped low ram: 0 - 10000000
low ram: 0 - 10000000
Zone ranges:
DMA [mem 0x0000000000001000-0x0000000000ffffff]
Normal [mem 0x0000000001000000-0x000000000fffffff]
HighMem empty
Movable zone start for each node
Early memory node ranges
node 0: [mem 0x0000000000001000-0x000000000009ffff]
node 0: [mem 0x0000000000100000-0x000000000fffffff]
Initmem setup node 0 [mem 0x0000000000001000-0x000000000fffffff]
Using APIC driver default
smpboot: Allowing 1 CPUs, 0 hotplug CPUs
No local APIC present or hardware disabled
APIC: disable apic facility
APIC: switched to apic NOOP
e820: [mem 0x10000000-0xffefffff] available for PCI devices
clocksource: refined-jiffies: mask: 0xffffffff max_cycles: 0xffffffff,
max_idle_ns: 19112604462750000 ns
setup_percpu: NR_CPUS:4 nr_cpumask_bits:4 nr_cpu_ids:1 nr_node_ids:1
PERCPU: Embedded 16 pages/cpu @cfc03000 s34060 r0 d31476 u65536
Built 1 zonelists in Zone order, mobility grouping on. Total pages: 64927
Kernel command line: load_ramdisk=1 initrd=/rootfs.img fli4l_mode=normal
console=ttyS0,38400n8 nokbd reboot=bios printk.time=0 ipv6.disable=1
acpi=off BOOT_IMAGE=/kernel
PID hash table entries: 1024 (order: 0, 4096 bytes)
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Initializing CPU#0
Initializing HighMem for node 0 (00000000:00000000)
Memory: 251160K/261756K available (3651K kernel code, 301K rwdata, 1304K
rodata, 444K init, 464K bss, 10596K reserved, 0K cma-reserved, 0K highmem)
virtual kernel memory layout:
fixmap : 0xfff67000 - 0xfffff000 ( 608 kB)
pkmap : 0xff800000 - 0xffc00000 (4096 kB)
vmalloc : 0xd0800000 - 0xff7fe000 ( 751 MB)
lowmem : 0xc0000000 - 0xd0000000 ( 256 MB)
.init : 0xc1525000 - 0xc1594000 ( 444 kB)
.data : 0xc1391010 - 0xc1523780 (1609 kB)
.text : 0xc1000000 - 0xc1391010 (3652 kB)
Checking if this processor honours the WP bit even in supervisor mode...Ok.
SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Hierarchical RCU implementation.
RCU dyntick-idle grace-period acceleration is enabled.
RCU restricting CPUs from NR_CPUS=4 to nr_cpu_ids=1.
RCU: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=1
NR_IRQS:2304 nr_irqs:32 16
Console: colour dummy device 80x25
console [ttyS0] enabled
tsc: Fast TSC calibration using PIT
tsc: Detected 498.031 MHz processor
Calibrating delay loop (skipped), value calculated using timer
frequency.. 996.06 BogoMIPS (lpj=4980310)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
Last level iTLB entries: 4KB 0, 2MB 0, 4MB 0
Last level dTLB entries: 4KB 0, 2MB 0, 4MB 0, 1GB 0
Spectre V2 : Spectre mitigation: LFENCE not serializing, switching to
generic retpoline
Spectre V2 : Mitigation: Full generic retpoline
Spectre V2 : Spectre v2 / SpectreRSB mitigation: Filling RSB on context
switch
Speculative Store Bypass: Vulnerable
Freeing SMP alternatives memory: 12K
smpboot: weird, boot CPU (#0) not listed by the BIOS
smpboot: SMP motherboard not detected
smpboot: SMP disabled
smpboot: Local APIC not detected. Using dummy APIC emulation.
Performance Events: no PMU driver, software events only.
x86: Booted up 1 node, 1 CPUs
smpboot: Total of 1 processors activated (996.06 BogoMIPS)
clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff,
max_idle_ns: 19112604462750000 ns
futex hash table entries: 256 (order: 2, 16384 bytes)
NET: Registered protocol family 16
cpuidle: using governor menu
clocksource: pit: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns:
1601818034827 ns
PCI: PCI BIOS revision 2.10 entry at 0xfced9, last bus=0
PCI: Using configuration type 1 for base access
ACPI: Interpreter disabled.
vgaarb: loaded
dmi: Firmware registration failed.
PCI: Probing PCI hardware
PCI host bridge to bus 0000:00
pci_bus 0000:00: root bus resource [io 0x0000-0xffff]
pci_bus 0000:00: root bus resource [mem 0x00000000-0xffffffff]
pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
pci 0000:00:01.0: [Firmware Bug]: reg 0x10: invalid BAR (can't size)
pci 0000:00:0f.2: legacy IDE quirk: reg 0x10: [io 0x01f0-0x01f7]
pci 0000:00:0f.2: legacy IDE quirk: reg 0x14: [io 0x03f6]
pci 0000:00:0f.2: legacy IDE quirk: reg 0x18: [io 0x0170-0x0177]
pci 0000:00:0f.2: legacy IDE quirk: reg 0x1c: [io 0x0376]
amd_nb: Cannot enumerate AMD northbridges
clocksource: Switched to clocksource pit
pnp: PnP ACPI: disabled
PnPBIOS: Scanning system for PnP BIOS support...
PnPBIOS: PnP BIOS support was not detected.
NET: Registered protocol family 2
TCP established hash table entries: 2048 (order: 1, 8192 bytes)
TCP bind hash table entries: 2048 (order: 2, 16384 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
UDP hash table entries: 256 (order: 1, 8192 bytes)
UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
NET: Registered protocol family 1
Unpacking initramfs...
Freeing initrd memory: 1956K
platform rtc_cmos: registered platform RTC device (no PNP device found)
SSE2 instructions are not detected.
PCLMULQDQ-NI instructions are not detected.
alix: system is recognized as "PC Engines ALIX.2 v0.99h"
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
io scheduler noop registered
io scheduler cfq registered (default)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.4
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
ÿserial8250: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 921600) is a NS16550A
clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0xe5b8ef9f82,
max_idle_ns: 881590410610 ns
clocksource: Switched to clocksource tsc
serial8250: ttyS1 at I/O 0x2f8 (irq = 3, base_baud = 921600) is a NS16550A
loop: module loaded
i8042: PNP: No PS/2 controller found. Probing ports directly.
i8042: No controller found
rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0
rtc_cmos rtc_cmos: alarms up to one day, 114 bytes nvram
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci-pltfm: SDHCI platform and OF driver helper
dmi-sysfs: dmi entry is absent.
Netfilter messages via NETLINK v0.30.
nfnl_acct: registering with nfnetlink.
nf_conntrack version 0.5.0 (3955 buckets, 15820 max)
ctnetlink v0.93: registering with nfnetlink.
nf_tables: (c) 2007-2009 Patrick McHardy
nf_tables_compat: (c) 2012 Pablo Neira Ayuso
xt_time: kernel timezone is -0000
ip_set: protocol 6
ip_tables: (C) 2000-2006 Netfilter Core Team
ipt_CLUSTERIP: ClusterIP Version 0.8 loaded successfully
arp_tables: (C) 2002 David S. Miller
Initializing XFRM netlink socket
IPv6: Loaded, but administratively disabled, reboot required to enable
IPv6: ah6_init: can't add xfrm type
IPv6: esp6_init: can't add xfrm type
IPv6: ipcomp6_init: can't add xfrm type
mip6: Mobile IPv6
mip6: mip6_init: can't add xfrm type(destopt)
ip6_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 17
NET: Registered protocol family 15
mpls_gso: MPLS GSO support
mce: Unable to init device /dev/mcelog (rc: -5)
Using IPI No-Shortcut mode
registered taskstats version 1
console [netcon0] enabled
netconsole: network logging started
rtc_cmos rtc_cmos: setting system clock to 2005-12-24 23:49:28 UTC
(1135468168)
Freeing unused kernel memory: 444K
Write protecting the kernel text: 3656k
Write protecting the kernel read-only data: 1304k

init started: BusyBox v1.27.2 (fli4l)

starting pid 117, tty '': '/etc/rc'
random: sh: uninitialized urandom read (4 bytes read, 8 bits of entropy
available)
random: sh: uninitialized urandom read (4 bytes read, 8 bits of entropy
available)
random: exe: uninitialized urandom read (4 bytes read, 8 bits of entropy
available)
random: sh: uninitialized urandom read (4 bytes read, 8 bits of entropy
available)
random: sh: uninitialized urandom read (4 bytes read, 8 bits of entropy
available)
random: sh: uninitialized urandom read (4 bytes read, 8 bits of entropy
available)
random: sh: uninitialized urandom read (4 bytes read, 8 bits of entropy
available)
random: sh: uninitialized urandom read (4 bytes read, 8 bits of entropy
available)
random: sh: uninitialized urandom read (4 bytes read, 8 bits of entropy
available)
random: sh: uninitialized urandom read (4 bytes read, 8 bits of entropy
available)
rootfs on / type rootfs (rw,size=125580k,nr_inodes=31395)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
input: PC Speaker as /devices/platform/pcspkr/input/input0
* running boot scripts
* [rc000.base] basic setup for booting...
* Wrapping of modutils disabled ()
SCSI subsystem initialized
 [ OK ]
* [rc010.hddrv] loading disk drivers ...
 [ OK ]
* [rc020.hd-generic] loading generic disk
drivers ...
scsi host0: ata_generic
scsi host1: ata_generic
ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xff00 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xff08 irq 15
ata1.00: CFA: SanDisk SDCFHSNJC-004G, HDX 7.08, max UDMA/100
ata1.00: 7813120 sectors, multi 0: LBA48
ata1.00: configured for UDMA/100
scsi 0:0:0:0: Direct-Access ATA SanDisk SDCFHSNJ 7.08 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 7813120 512-byte logical blocks: (4.00 GB/3.73 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't
support DPO or FUA


------------------

und hier bleibt er hängen.

ich hoffe, ich habe nicht zuviel oder zuwenig geschrieben. Was kann ich
noch liefern?

Dankeschön
Re: Fli4l 4.0.0 auf WRAP/ALIX.2 Bootet nicht zu Ende [Beitrag #68901 ist eine Antwort auf Beitrag #68898] Tue, 22 January 2019 09:36 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
LeSpocky ist gerade offline  LeSpocky
Beiträge: 648
Registriert: July 2010
Ort: Magdeburg
Senior Member

Hallo Friedhold,

Friedhold Schuster schrieb Dienstag, 22. Januar 2019, 08:42 (CET):
> weiter gehts, Schweißabwisch.....
> ich ging davon aus, einen WRAP zu benutzen, aber es ist ein ALIX.

Ich habe hier ein ALIX 2D3 im Produktivbetrieb mit 4.0 trunk, das sollte
also zu schaffen sein.

Folgende Config läuft bei mir, zunächst base.txt:

BOOT_TYPE='hd'
LIBATA_DMA='enabled'
RTC_SYNC='kernel'
KERNEL_BOOT_OPTION=''
POWERMANAGEMENT='none'
CONSOLE_BLANK_TIME='0'
SER_CONSOLE='yes'
NET_DRV[]='via-rhine'
{
OPTION=''
}

hwsupp.txt sah ja schon gut aus bei Dir, für hd.txt hab ich folgendes:

OPT_HDDRV='yes'
HDDRV_N='1'
HDDRV_1='pata_cs5536'
HDDRV_1_OPTION=''

> SCSI subsystem initialized
>  [ OK ]
> * [rc010.hddrv] loading disk drivers ...
>  [ OK ]
> * [rc020.hd-generic] loading generic disk
> drivers ...
> scsi host0: ata_generic
> scsi host1: ata_generic
> ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xff00 irq 14
> ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xff08 irq 15
> ata1.00: CFA: SanDisk SDCFHSNJC-004G, HDX 7.08, max UDMA/100
> ata1.00: 7813120 sectors, multi 0: LBA48
> ata1.00: configured for UDMA/100
> scsi 0:0:0:0: Direct-Access ATA SanDisk SDCFHSNJ 7.08 PQ: 0 ANSI: 5
> sd 0:0:0:0: [sda] 7813120 512-byte logical blocks: (4.00 GB/3.73 GiB)
> sd 0:0:0:0: [sda] Write Protect is off
> sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't
> support DPO or FUA

Hmm, Du hast nur den generischen ATA-Treiber benutzt, richtig?
Eigentlich sollte das ja auch gehen, auch mit den DMA-Settings. Aber
einen Versuch ist es wert mal den anderen zu nehmen.

Grüße
Alex

--
***** http://blog.antiblau.de/ *****************************
GnuPG-FP: C28E E6B9 0263 95CF 8FAF 08FA 34AD CD00 7221 5CC6
Re: Fli4l 4.0.0 auf WRAP/ALIX.2 Bootet nicht zu Ende [Beitrag #68908 ist eine Antwort auf Beitrag #68901] Tue, 22 January 2019 11:19 Zum vorherigen Beitrag gehen
Friedhold Schuster ist gerade offline  Friedhold Schuster
Beiträge: 416
Registriert: October 2011
Senior Member
Hallo Alex,

Am 22.01.2019 um 09:36 schrieb Alexander Dahl:
> Aber
> einen Versuch ist es wert mal den anderen zu nehmen.

mit Deinen Einstellungen läuft er durch. Prima Dankeschön.

Die nächste Frage kommt bestimmt gleich.


Oh Mann, seit 2013 alles vergessen.

Dankeschön
Vorheriges Thema: Nach vielen Jahren mal wieder einen fli4l einrichten. Brauche Tipps zur Hardware...
Nächstes Thema: Fehler beim build
Gehe zum Forum:
  


aktuelle Zeit: Thu Apr 18 20:50:25 CEST 2019

Insgesamt benötigte Zeit, um die Seite zu erzeugen: 0.01044 Sekunden