• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/18xx-ti-utils/18xx-ti-utils.mk
Baruch SiachBaruch Siach committed 8304e920cb901 Mar 2018
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
################################################################################
#
# 18xx-ti-utils
#
################################################################################
​
18XX_TI_UTILS_VERSION = R8.7_SP3
18XX_TI_UTILS_SITE = git://git.ti.com/wilink8-wlan/18xx-ti-utils
18XX_TI_UTILS_DEPENDENCIES = libnl
18XX_TI_UTILS_LICENSE = BSD-3-Clause
18XX_TI_UTILS_LICENSE_FILES = COPYING
​
18XX_TI_UTILS_CFLAGS = -I$(STAGING_DIR)/usr/include/libnl3 -DCONFIG_LIBNL32
​
ifeq ($(BR2_STATIC_LIBS),y)
18XX_TI_UTILS_BUILD_TARGET = static
endif
​
define 18XX_TI_UTILS_BUILD_CMDS
    $(TARGET_MAKE_ENV) CROSS_COMPILE=$(TARGET_CROSS) \
        NFSROOT="$(STAGING_DIR)" NLVER=3 $(MAKE) -C $(@D) \
        CFLAGS="$(TARGET_CFLAGS) $(18XX_TI_UTILS_CFLAGS)" \
        $(18XX_TI_UTILS_BUILD_TARGET)
endef
​
define 18XX_TI_UTILS_INSTALL_TARGET_CMDS
    $(INSTALL) -m 0755 $(@D)/calibrator $(TARGET_DIR)/usr/bin/calibrator
endef
​
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.