• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/acpica/acpica.mk
Arnout VandecappelleArnout Vandecappelle committed 15bff58f3e605 Jul 2017
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# acpica
4
#
5
################################################################################
6
​
7
ACPICA_VERSION = 20170531
8
ACPICA_SOURCE = acpica-unix2-$(ACPICA_VERSION).tar.gz
9
ACPICA_SITE = https://acpica.org/sites/acpica/files
10
ACPICA_LICENSE = BSD-3-Clause or GPL-2.0
11
ACPICA_LICENSE_FILES = source/include/acpi.h
12
ACPICA_DEPENDENCIES = host-bison host-flex
13
​
14
define ACPICA_BUILD_CMDS
15
    $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
16
        HARDWARE_NAME=$(BR2_ARCH) HOST=_LINUX CC="$(TARGET_CC)" \
17
        all
18
endef
19
​
20
define HOST_ACPICA_BUILD_CMDS
21
    $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
22
        all
23
endef
24
​
25
define ACPICA_INSTALL_TARGET_CMDS
26
    $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
27
        HARDWARE_NAME=$(BR2_ARCH) DESTDIR="$(TARGET_DIR)" \
28
        INSTALLFLAGS=-m755 install
29
endef
30
​
31
define HOST_ACPICA_INSTALL_CMDS
32
    $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
33
        PREFIX="$(HOST_DIR)" \
34
        INSTALLFLAGS=-m755 install
35
endef
36
​
37
$(eval $(generic-package))
38
$(eval $(host-generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.