• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/acpid/acpid.mk
Rahul BedarkarRahul Bedarkar committed af31c309e7330 Mar 2017
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# acpid
4
#
5
################################################################################
6
​
7
ACPID_VERSION = 2.0.28
8
ACPID_SOURCE = acpid-$(ACPID_VERSION).tar.xz
9
ACPID_SITE = http://downloads.sourceforge.net/project/acpid2
10
ACPID_LICENSE = GPL-2.0+
11
ACPID_LICENSE_FILES = COPYING
12
​
13
define ACPID_INSTALL_INIT_SYSV
14
    $(INSTALL) -D -m 0755 package/acpid/S02acpid \
15
        $(TARGET_DIR)/etc/init.d/S02acpid
16
endef
17
​
18
define ACPID_SET_EVENTS
19
    mkdir -p $(TARGET_DIR)/etc/acpi/events
20
    printf "event=button[ /]power\naction=/sbin/poweroff\n" \
21
        >$(TARGET_DIR)/etc/acpi/events/powerbtn
22
endef
23
​
24
ACPID_POST_INSTALL_TARGET_HOOKS += ACPID_SET_EVENTS
25
​
26
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.