• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/alsa-lib/alsa-lib.mk
Thomas PetazzoniThomas Petazzoni committed 7a03caaa13605 Apr 2018
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# alsa-lib
4
#
5
################################################################################
6
​
7
ALSA_LIB_VERSION = 1.1.6
8
ALSA_LIB_SOURCE = alsa-lib-$(ALSA_LIB_VERSION).tar.bz2
9
ALSA_LIB_SITE = ftp://ftp.alsa-project.org/pub/lib
10
ALSA_LIB_LICENSE = LGPL-2.1+ (library), GPL-2.0+ (aserver)
11
ALSA_LIB_LICENSE_FILES = COPYING aserver/COPYING
12
ALSA_LIB_INSTALL_STAGING = YES
13
ALSA_LIB_CFLAGS = $(TARGET_CFLAGS)
14
ALSA_LIB_AUTORECONF = YES
15
ALSA_LIB_CONF_OPTS = \
16
    --with-alsa-devdir=$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_DEVDIR)) \
17
    --with-pcm-plugins="$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_PCM_PLUGINS))" \
18
    --with-ctl-plugins="$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_CTL_PLUGINS))" \
19
    --without-versioned
20
​
21
# Can't build with static & shared at the same time (1.0.25+)
22
ifeq ($(BR2_STATIC_LIBS),y)
23
ALSA_LIB_CONF_OPTS += \
24
    --enable-shared=no \
25
    --without-libdl
26
else
27
ALSA_LIB_CONF_OPTS += --enable-static=no
28
endif
29
​
30
ifneq ($(BR2_PACKAGE_ALSA_LIB_ALOAD),y)
31
ALSA_LIB_CONF_OPTS += --disable-aload
32
endif
33
ifneq ($(BR2_PACKAGE_ALSA_LIB_MIXER),y)
34
ALSA_LIB_CONF_OPTS += --disable-mixer
35
endif
36
ifneq ($(BR2_PACKAGE_ALSA_LIB_PCM),y)
37
ALSA_LIB_CONF_OPTS += --disable-pcm
38
endif
39
ifneq ($(BR2_PACKAGE_ALSA_LIB_RAWMIDI),y)
40
ALSA_LIB_CONF_OPTS += --disable-rawmidi
41
endif
42
ifneq ($(BR2_PACKAGE_ALSA_LIB_HWDEP),y)
43
ALSA_LIB_CONF_OPTS += --disable-hwdep
44
endif
45
ifneq ($(BR2_PACKAGE_ALSA_LIB_SEQ),y)
46
ALSA_LIB_CONF_OPTS += --disable-seq
47
endif
48
ifneq ($(BR2_PACKAGE_ALSA_LIB_ALISP),y)
49
ALSA_LIB_CONF_OPTS += --disable-alisp
50
endif
51
ifneq ($(BR2_PACKAGE_ALSA_LIB_OLD_SYMBOLS),y)
52
ALSA_LIB_CONF_OPTS += --disable-old-symbols
53
endif
54
​
55
ifeq ($(BR2_PACKAGE_ALSA_LIB_PYTHON),y)
56
ALSA_LIB_CONF_OPTS += \
57
    --with-pythonlibs=-lpython$(PYTHON_VERSION_MAJOR) \
58
    --with-pythonincludes=$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
59
ALSA_LIB_CFLAGS += -I$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
60
ALSA_LIB_DEPENDENCIES = python
61
else
62
ALSA_LIB_CONF_OPTS += --disable-python
63
endif
64
​
65
ALSA_LIB_CONF_ENV = \
66
    CFLAGS="$(ALSA_LIB_CFLAGS)" \
67
    LDFLAGS="$(TARGET_LDFLAGS) -lm"
68
​
69
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.