• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/apr-util/apr-util.mk
Baruch SiachBaruch Siach committed 1d3c611dee830 Oct 2017
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# apr-util
4
#
5
################################################################################
6
​
7
APR_UTIL_VERSION = 1.6.1
8
APR_UTIL_SOURCE = apr-util-$(APR_UTIL_VERSION).tar.bz2
9
APR_UTIL_SITE = http://archive.apache.org/dist/apr
10
APR_UTIL_LICENSE = Apache-2.0
11
APR_UTIL_LICENSE_FILES = LICENSE
12
APR_UTIL_INSTALL_STAGING = YES
13
APR_UTIL_DEPENDENCIES = apr expat
14
APR_UTIL_CONF_OPTS = \
15
    --with-apr=$(STAGING_DIR)/usr/bin/apr-1-config
16
APR_UTIL_CONFIG_SCRIPTS = apu-1-config
17
​
18
# When iconv is available, then use it to provide charset conversion
19
# features.
20
APR_UTIL_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)
21
​
22
ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
23
APR_UTIL_CONF_OPTS += --with-dbm=db53 --with-berkeley-db="$(STAGING_DIR)/usr"
24
APR_UTIL_DEPENDENCIES += berkeleydb
25
else
26
APR_UTIL_CONF_OPTS += --without-berkeley-db
27
endif
28
​
29
ifeq ($(BR2_PACKAGE_GDBM),y)
30
APR_UTIL_CONF_OPTS += --with-gdbm="$(STAGING_DIR)/usr"
31
APR_UTIL_DEPENDENCIES += gdbm
32
else
33
APR_UTIL_CONF_OPTS += --without-gdbm
34
endif
35
​
36
ifeq ($(BR2_PACKAGE_MYSQL),y)
37
APR_UTIL_CONF_OPTS += --with-mysql="$(STAGING_DIR)/usr"
38
APR_UTIL_DEPENDENCIES += mysql
39
else
40
APR_UTIL_CONF_OPTS += --without-mysql
41
endif
42
​
43
ifeq ($(BR2_PACKAGE_SQLITE),y)
44
APR_UTIL_CONF_OPTS += --with-sqlite3="$(STAGING_DIR)/usr"
45
APR_UTIL_DEPENDENCIES += sqlite
46
else
47
APR_UTIL_CONF_OPTS += --without-sqlite3
48
endif
49
​
50
ifeq ($(BR2_PACKAGE_OPENSSL),y)
51
APR_UTIL_CONF_OPTS += --with-crypto --with-openssl="$(STAGING_DIR)/usr"
52
APR_UTIL_DEPENDENCIES += openssl
53
else
54
APR_UTIL_CONF_OPTS += --without-crypto
55
endif
56
​
57
ifeq ($(BR2_PACKAGE_UNIXODBC),y)
58
APR_UTIL_CONF_OPTS += --with-odbc="$(STAGING_DIR)/usr"
59
# avoid using target binary $(STAGING_DIR)/usr/bin/odbc_config
60
APR_UTIL_CONF_ENV += ac_cv_path_ODBC_CONFIG=""
61
APR_UTIL_DEPENDENCIES += unixodbc
62
else
63
APR_UTIL_CONF_OPTS += --without-odbc
64
endif
65
​
66
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.