• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/argp-standalone/argp-standalone.mk
Matt WeberMatt Weber committed f0b65bd90ce31 Oct 2017
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# argp-standalone
4
#
5
################################################################################
6
​
7
ARGP_STANDALONE_VERSION = 1.3
8
ARGP_STANDALONE_SITE = http://www.lysator.liu.se/~nisse/archive
9
ARGP_STANDALONE_INSTALL_STAGING = YES
10
ARGP_STANDALONE_LICENSE = LGPL-2.0+
11
​
12
ARGP_STANDALONE_CONF_ENV = \
13
    CFLAGS="$(TARGET_CFLAGS) -fPIC -fgnu89-inline"
14
​
15
define ARGP_STANDALONE_INSTALL_STAGING_CMDS
16
    $(INSTALL) -D $(@D)/libargp.a $(STAGING_DIR)/usr/lib/libargp.a
17
    $(INSTALL) -D $(@D)/argp.h $(STAGING_DIR)/usr/include/argp.h
18
endef
19
​
20
define ARGP_STANDALONE_INSTALL_TARGET_CMDS
21
    $(INSTALL) -D $(@D)/libargp.a $(TARGET_DIR)/usr/lib/libargp.a
22
    $(INSTALL) -D $(@D)/argp.h $(TARGET_DIR)/usr/include/argp.h
23
endef
24
​
25
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.