• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/automake/automake.mk
Gustavo ZacariasGustavo Zacarias committed 6c653c5002501 Jan 2014
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# automake
4
#
5
################################################################################
6
​
7
AUTOMAKE_VERSION = 1.14.1
8
AUTOMAKE_SOURCE = automake-$(AUTOMAKE_VERSION).tar.xz
9
AUTOMAKE_SITE = $(BR2_GNU_MIRROR)/automake
10
AUTOMAKE_LICENSE = GPLv2+
11
AUTOMAKE_LICENSE_FILES = COPYING
12
​
13
AUTOMAKE_DEPENDENCIES = host-autoconf autoconf perl
14
​
15
HOST_AUTOMAKE_DEPENDENCIES = host-autoconf
16
​
17
define GTK_DOC_M4_INSTALL
18
 $(INSTALL) -D -m 0644 package/automake/gtk-doc.m4 $(HOST_DIR)/usr/share/aclocal/gtk-doc.m4
19
endef
20
​
21
# ensure staging aclocal dir exists
22
define HOST_AUTOMAKE_MAKE_ACLOCAL
23
    mkdir -p $(ACLOCAL_DIR)
24
endef
25
​
26
HOST_AUTOMAKE_POST_INSTALL_HOOKS += GTK_DOC_M4_INSTALL
27
HOST_AUTOMAKE_POST_INSTALL_HOOKS += HOST_AUTOMAKE_MAKE_ACLOCAL
28
​
29
$(eval $(autotools-package))
30
$(eval $(host-autotools-package))
31
​
32
# variables used by other packages
33
AUTOMAKE = $(HOST_DIR)/usr/bin/automake
34
ACLOCAL_DIR = $(STAGING_DIR)/usr/share/aclocal
35
ACLOCAL_HOST_DIR = $(HOST_DIR)/usr/share/aclocal
36
ACLOCAL = $(HOST_DIR)/usr/bin/aclocal -I $(ACLOCAL_DIR)
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.