• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/botan/botan.mk
Tobias BlassTobias Blass committed e654839f9e206 Jun 2017
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# botan
4
#
5
################################################################################
6
​
7
BOTAN_VERSION = 1.10.16
8
BOTAN_SOURCE = Botan-$(BOTAN_VERSION).tgz
9
BOTAN_SITE = http://botan.randombit.net/releases
10
BOTAN_LICENSE = BSD-2-Clause
11
BOTAN_LICENSE_FILES = doc/license.txt
12
​
13
BOTAN_INSTALL_STAGING = YES
14
​
15
BOTAN_CONF_OPTS = \
16
    --cpu=$(BR2_ARCH) \
17
    --os=linux \
18
    --cc=gcc \
19
    --cc-bin="$(TARGET_CXX)" \
20
    --prefix=/usr
21
​
22
ifeq ($(BR2_STATIC_LIBS),y)
23
BOTAN_CONF_OPTS += --disable-shared --no-autoload
24
endif
25
​
26
ifeq ($(BR2_PACKAGE_BZIP2),y)
27
BOTAN_DEPENDENCIES += bzip2
28
BOTAN_CONF_OPTS += --with-bzip2
29
endif
30
​
31
ifeq ($(BR2_PACKAGE_GMP),y)
32
BOTAN_DEPENDENCIES += gmp
33
BOTAN_CONF_OPTS += --with-gnump
34
endif
35
​
36
ifeq ($(BR2_PACKAGE_OPENSSL),y)
37
BOTAN_DEPENDENCIES += openssl
38
BOTAN_CONF_OPTS += --with-openssl
39
endif
40
​
41
ifeq ($(BR2_PACKAGE_ZLIB),y)
42
BOTAN_DEPENDENCIES += zlib
43
BOTAN_CONF_OPTS += --with-zlib
44
endif
45
​
46
ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
47
BOTAN_CONF_OPTS += --enable-altivec
48
else
49
BOTAN_CONF_OPTS += --disable-altivec
50
endif
51
​
52
define BOTAN_CONFIGURE_CMDS
53
    (cd $(@D); $(TARGET_MAKE_ENV) ./configure.py $(BOTAN_CONF_OPTS))
54
endef
55
​
56
define BOTAN_BUILD_CMDS
57
    $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) AR="$(TARGET_AR) crs"
58
endef
59
​
60
define BOTAN_INSTALL_STAGING_CMDS
61
    $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(STAGING_DIR)/usr" install
62
endef
63
​
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.