• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/cmake/cmake.mk
Maxime HadjinlianMaxime Hadjinlian committed 1497e1b133e22 Dec 2013
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# cmake
4
#
5
################################################################################
6
​
7
CMAKE_VERSION_MAJOR = 2.8
8
CMAKE_VERSION = $(CMAKE_VERSION_MAJOR).12.1
9
CMAKE_SITE = http://www.cmake.org/files/v$(CMAKE_VERSION_MAJOR)/
10
CMAKE_LICENSE = BSD-3c
11
CMAKE_LICENSE_FILES = Copyright.txt
12
​
13
define HOST_CMAKE_CONFIGURE_CMDS
14
    (cd $(@D); \
15
        LDFLAGS="$(HOST_LDFLAGS)" \
16
        CFLAGS="$(HOST_CFLAGS)" \
17
        ./bootstrap --prefix=$(HOST_DIR)/usr --parallel=$(PARALLEL_JOBS) \
18
    )
19
endef
20
​
21
define HOST_CMAKE_BUILD_CMDS
22
    $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
23
endef
24
​
25
define HOST_CMAKE_INSTALL_CMDS
26
    $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install
27
endef
28
​
29
$(eval $(host-generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.