• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/docker-engine/docker-engine.mk
Christian StewartChristian Stewart committed e099f37013024 Jul 2016
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# docker-engine
4
#
5
################################################################################
6
​
7
DOCKER_ENGINE_VERSION = v1.12.0-rc4
8
DOCKER_ENGINE_SITE = $(call github,docker,docker,$(DOCKER_ENGINE_VERSION))
9
​
10
DOCKER_ENGINE_LICENSE = Apache-2.0
11
DOCKER_ENGINE_LICENSE_FILES = LICENSE
12
​
13
DOCKER_ENGINE_DEPENDENCIES = host-go
14
​
15
DOCKER_ENGINE_GOPATH = "$(@D)/vendor"
16
DOCKER_ENGINE_MAKE_ENV = $(HOST_GO_TARGET_ENV) \
17
    CGO_ENABLED=1 \
18
    CGO_NO_EMULATION=1 \
19
    GOBIN="$(@D)/bin" \
20
    GOPATH="$(DOCKER_ENGINE_GOPATH)"
21
​
22
DOCKER_ENGINE_GLDFLAGS = \
23
    -X main.GitCommit=$(DOCKER_ENGINE_VERSION) \
24
    -X main.Version=$(DOCKER_ENGINE_VERSION)
25
​
26
ifeq ($(BR2_STATIC_LIBS),y)
27
DOCKER_ENGINE_GLDFLAGS += -extldflags '-static'
28
endif
29
​
30
DOCKER_ENGINE_BUILD_TAGS = cgo exclude_graphdriver_zfs autogen
31
DOCKER_ENGINE_BUILD_TARGETS = docker
32
​
33
ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
34
DOCKER_ENGINE_BUILD_TAGS += seccomp
35
DOCKER_ENGINE_DEPENDENCIES += libseccomp
36
endif
37
​
38
ifeq ($(BR2_PACKAGE_DOCKER_ENGINE_DAEMON),y)
39
DOCKER_ENGINE_BUILD_TAGS += daemon
40
DOCKER_ENGINE_BUILD_TARGETS += dockerd
41
endif
42
​
43
ifeq ($(BR2_PACKAGE_DOCKER_ENGINE_EXPERIMENTAL),y)
44
DOCKER_ENGINE_BUILD_TAGS += experimental
45
endif
46
​
47
ifeq ($(BR2_PACKAGE_DOCKER_ENGINE_DRIVER_BTRFS),y)
48
DOCKER_ENGINE_DEPENDENCIES += btrfs-progs
49
else
50
DOCKER_ENGINE_BUILD_TAGS += exclude_graphdriver_btrfs
51
endif
52
​
53
ifeq ($(BR2_PACKAGE_DOCKER_ENGINE_DRIVER_DEVICEMAPPER),y)
54
DOCKER_ENGINE_DEPENDENCIES += lvm2
55
else
56
DOCKER_ENGINE_BUILD_TAGS += exclude_graphdriver_devicemapper
57
endif
58
​
59
ifeq ($(BR2_PACKAGE_DOCKER_ENGINE_DRIVER_VFS),y)
60
DOCKER_ENGINE_DEPENDENCIES += gvfs
61
else
62
DOCKER_ENGINE_BUILD_TAGS += exclude_graphdriver_vfs
63
endif
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.