• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/dropbear/dropbear.mk
Peter KorsgaardPeter Korsgaard committed 8644a83bd8020 May 2017
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# dropbear
4
#
5
################################################################################
6
​
7
DROPBEAR_VERSION = 2017.75
8
DROPBEAR_SITE = http://matt.ucc.asn.au/dropbear/releases
9
DROPBEAR_SOURCE = dropbear-$(DROPBEAR_VERSION).tar.bz2
10
DROPBEAR_LICENSE = MIT, BSD-2-Clause-like, BSD-2-Clause
11
DROPBEAR_LICENSE_FILES = LICENSE
12
DROPBEAR_TARGET_BINS = dropbearkey dropbearconvert scp
13
DROPBEAR_PROGRAMS = dropbear $(DROPBEAR_TARGET_BINS)
14
​
15
ifeq ($(BR2_PACKAGE_DROPBEAR_CLIENT),y)
16
# Build dbclient, and create a convenience symlink named ssh
17
DROPBEAR_PROGRAMS += dbclient
18
DROPBEAR_TARGET_BINS += dbclient ssh
19
endif
20
​
21
DROPBEAR_MAKE = \
22
    $(MAKE) MULTI=1 SCPPROGRESS=1 \
23
    PROGRAMS="$(DROPBEAR_PROGRAMS)"
24
​
25
ifeq ($(BR2_STATIC_LIBS),y)
26
DROPBEAR_MAKE += STATIC=1
27
endif
28
​
29
define DROPBEAR_FIX_XAUTH
30
    $(SED) 's,^#define XAUTH_COMMAND.*/xauth,#define XAUTH_COMMAND "/usr/bin/xauth,g' $(@D)/options.h
31
endef
32
​
33
DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_FIX_XAUTH
34
​
35
define DROPBEAR_ENABLE_REVERSE_DNS
36
    $(SED) 's:.*\(#define DO_HOST_LOOKUP\).*:\1:' $(@D)/options.h
37
endef
38
​
39
define DROPBEAR_BUILD_SMALL
40
    $(SED) 's:.*\(#define NO_FAST_EXPTMOD\).*:\1:' $(@D)/options.h
41
endef
42
​
43
define DROPBEAR_BUILD_FEATURED
44
    $(SED) 's:^#define DROPBEAR_SMALL_CODE::' $(@D)/options.h
45
    $(SED) 's:.*\(#define DROPBEAR_BLOWFISH\).*:\1:' $(@D)/options.h
46
    $(SED) 's:.*\(#define DROPBEAR_TWOFISH128\).*:\1:' $(@D)/options.h
47
    $(SED) 's:.*\(#define DROPBEAR_TWOFISH256\).*:\1:' $(@D)/options.h
48
endef
49
​
50
define DROPBEAR_DISABLE_STANDALONE
51
    $(SED) 's:\(#define NON_INETD_MODE\):/*\1 */:' $(@D)/options.h
52
endef
53
​
54
define DROPBEAR_INSTALL_INIT_SYSTEMD
55
    $(INSTALL) -D -m 644 package/dropbear/dropbear.service \
56
        $(TARGET_DIR)/usr/lib/systemd/system/dropbear.service
57
    mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
58
    ln -fs ../../../../usr/lib/systemd/system/dropbear.service \
59
        $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/dropbear.service
60
endef
61
​
62
ifeq ($(BR2_USE_MMU),y)
63
define DROPBEAR_INSTALL_INIT_SYSV
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.