• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/ebtables/ebtables.mk
Luca CeresoliLuca Ceresoli committed 7b0e757fb8528 Sep 2015
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# ebtables
4
#
5
################################################################################
6
​
7
EBTABLES_VERSION = 2.0.10-4
8
EBTABLES_SOURCE = ebtables-v$(EBTABLES_VERSION).tar.gz
9
EBTABLES_SITE = http://ftp.netfilter.org/pub/ebtables
10
EBTABLES_LICENSE = GPLv2+
11
EBTABLES_LICENSE_FILES = COPYING
12
EBTABLES_STATIC = $(if $(BR2_STATIC_LIBS),static)
13
EBTABLES_K64U32 = $(if $(BR2_KERNEL_64_USERLAND_32),-DKERNEL_64_USERSPACE_32)
14
​
15
define EBTABLES_BUILD_CMDS
16
    $(MAKE) $(TARGET_CONFIGURE_OPTS) LIBDIR=/lib/ebtables $(EBTABLES_STATIC) \
17
        CFLAGS="$(TARGET_CFLAGS) $(EBTABLES_K64U32)" -C $(@D)
18
endef
19
​
20
ifeq ($(BR2_STATIC_LIBS),y)
21
define EBTABLES_INSTALL_TARGET_CMDS
22
    $(INSTALL) -m 0755 -D $(@D)/$(EBTABLES_SUBDIR)/static \
23
        $(TARGET_DIR)/sbin/ebtables
24
endef
25
else
26
define EBTABLES_INSTALL_TARGET_CMDS
27
    for so in $(@D)/$(EBTABLES_SUBDIR)/*.so \
28
        $(@D)/$(EBTABLES_SUBDIR)/extensions/*.so; \
29
        do \
30
        $(INSTALL) -m 0755 -D $${so} \
31
            $(TARGET_DIR)/lib/ebtables/`basename $${so}` || exit 1; \
32
    done
33
    $(INSTALL) -m 0755 -D $(@D)/$(EBTABLES_SUBDIR)/ebtables \
34
        $(TARGET_DIR)/sbin/ebtables
35
    $(INSTALL) -m 0644 -D $(@D)/ethertypes $(TARGET_DIR)/etc/ethertypes
36
endef
37
endif
38
​
39
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.