• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/erlang/erlang.mk
Frank HunlethFrank Hunleth committed 00856e2ba2e10 Apr 2014
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# erlang
4
#
5
################################################################################
6
​
7
ERLANG_VERSION = 17.0
8
ERLANG_SITE = http://www.erlang.org/download
9
ERLANG_SOURCE = otp_src_$(ERLANG_VERSION).tar.gz
10
ERLANG_DEPENDENCIES = host-erlang
11
HOST_ERLANG_DEPENDENCIES =
12
​
13
ERLANG_LICENSE = EPL
14
ERLANG_LICENSE_FILES = EPLICENCE
15
ERLANG_INSTALL_STAGING = YES
16
​
17
# The configure checks for these functions fail incorrectly
18
ERLANG_CONF_ENV = ac_cv_func_isnan=yes ac_cv_func_isinf=yes
19
​
20
# Set erl_xcomp variables. See xcomp/erl-xcomp.conf.template
21
# for documentation.
22
ERLANG_CONF_ENV += erl_xcomp_sysroot=$(STAGING_DIR)
23
​
24
ERLANG_CONF_OPT = --without-javac
25
HOST_ERLANG_CONF_OPT = --without-javac
26
​
27
ifeq ($(BR2_PACKAGE_NCURSES),y)
28
ERLANG_CONF_OPT += --with-termcap
29
ERLANG_DEPENDENCIES += ncurses
30
else
31
ERLANG_CONF_OPT += --without-termcap
32
endif
33
​
34
ifeq ($(BR2_PACKAGE_OPENSSL),y)
35
ERLANG_CONF_OPT += --with-ssl
36
ERLANG_DEPENDENCIES += openssl
37
else
38
ERLANG_CONF_OPT += --without-ssl
39
endif
40
​
41
ifeq ($(BR2_PACKAGE_ZLIB),y)
42
ERLANG_CONF_OPT += --enable-shared-zlib
43
ERLANG_DEPENDENCIES += zlib
44
endif
45
​
46
ifeq ($(BR2_PACKAGE_ERLANG_SMP),)
47
ERLANG_CONF_OPT += --disable-smp-support
48
endif
49
​
50
# Remove source, example, gs and wx files from the target
51
ERLANG_REMOVE_PACKAGES = gs wx
52
​
53
ifneq ($(BR2_PACKAGE_ERLANG_MEGACO),y)
54
ERLANG_REMOVE_PACKAGES += megaco
55
endif
56
​
57
define ERLANG_REMOVE_UNUSED
58
    find $(TARGET_DIR)/usr/lib/erlang -type d -name src -prune -exec rm -rf {} \;
59
    find $(TARGET_DIR)/usr/lib/erlang -type d -name examples -prune -exec rm -rf {} \;
60
    for package in $(ERLANG_REMOVE_PACKAGES); do \
61
        rm -rf $(TARGET_DIR)/usr/lib/erlang/lib/$${package}-*; \
62
    done
63
endef
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.