• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/fetchmail/fetchmail.mk
Thomas PetazzoniThomas Petazzoni committed a2b66b348af09 Jun 2016
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# fetchmail
4
#
5
################################################################################
6
​
7
FETCHMAIL_VERSION_MAJOR = 6.3
8
FETCHMAIL_VERSION = $(FETCHMAIL_VERSION_MAJOR).26
9
FETCHMAIL_SOURCE = fetchmail-$(FETCHMAIL_VERSION).tar.xz
10
FETCHMAIL_SITE = http://downloads.sourceforge.net/project/fetchmail/branch_$(FETCHMAIL_VERSION_MAJOR)
11
FETCHMAIL_LICENSE = GPLv2; some exceptions are mentioned in COPYING
12
FETCHMAIL_LICENSE_FILES = COPYING
13
FETCHMAIL_AUTORECONF = YES
14
FETCHMAIL_GETTEXTIZE = YES
15
​
16
FETCHMAIL_CONF_ENV += LIBS="-lz"
17
​
18
FETCHMAIL_CONF_OPTS = \
19
    --with-ssl=$(STAGING_DIR)/usr
20
​
21
FETCHMAIL_DEPENDENCIES = \
22
    ca-certificates \
23
    openssl \
24
    $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
25
​
26
# fetchmailconf.py script is not (yet) python3-compliant.
27
# Prevent the pyc-compilation with python-3 from failing by removing this
28
# non-critical script.
29
ifeq ($(BR2_PACKAGE_PYTHON3),y)
30
define FETCHMAIL_REMOVE_FETCHMAILCONF_PY
31
    $(RM) -f $(TARGET_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/site-packages/fetchmailconf.py
32
endef
33
FETCHMAIL_POST_INSTALL_TARGET_HOOKS += FETCHMAIL_REMOVE_FETCHMAILCONF_PY
34
endif
35
​
36
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.