• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/freeswitch/freeswitch.mk
Bernd KuhlsBernd Kuhls committed 22137aa460618 Apr 2017
Raw file
Source viewDiff to previous
ifeq ($(BR2_i386)$(BR2_arm)$(BR2_armeb)$(BR2_aarch64)$(BR2_aarch64_be)$(BR2_mips)$(BR2_mipsel)$(BR2_mips64)$(BR2_mips64el)$(BR2_powerpc)$(BR2_powerpc64)$(BR2_powerpcle)$(BR2_x86_64),y)
 
1
################################################################################
2
#
3
# freeswitch
4
#
5
################################################################################
6
​
7
FREESWITCH_VERSION = 1.6.17
8
FREESWITCH_SOURCE = freeswitch-$(FREESWITCH_VERSION).tar.xz
9
FREESWITCH_SITE = http://files.freeswitch.org/freeswitch-releases
10
FREESWITCH_LICENSE = MPL-1.1, \
11
    GPL-3.0+ with font exception (fonts), \
12
    Apache-2.0 (apr, apr-util), \
13
    LGPL-2.0+ (sofia-sip), \
14
    LGPL-2.1, GPL-2.0 (spandsp), \
15
    BSD-3-Clause (libsrtp), \
16
    tiff license
17
​
18
FREESWITCH_LICENSE_FILES = \
19
    COPYING \
20
    libs/apr/LICENSE \
21
    libs/apr-util/LICENSE \
22
    libs/sofia-sip/COPYING \
23
    libs/sofia-sip/COPYRIGHTS \
24
    libs/spandsp/COPYING \
25
    libs/srtp/LICENSE \
26
    libs/tiff-4.0.2/COPYRIGHT
27
​
28
# required dependencies
29
FREESWITCH_DEPENDENCIES = \
30
    host-pkgconf \
31
    jpeg \
32
    libcurl \
33
    openssl \
34
    pcre \
35
    speex \
36
    sqlite \
37
    util-linux \
38
    zlib
39
​
40
# disable display of ClueCon banner in fs_cli
41
FREESWITCH_CONF_ENV += \
42
    disable_cc=yes
43
​
44
# we neither need host-perl nor host-php
45
FREESWITCH_CONF_ENV += \
46
    ac_cv_prog_PERL=false \
47
    ac_cv_have_perl=no \
48
    ac_cv_prog_PHP=false \
49
    ac_cv_have_php=no \
50
    ac_cv_prog_PHP_CONFIG=false \
51
    ac_cv_have_php_config=no
52
​
53
# copied from freeswitch/configure.ac, line 258+
54
FREESWITCH_CONF_ENV += \
55
    ac_cv_file__dev_ptmx=yes \
56
    ac_cv_va_copy=yes \
57
    ac_cv_file__dev_urandom=yes \
58
    ac_cv_func_realloc_0_nonnull=yes \
59
    ac_cv_func_malloc_0_nonnull=yes \
60
    ac_cv_func_setpgrp_void=yes \
61
    ac_cv_file__dev_zero=yes \
62
    apr_cv_tcp_nodelay_with_cork=yes \
63
    ac_cv_file_dbd_apr_dbd_mysql_c=no \
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.