• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/gdk-pixbuf/gdk-pixbuf.mk
Pierre CROKAERTPierre CROKAERT committed 5f3246a1d6920 Jan 2018
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# gdk-pixbuf
4
#
5
################################################################################
6
​
7
GDK_PIXBUF_VERSION_MAJOR = 2.36
8
GDK_PIXBUF_VERSION = $(GDK_PIXBUF_VERSION_MAJOR).10
9
GDK_PIXBUF_SOURCE = gdk-pixbuf-$(GDK_PIXBUF_VERSION).tar.xz
10
GDK_PIXBUF_SITE = http://ftp.gnome.org/pub/gnome/sources/gdk-pixbuf/$(GDK_PIXBUF_VERSION_MAJOR)
11
GDK_PIXBUF_LICENSE = LGPL-2.0+
12
GDK_PIXBUF_LICENSE_FILES = COPYING
13
GDK_PIXBUF_INSTALL_STAGING = YES
14
GDK_PIXBUF_DEPENDENCIES = \
15
    host-gdk-pixbuf host-libglib2 host-pkgconf \
16
    libglib2 $(if $(BR2_ENABLE_LOCALE),,libiconv)
17
HOST_GDK_PIXBUF_DEPENDENCIES = host-libpng host-pkgconf host-libglib2
18
​
19
GDK_PIXBUF_CONF_ENV = \
20
    ac_cv_path_GLIB_GENMARSHAL=$(LIBGLIB2_HOST_BINARY) \
21
    gio_can_sniff=no
22
​
23
HOST_GDK_PIXBUF_CONF_ENV = \
24
    gio_can_sniff=no
25
​
26
GDK_PIXBUF_CONF_OPTS = --disable-glibtest
27
​
28
ifneq ($(BR2_PACKAGE_LIBPNG),y)
29
GDK_PIXBUF_CONF_OPTS += --without-libpng
30
else
31
GDK_PIXBUF_DEPENDENCIES += libpng
32
endif
33
​
34
ifneq ($(BR2_PACKAGE_JPEG),y)
35
HOST_GDK_PIXBUF_CONF_OPTS += --without-libjpeg
36
GDK_PIXBUF_CONF_OPTS += --without-libjpeg
37
else
38
GDK_PIXBUF_DEPENDENCIES += jpeg
39
HOST_GDK_PIXBUF_DEPENDENCIES += host-libjpeg
40
endif
41
​
42
ifneq ($(BR2_PACKAGE_TIFF),y)
43
GDK_PIXBUF_CONF_OPTS += --without-libtiff
44
HOST_GDK_PIXBUF_CONF_OPTS += --without-libtiff
45
else
46
GDK_PIXBUF_DEPENDENCIES += tiff
47
GDK_PIXBUF_CONF_ENV += \
48
    LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs libtiff-4`"
49
HOST_GDK_PIXBUF_DEPENDENCIES += host-tiff
50
endif
51
​
52
ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
53
GDK_PIXBUF_CONF_OPTS += --with-x11
54
GDK_PIXBUF_DEPENDENCIES += xlib_libX11
55
endif
56
​
57
# gdk-pixbuf requires the loaders.cache file populated to work properly
58
# Rather than doing so at runtime, since the fs can be read-only, do so
59
# here after building and installing to target.
60
# And since the cache file will contain absolute host directory names we
61
# need to sanitize (strip) them.
62
ifeq ($(BR2_STATIC_LIBS),)
63
define GDK_PIXBUF_UPDATE_CACHE
64
    GDK_PIXBUF_MODULEDIR=$(HOST_DIR)/lib/gdk-pixbuf-2.0/2.10.0/loaders \
65
        $(HOST_DIR)/bin/gdk-pixbuf-query-loaders \
66
        > $(TARGET_DIR)/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
67
    $(SED) "s,$(HOST_DIR)/lib,/usr/lib,g" \
68
        $(TARGET_DIR)/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
69
endef
70
GDK_PIXBUF_POST_INSTALL_TARGET_HOOKS += GDK_PIXBUF_UPDATE_CACHE
71
endif
72
​
73
# Tests don't build correctly with uClibc
74
define GDK_PIXBUF_DISABLE_TESTS
75
    $(SED) 's/ tests//' $(@D)/Makefile.in
76
endef
77
GDK_PIXBUF_POST_PATCH_HOOKS += GDK_PIXBUF_DISABLE_TESTS
78
​
79
# Target gdk-pixbuf needs loaders.cache populated to build for the
80
# thumbnailer. Use the host-built since it matches the target options
81
# regarding mime types (which is the used information).
82
define GDK_PIXBUF_COPY_LOADERS_CACHE
83
    cp -f $(HOST_DIR)/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache \
84
        $(@D)/gdk-pixbuf
85
endef
86
GDK_PIXBUF_PRE_BUILD_HOOKS += GDK_PIXBUF_COPY_LOADERS_CACHE
87
​
88
$(eval $(autotools-package))
89
$(eval $(host-autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.