• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/i2c-tools/0005-lib-Module.mk-Fix-LIB_LINKS-dependency.patch
Angelo CompagnucciAngelo Compagnucci committed b52f74f428221 Dec 2017
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
From de278d0933e3caea2508f95fd00e7e338bc12e8f Mon Sep 17 00:00:00 2001
2
From: Angelo Compagnucci <angelo@amarulasolutions.com>
3
Date: Thu, 14 Dec 2017 13:34:29 +0100
4
Subject: lib/Module.mk: Fix LIB_LINKS dependency
5
​
6
LIB_LINKS should be added as a dependency only when
7
BUILD_DYNAMIC_LIB is enabled.
8
​
9
Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
10
Signed-off-by: Jean Delvare <jdelvare@suse.de>
11
Fixes: 9906b2ecb6ae ("Makefile: Add flag to disable dynamic library"
12
---
13
 lib/Module.mk | 3 +--
14
 1 file changed, 1 insertion(+), 2 deletions(-)
15
​
16
diff --git a/lib/Module.mk b/lib/Module.mk
17
index 67afe91..2ebc70d 100644
18
--- a/lib/Module.mk
19
+++ b/lib/Module.mk
20
@@ -27,10 +27,9 @@ LIB_SHSONAME := $(LIB_SHBASENAME).$(LIB_MAINVER)
21
 LIB_SHLIBNAME  := $(LIB_SHBASENAME).$(LIB_VER)
22
 LIB_STLIBNAME  := libi2c.a
23
 
24
-LIB_LINKS  := $(LIB_SHSONAME) $(LIB_SHBASENAME)
25
-
26
 LIB_TARGETS    :=
27
 ifeq ($(BUILD_DYNAMIC_LIB),1)
28
+LIB_LINKS  := $(LIB_SHSONAME) $(LIB_SHBASENAME)
29
 LIB_TARGETS    += $(LIB_SHLIBNAME)
30
 endif
31
 ifeq ($(BUILD_STATIC_LIB),1)
32
-- 
33
2.7.4
34
​
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.