• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/imagemagick/imagemagick.mk
Vicente Olivert RieraVicente Olivert Riera committed cf5e7bc63be24 Jun 2016
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# imagemagick
4
#
5
################################################################################
6
​
7
IMAGEMAGICK_VERSION = 7.0.2-1
8
IMAGEMAGICK_SOURCE = ImageMagick-$(IMAGEMAGICK_VERSION).tar.xz
9
IMAGEMAGICK_SITE = http://www.imagemagick.org/download/releases
10
IMAGEMAGICK_LICENSE = Apache-2.0
11
IMAGEMAGICK_LICENSE_FILES = LICENSE
12
​
13
IMAGEMAGICK_INSTALL_STAGING = YES
14
IMAGEMAGICK_CONFIG_SCRIPTS = \
15
    $(addsuffix -config,MagickCore MagickWand)
16
​
17
ifeq ($(BR2_INSTALL_LIBSTDCPP)$(BR2_USE_WCHAR),yy)
18
IMAGEMAGICK_CONFIG_SCRIPTS += Magick++-config
19
endif
20
​
21
IMAGEMAGICK_CONF_ENV = ac_cv_sys_file_offset_bits=64
22
​
23
IMAGEMAGICK_CONF_OPTS = \
24
    --program-transform-name='s,,,' \
25
    --disable-openmp \
26
    --without-djvu \
27
    --without-dps \
28
    --without-flif \
29
    --without-fpx \
30
    --without-gslib \
31
    --without-gvc \
32
    --without-jbig \
33
    --without-jp2 \
34
    --without-lqr \
35
    --without-openexr \
36
    --without-perl \
37
    --without-raqm \
38
    --without-wmf \
39
    --without-x
40
​
41
IMAGEMAGICK_DEPENDENCIES = host-pkgconf
42
​
43
ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
44
IMAGEMAGICK_CONF_OPTS += --with-fontconfig
45
IMAGEMAGICK_DEPENDENCIES += fontconfig
46
else
47
IMAGEMAGICK_CONF_OPTS += --without-fontconfig
48
endif
49
​
50
ifeq ($(BR2_PACKAGE_FREETYPE),y)
51
IMAGEMAGICK_CONF_OPTS += --with-freetype
52
IMAGEMAGICK_CONF_ENV += \
53
    ac_cv_path_freetype_config=$(STAGING_DIR)/usr/bin/freetype-config
54
IMAGEMAGICK_DEPENDENCIES += freetype
55
else
56
IMAGEMAGICK_CONF_OPTS += --without-freetype
57
endif
58
​
59
ifeq ($(BR2_PACKAGE_JPEG),y)
60
IMAGEMAGICK_CONF_OPTS += --with-jpeg
61
IMAGEMAGICK_DEPENDENCIES += jpeg
62
else
63
IMAGEMAGICK_CONF_OPTS += --without-jpeg
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.