• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/imagemagick/imagemagick.mk
Jerzy GrzegorekJerzy Grzegorek committed b2090e18a0a24 Mar 2016
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# imagemagick
4
#
5
################################################################################
6
​
7
IMAGEMAGICK_VERSION = 6.9.3-7
8
IMAGEMAGICK_SOURCE = ImageMagick-$(IMAGEMAGICK_VERSION).tar.xz
9
IMAGEMAGICK_SITE = http://www.imagemagick.org/download/releases
10
IMAGEMAGICK_LICENSE = Apache-2.0
11
IMAGEMAGICK_LICENSE_FILES = LICENSE
12
​
13
IMAGEMAGICK_INSTALL_STAGING = YES
14
IMAGEMAGICK_CONFIG_SCRIPTS = \
15
    $(addsuffix -config,Magick MagickCore MagickWand Wand)
16
​
17
ifeq ($(BR2_INSTALL_LIBSTDCPP)$(BR2_USE_WCHAR),yy)
18
IMAGEMAGICK_CONFIG_SCRIPTS += Magick++-config
19
endif
20
​
21
IMAGEMAGICK_CONF_ENV = ac_cv_sys_file_offset_bits=64
22
​
23
IMAGEMAGICK_CONF_OPTS = \
24
    --program-transform-name='s,,,' \
25
    --disable-openmp \
26
    --without-perl \
27
    --without-wmf \
28
    --without-openexr \
29
    --without-jp2 \
30
    --without-jbig \
31
    --without-gvc \
32
    --without-djvu \
33
    --without-dps \
34
    --without-gslib \
35
    --without-fpx \
36
    --without-x
37
​
38
IMAGEMAGICK_DEPENDENCIES = host-pkgconf
39
​
40
ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
41
IMAGEMAGICK_CONF_OPTS += --with-fontconfig
42
IMAGEMAGICK_DEPENDENCIES += fontconfig
43
else
44
IMAGEMAGICK_CONF_OPTS += --without-fontconfig
45
endif
46
​
47
ifeq ($(BR2_PACKAGE_FREETYPE),y)
48
IMAGEMAGICK_CONF_OPTS += --with-freetype
49
IMAGEMAGICK_CONF_ENV += \
50
    ac_cv_path_freetype_config=$(STAGING_DIR)/usr/bin/freetype-config
51
IMAGEMAGICK_DEPENDENCIES += freetype
52
else
53
IMAGEMAGICK_CONF_OPTS += --without-freetype
54
endif
55
​
56
ifeq ($(BR2_PACKAGE_JPEG),y)
57
IMAGEMAGICK_CONF_OPTS += --with-jpeg
58
IMAGEMAGICK_DEPENDENCIES += jpeg
59
else
60
IMAGEMAGICK_CONF_OPTS += --without-jpeg
61
endif
62
​
63
ifeq ($(BR2_PACKAGE_LCMS2),y)
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.