• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/input-tools/input-tools.mk
Bernd KuhlsBernd Kuhls committed 92500f911a330 Jan 2016
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# input-tools
4
#
5
################################################################################
6
​
7
INPUT_TOOLS_VERSION = 20051019
8
INPUT_TOOLS_SOURCE = joystick_$(INPUT_TOOLS_VERSION).orig.tar.gz
9
INPUT_TOOLS_PATCH = joystick_$(INPUT_TOOLS_VERSION)-5.diff.gz
10
INPUT_TOOLS_SITE = http://snapshot.debian.org/archive/debian/20101023T043132Z/pool/main/j/joystick
11
INPUT_TOOLS_LICENSE = GPLv2+
12
INPUT_TOOLS_LICENSE_FILES = utils/Makefile
13
​
14
INPUT_TOOLS_TARGETS_$(BR2_PACKAGE_INPUT_TOOLS_INPUTATTACH) += inputattach
15
INPUT_TOOLS_TARGETS_$(BR2_PACKAGE_INPUT_TOOLS_JSCAL)       += jscal
16
INPUT_TOOLS_TARGETS_$(BR2_PACKAGE_INPUT_TOOLS_JSTEST)      += jstest
17
​
18
define INPUT_TOOLS_DEBIAN_PATCHES
19
    if [ -d $(@D)/debian/patches ]; then \
20
        $(APPLY_PATCHES) $(@D) $(@D)/debian/patches \*.patch; \
21
    fi
22
endef
23
​
24
INPUT_TOOLS_POST_PATCH_HOOKS = INPUT_TOOLS_DEBIAN_PATCHES
25
​
26
# jscal needs -lm
27
define INPUT_TOOLS_BUILD_CMDS
28
    for i in $(filter-out jscal,$(INPUT_TOOLS_TARGETS_y)); do \
29
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(@D)/$$i $(@D)/utils/$$i.c \
30
            $(TARGET_LDFLAGS); \
31
    done
32
    for i in $(filter jscal,$(INPUT_TOOLS_TARGETS_y)); do \
33
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(@D)/$$i $(@D)/utils/$$i.c \
34
            $(TARGET_LDFLAGS) -lm; \
35
    done
36
endef
37
​
38
define INPUT_TOOLS_INSTALL_TARGET_CMDS
39
    for i in $(INPUT_TOOLS_TARGETS_y); do \
40
        $(INSTALL) -m 755 -D $(@D)/$$i $(TARGET_DIR)/usr/bin/$$i; \
41
    done
42
endef
43
​
44
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.