• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/intel-microcode/intel-microcode.mk
Maxime HadjinlianMaxime Hadjinlian committed ee8f0ecfbcd04 Feb 2014
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# intel-microcode
4
#
5
################################################################################
6
​
7
INTEL_MICROCODE_VERSION = 20140122
8
INTEL_MICROCODE_SOURCE = microcode-$(INTEL_MICROCODE_VERSION).tgz
9
INTEL_MICROCODE_SITE = http://downloadmirror.intel.com/23574/eng
10
INTEL_MICROCODE_LICENSE = PROPRIETARY
11
INTEL_MICROCODE_LICENSE_FILES = license.txt
12
INTEL_MICROCODE_REDISTRIBUTE = NO
13
​
14
# N.B. Don't strip any path components during extraction.
15
define INTEL_MICROCODE_EXTRACT_CMDS
16
    gzip -d -c $(DL_DIR)/$(INTEL_MICROCODE_SOURCE) | \
17
    tar --strip-components=0 -C $(@D) -xf -
18
    head -n 33 $(@D)/microcode.dat > $(@D)/license.txt
19
endef
20
​
21
define INTEL_MICROCODE_INSTALL_TARGET_CMDS
22
    $(INSTALL) -D -m 0644 $(@D)/microcode.dat \
23
        $(TARGET_DIR)/usr/share/misc/intel-microcode.dat
24
endef
25
​
26
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.