• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/jimtcl/jimtcl.mk
gilles.talis@gmail.comgilles.talis@gmail.com committed 0e4f6dcb04810 Jul 2013
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# jimtcl
4
#
5
################################################################################
6
​
7
JIMTCL_VERSION = 0.73
8
JIMTCL_SITE = $(BR2_DEBIAN_MIRROR)/debian/pool/main/j/jimtcl
9
JIMTCL_SOURCE = jimtcl_$(JIMTCL_VERSION).orig.tar.bz2
10
JIMTCL_INSTALL_STAGING = YES
11
JIMTCL_LICENSE = BSD-2c
12
JIMTCL_LICENSE_FILES = LICENSE
13
​
14
JIMTCL_HEADERS_TO_INSTALL = \
15
    jim.h \
16
    jim-eventloop.h \
17
    jim-signal.h \
18
    jim-subcmd.h \
19
    jim-win32compat.h \
20
    jim-config.h \
21
​
22
ifeq ($(BR2_PACKAGE_TCL),)
23
define JIMTCL_LINK_TCLSH
24
    ln -sf jimsh $(TARGET_DIR)/usr/bin/tclsh
25
endef
26
endif
27
​
28
ifeq ($(BR2_PREFER_STATIC_LIB),y)
29
JIMTCL_SHARED =
30
JIMTCL_LIB = a
31
JIMTCL_INSTALL_LIB =
32
else
33
JIMTCL_SHARED = --shared
34
JIMTCL_LIB = so
35
JIMTCL_INSTALL_LIB = $(INSTALL) -D $(@D)/libjim.$(JIMTCL_LIB) \
36
             $(TARGET_DIR)/usr/lib/libjim.$(JIMTCL_LIB)
37
endif
38
​
39
define JIMTCL_CONFIGURE_CMDS
40
    (cd $(@D); \
41
        $(TARGET_CONFIGURE_OPTS) \
42
        ./configure --prefix=/usr \
43
        $(JIMTCL_SHARED) \
44
    )
45
endef
46
​
47
define JIMTCL_BUILD_CMDS
48
    $(MAKE) -C $(@D)
49
endef
50
​
51
define JIMTCL_INSTALL_STAGING_CMDS
52
    for i in $(JIMTCL_HEADERS_TO_INSTALL); do \
53
        cp -a $(@D)/$$i $(STAGING_DIR)/usr/include/ ; \
54
    done; \
55
    $(INSTALL) -D $(@D)/libjim.$(JIMTCL_LIB) $(STAGING_DIR)/usr/lib/libjim.$(JIMTCL_LIB)
56
endef
57
​
58
define JIMTCL_INSTALL_TARGET_CMDS
59
    $(INSTALL) -D $(@D)/jimsh $(TARGET_DIR)/usr/bin/jimsh
60
    $(JIMTCL_INSTALL_LIB)
61
    $(JIMTCL_LINK_TCLSH)
62
endef
63
​
64
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.