• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/lcdapi/lcdapi.mk
Bernd KuhlsBernd Kuhls committed aa88449b9b925 Jul 2017
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# lcdapi
4
#
5
################################################################################
6
​
7
LCDAPI_VERSION = v0.11
8
LCDAPI_SITE = $(call github,spdawson,lcdapi,$(LCDAPI_VERSION))
9
LCDAPI_LICENSE = LGPL-2.1+
10
LCDAPI_LICENSE_FILES = COPYING
11
LCDAPI_AUTORECONF = YES
12
LCDAPI_INSTALL_STAGING = YES
13
​
14
# Internal error, aborting at dw2gencfi.c:214 in emit_expr_encoded
15
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79509
16
ifeq ($(BR2_m68k_cf),y)
17
LCDAPI_CONF_OPTS += CXXFLAGS="$(TARGET_CXXFLAGS) -fno-dwarf2-cfi-asm"
18
endif
19
​
20
define LCDAPI_CREATE_M4_DIR
21
    mkdir -p $(@D)/m4
22
endef
23
​
24
LCDAPI_POST_PATCH_HOOKS += LCDAPI_CREATE_M4_DIR
25
​
26
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.