• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libasplib/libasplib.mk
Rahul BedarkarRahul Bedarkar committed 337aa51f3fd30 Mar 2017
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libasplib
4
#
5
################################################################################
6
​
7
LIBASPLIB_VERSION = be7fac89218a84b75f7598e3d76625ece99296f2
8
LIBASPLIB_SITE = $(call github,AchimTuran,asplib,$(LIBASPLIB_VERSION))
9
LIBASPLIB_LICENSE = GPL-3.0+
10
LIBASPLIB_LICENSE_FILES = LICENSE
11
LIBASPLIB_INSTALL_STAGING = YES
12
​
13
LIBASPLIB_CONF_OPTS = \
14
    -DASPLIB_MODULES_TO_BUILD=some \
15
    -DBUILD_BIQUAD=ON \
16
    -DBUILD_IIR=ON \
17
    -DBUILD_LOGGER=ON \
18
    -DBUILD_SIGNALS=ON \
19
    -DBUILD_TIMER=ON
20
​
21
# Internal error, aborting at dw2gencfi.c:214 in emit_expr_encoded
22
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79509
23
ifeq ($(BR2_m68k_cf),y)
24
LIBASPLIB_CXXFLAGS += -fno-dwarf2-cfi-asm
25
endif
26
​
27
LIBASPLIB_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) $(LIBASPLIB_CXXFLAGS)"
28
​
29
$(eval $(cmake-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.