• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libbluray/libbluray.mk
Rahul BedarkarRahul Bedarkar committed 30a3e8d108d30 Mar 2017
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libbluray
4
#
5
################################################################################
6
​
7
LIBBLURAY_VERSION = 1.0.0
8
LIBBLURAY_SITE = http://get.videolan.org/libbluray/$(LIBBLURAY_VERSION)
9
LIBBLURAY_SOURCE = libbluray-$(LIBBLURAY_VERSION).tar.bz2
10
LIBBLURAY_INSTALL_STAGING = YES
11
LIBBLURAY_LICENSE = LGPL-2.1+
12
LIBBLURAY_LICENSE_FILES = COPYING
13
LIBBLURAY_DEPENDENCIES = host-pkgconf
14
​
15
LIBBLURAY_CONF_OPTS = --enable-udf --disable-bdjava
16
​
17
ifeq ($(BR2_PACKAGE_LIBICONV),y)
18
LIBBLURAY_DEPENDENCIES += libiconv
19
endif
20
​
21
ifeq ($(BR2_PACKAGE_FREETYPE),y)
22
LIBBLURAY_DEPENDENCIES += freetype
23
LIBBLURAY_CONF_OPTS += --with-freetype
24
else
25
LIBBLURAY_CONF_OPTS += --without-freetype
26
endif
27
​
28
ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
29
LIBBLURAY_DEPENDENCIES += fontconfig
30
LIBBLURAY_CONF_OPTS += --with-fontconfig
31
else
32
LIBBLURAY_CONF_OPTS += --without-fontconfig
33
endif
34
​
35
ifeq ($(BR2_PACKAGE_LIBXML2),y)
36
LIBBLURAY_DEPENDENCIES += libxml2
37
LIBBLURAY_CONF_OPTS += --with-libxml2
38
else
39
LIBBLURAY_CONF_OPTS += --without-libxml2
40
endif
41
​
42
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.