• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libcec/libcec.mk
Bernd KuhlsBernd Kuhls committed dedf1fb574521 Feb 2016
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libcec
4
#
5
################################################################################
6
​
7
LIBCEC_VERSION = 2c675dac48387c48c7f43c5d2547ef0c4ef5c7dd
8
LIBCEC_SITE = $(call github,Pulse-Eight,libcec,$(LIBCEC_VERSION))
9
LIBCEC_LICENSE = GPLv2+
10
LIBCEC_LICENSE_FILES = COPYING
11
​
12
# Autoreconf required due to being a dev tarball and not a release tarball.
13
LIBCEC_AUTORECONF = YES
14
LIBCEC_INSTALL_STAGING = YES
15
LIBCEC_DEPENDENCIES = host-pkgconf libplatform
16
​
17
ifeq ($(BR2_PACKAGE_LOCKDEV),y)
18
LIBCEC_DEPENDENCIES += lockdev
19
endif
20
​
21
ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
22
LIBCEC_DEPENDENCIES += udev
23
endif
24
​
25
ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
26
LIBCEC_DEPENDENCIES += host-swig $(if $(BR2_PACKAGE_PYTHON3),python3,python)
27
endif
28
​
29
ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
30
LIBCEC_DEPENDENCIES += rpi-userland
31
LIBCEC_CONF_OPTS += \
32
    -DCMAKE_C_FLAGS="-lvcos -lvchiq_arm" \
33
    -DCMAKE_CXX_FLAGS="-I$(STAGING_DIR)/usr/include/interface/vmcs_host/linux \
34
        -I$(STAGING_DIR)/usr/include/interface/vcos/pthreads"
35
endif
36
​
37
ifeq ($(BR2_PACKAGE_XLIB_LIBXRANDR),y)
38
LIBCEC_DEPENDENCIES += xlib_libXrandr
39
endif
40
​
41
$(eval $(cmake-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.