• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libcli/libcli.mk
Steve JamesSteve James committed e51be5039f714 Jan 2015
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libcli
4
#
5
################################################################################
6
​
7
LIBCLI_VERSION = c63c9d35144939c8b4fa3c5394aed2e29ff517b0
8
LIBCLI_SITE = $(call github,dparrish,libcli,$(LIBCLI_VERSION))
9
LIBCLI_LICENSE = LGPLv2.1
10
LIBCLI_LICENSE_FILES = COPYING
11
LIBCLI_INSTALL_STAGING = YES
12
​
13
# We will pass optimisation level via CFLAGS so remove libcli default
14
LIBCLI_MAKE_ARGS += OPTIM=
15
​
16
# We can't run the test harness
17
LIBCLI_MAKE_ARGS += TESTS=
18
​
19
# Disable the static library for shared only build
20
ifeq ($(BR2_SHARED_LIBS),y)
21
LIBCLI_MAKE_ARGS += STATIC_LIB=
22
endif
23
​
24
# Disable the shared library for static only build
25
ifeq ($(BR2_STATIC_LIBS),y)
26
LIBCLI_MAKE_ARGS += DYNAMIC_LIB=
27
endif
28
​
29
define LIBCLI_BUILD_CMDS
30
    $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
31
        $(LIBCLI_MAKE_ARGS)
32
endef
33
​
34
define LIBCLI_INSTALL_STAGING_CMDS
35
    $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
36
        $(LIBCLI_MAKE_ARGS) DESTDIR=$(STAGING_DIR) PREFIX=/usr install
37
endef
38
​
39
define LIBCLI_INSTALL_TARGET_CMDS
40
    $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
41
        $(LIBCLI_MAKE_ARGS) DESTDIR=$(TARGET_DIR) PREFIX=/usr install
42
endef
43
​
44
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.