• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libcurl/libcurl.mk
Gustavo ZacariasGustavo Zacarias committed 8abdd5fa3e029 Jan 2014
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# libcurl
4
#
5
################################################################################
6
​
7
LIBCURL_VERSION = 7.35.0
8
LIBCURL_SOURCE = curl-$(LIBCURL_VERSION).tar.bz2
9
LIBCURL_SITE = http://curl.haxx.se/download
10
LIBCURL_DEPENDENCIES = host-pkgconf \
11
    $(if $(BR2_PACKAGE_ZLIB),zlib) \
12
    $(if $(BR2_PACKAGE_LIBIDN),libidn) \
13
    $(if $(BR2_PACKAGE_RTMPDUMP),rtmpdump)
14
LIBCURL_LICENSE = ICS
15
LIBCURL_LICENSE_FILES = COPYING
16
LIBCURL_INSTALL_STAGING = YES
17
​
18
# We disable NTLM support because it uses fork(), which doesn't work
19
# on non-MMU platforms. Moreover, this authentication method is
20
# probably almost never used. See
21
# http://curl.haxx.se/docs/manpage.html#--ntlm.
22
LIBCURL_CONF_OPT = --disable-verbose --disable-manual --disable-ntlm-wb \
23
    --enable-hidden-symbols --with-random=/dev/urandom
24
LIBCURL_CONFIG_SCRIPTS = curl-config
25
​
26
ifeq ($(BR2_PACKAGE_OPENSSL),y)
27
LIBCURL_DEPENDENCIES += openssl
28
LIBCURL_CONF_ENV += ac_cv_lib_crypto_CRYPTO_lock=yes
29
# configure adds the cross openssl dir to LD_LIBRARY_PATH which screws up
30
# native stuff during the rest of configure when target == host.
31
# Fix it by setting LD_LIBRARY_PATH to something sensible so those libs
32
# are found first.
33
LIBCURL_CONF_ENV += LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:/lib:/usr/lib
34
LIBCURL_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr \
35
    --with-ca-path=/etc/ssl/certs
36
else ifeq ($(BR2_PACKAGE_GNUTLS),y)
37
LIBCURL_CONF_OPT += --with-gnutls=$(STAGING_DIR)/usr
38
LIBCURL_DEPENDENCIES += gnutls
39
else ifeq ($(BR2_PACKAGE_POLARSSL),y)
40
LIBCURL_CONF_OPT += --with-polarssl=$(STAGING_DIR)/usr
41
LIBCURL_DEPENDENCIES += polarssl
42
else ifeq ($(BR2_PACKAGE_LIBNSS),y)
43
LIBCURL_CONF_OPT += --with-nss=$(STAGING_DIR)/usr
44
LIBCURL_CONF_ENV += CPPFLAGS="$(TARGET_CPPFLAGS) `$(PKG_CONFIG_HOST_BINARY) nspr nss --cflags`"
45
LIBCURL_DEPENDENCIES += libnss
46
else
47
LIBCURL_CONF_OPT += --without-ssl --without-gnutls \
48
    --without-polarssl --without-nss
49
endif
50
​
51
# Configure curl to support libssh2
52
ifeq ($(BR2_PACKAGE_LIBSSH2),y)
53
LIBCURL_DEPENDENCIES += libssh2
54
LIBCURL_CONF_OPT += --with-libssh2
55
else
56
LIBCURL_CONF_OPT += --without-libssh2
57
endif
58
​
59
define LIBCURL_FIX_DOT_PC
60
    printf 'Requires: openssl\n' >>$(@D)/libcurl.pc.in
61
endef
62
LIBCURL_POST_PATCH_HOOKS += $(if $(BR2_PACKAGE_OPENSSL),LIBCURL_FIX_DOT_PC)
63
​
64
ifeq ($(BR2_PACKAGE_CURL),)
65
define LIBCURL_TARGET_CLEANUP
66
    rm -rf $(TARGET_DIR)/usr/bin/curl
67
endef
68
LIBCURL_POST_INSTALL_TARGET_HOOKS += LIBCURL_TARGET_CLEANUP
69
endif
70
​
71
$(eval $(autotools-package))
72
​
73
curl: libcurl
74
curl-clean: libcurl-clean
75
curl-dirclean: libcurl-dirclean
76
curl-source: libcurl-source
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.