• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libdrm/libdrm.mk
Bernd KuhlsBernd Kuhls committed 96a52efb09507 Mar 2018
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libdrm
4
#
5
################################################################################
6
​
7
LIBDRM_VERSION = 2.4.91
8
LIBDRM_SOURCE = libdrm-$(LIBDRM_VERSION).tar.bz2
9
LIBDRM_SITE = https://dri.freedesktop.org/libdrm
10
LIBDRM_LICENSE = MIT
11
LIBDRM_INSTALL_STAGING = YES
12
​
13
# patch 0003-configure-Makefile.am-use-pkg-config-to-discover-lib.patch
14
# touching configure.ac/Makefile.am (and host-xutil_util-macros dependency)
15
LIBDRM_AUTORECONF = YES
16
​
17
LIBDRM_DEPENDENCIES = \
18
    libpthread-stubs \
19
    host-pkgconf \
20
    host-xutil_util-macros
21
​
22
LIBDRM_CONF_OPTS = \
23
    --disable-cairo-tests \
24
    --disable-manpages
25
​
26
LIBDRM_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
27
​
28
ifeq ($(BR2_PACKAGE_LIBATOMIC_OPS),y)
29
LIBDRM_DEPENDENCIES += libatomic_ops
30
ifeq ($(BR2_sparc_v8)$(BR2_sparc_leon3),y)
31
LIBDRM_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -DAO_NO_SPARC_V9"
32
endif
33
endif
34
​
35
ifeq ($(BR2_PACKAGE_LIBDRM_INTEL),y)
36
LIBDRM_CONF_OPTS += --enable-intel
37
LIBDRM_DEPENDENCIES += libpciaccess
38
else
39
LIBDRM_CONF_OPTS += --disable-intel
40
endif
41
​
42
ifeq ($(BR2_PACKAGE_LIBDRM_RADEON),y)
43
LIBDRM_CONF_OPTS += --enable-radeon
44
else
45
LIBDRM_CONF_OPTS += --disable-radeon
46
endif
47
​
48
ifeq ($(BR2_PACKAGE_LIBDRM_AMDGPU),y)
49
LIBDRM_CONF_OPTS += --enable-amdgpu
50
else
51
LIBDRM_CONF_OPTS += --disable-amdgpu
52
endif
53
​
54
ifeq ($(BR2_PACKAGE_LIBDRM_NOUVEAU),y)
55
LIBDRM_CONF_OPTS += --enable-nouveau
56
else
57
LIBDRM_CONF_OPTS += --disable-nouveau
58
endif
59
​
60
ifeq ($(BR2_PACKAGE_LIBDRM_VMWGFX),y)
61
LIBDRM_CONF_OPTS += --enable-vmwgfx
62
else
63
LIBDRM_CONF_OPTS += --disable-vmwgfx
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.