• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libglew/libglew.mk
Rahul BedarkarRahul Bedarkar committed 9f59b378a3630 Mar 2017
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libglew
4
#
5
################################################################################
6
​
7
LIBGLEW_VERSION = 2.0.0
8
LIBGLEW_SOURCE = glew-$(LIBGLEW_VERSION).tgz
9
LIBGLEW_SITE = http://sourceforge.net/projects/glew/files/glew/$(LIBGLEW_VERSION)
10
LIBGLEW_LICENSE = BSD-3-Clause, MIT
11
LIBGLEW_LICENSE_FILES = LICENSE.txt
12
LIBGLEW_INSTALL_STAGING = YES
13
LIBGLEW_DEPENDENCIES = libgl xlib_libX11 xlib_libXext xlib_libXi xlib_libXmu
14
​
15
# using $TARGET_CONFIGURE_OPTS breaks compilation
16
define LIBGLEW_BUILD_CMDS
17
    $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
18
        GLEW_DEST="/usr" LIBDIR="/usr/lib" \
19
        AR="$(TARGET_AR)" CC="$(TARGET_CC)" \
20
        LD="$(TARGET_CC)" STRIP="$(TARGET_STRIP)" \
21
        POPT="$(TARGET_CFLAGS)" LDFLAGS.EXTRA="$(TARGET_LDFLAGS)"
22
endef
23
​
24
define LIBGLEW_INSTALL_STAGING_CMDS
25
    $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
26
        GLEW_DEST="$(STAGING_DIR)/usr" LIBDIR="$(STAGING_DIR)/usr/lib" \
27
        $(TARGET_CONFIGURE_OPTS) install
28
endef
29
​
30
define LIBGLEW_INSTALL_TARGET_CMDS
31
    $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
32
        GLEW_DEST="$(TARGET_DIR)/usr" LIBDIR="$(TARGET_DIR)/usr/lib" \
33
        $(TARGET_CONFIGURE_OPTS) install
34
endef
35
​
36
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.