• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libglob/libglob.mk
Rahul BedarkarRahul Bedarkar committed 9f59b378a3630 Mar 2017
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libglob
4
#
5
################################################################################
6
​
7
LIBGLOB_VERSION = 1.0
8
LIBGLOB_SITE = $(call github,voidlinux,libglob,$(LIBGLOB_VERSION))
9
LIBGLOB_LICENSE = BSD-3-Clause
10
LIBGLOB_LICENSE_FILES = LICENSE
11
LIBGLOB_INSTALL_STAGING = YES
12
​
13
ifeq ($(BR2_SHARED_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
14
LIBGLOB_MAKE_TARGETS += libglob.so
15
# $1: destination directory
16
define LIBGLOB_INSTALL_SHARED
17
    $(INSTALL) -m 0755 -D $(@D)/libglob.so.0.0.0 \
18
        $(1)/usr/lib/libglob.so.0.0.0
19
    ln -sf libglob.so.0.0.0 $(1)/usr/lib/libglob.so.0
20
    ln -sf libglob.so.0.0.0 $(1)/usr/lib/libglob.so
21
endef
22
endif
23
​
24
ifeq ($(BR2_STATIC_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
25
LIBGLOB_MAKE_TARGETS += libglob.a
26
# $1: destination directory
27
define LIBGLOB_INSTALL_STATIC
28
    $(INSTALL) -m 0644 -D $(@D)/libglob.a $(1)/usr/lib/libglob.a
29
endef
30
endif
31
​
32
define LIBGLOB_BUILD_CMDS
33
    $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
34
        $(LIBGLOB_MAKE_TARGETS)
35
endef
36
​
37
define LIBGLOB_INSTALL_STAGING_CMDS
38
    $(INSTALL) -m 0644 -D $(@D)/glob.h \
39
        $(STAGING_DIR)/usr/include/libglob/glob.h
40
    $(call LIBGLOB_INSTALL_SHARED,$(STAGING_DIR))
41
    $(call LIBGLOB_INSTALL_STATIC,$(STAGING_DIR))
42
endef
43
​
44
define LIBGLOB_INSTALL_TARGET_CMDS
45
    $(call LIBGLOB_INSTALL_SHARED,$(TARGET_DIR))
46
endef
47
​
48
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.