• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/liblinear/liblinear.mk
Rahul BedarkarRahul Bedarkar committed 9f59b378a3630 Mar 2017
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# liblinear
4
#
5
################################################################################
6
​
7
LIBLINEAR_VERSION = 2.1
8
LIBLINEAR_SITE = http://www.csie.ntu.edu.tw/~cjlin/liblinear
9
LIBLINEAR_LICENSE = BSD-3-Clause
10
LIBLINEAR_LICENSE_FILES = COPYRIGHT
11
LIBLINEAR_INSTALL_STAGING = YES
12
LIBLINEAR_CFLAGS = $(TARGET_CFLAGS)
13
​
14
ifeq ($(BR2_SHARED_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
15
# $1: destination directory
16
define LIBLINEAR_INSTALL_SHARED
17
    $(INSTALL) -m 0644 -D $(@D)/liblinear.so.3 $(1)/usr/lib/liblinear.so.3
18
    ln -sf liblinear.so.3 $(1)/usr/lib/liblinear.so
19
endef
20
LIBLINEAR_CFLAGS += -fPIC
21
endif
22
​
23
ifeq ($(BR2_STATIC_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
24
# $1: destination directory
25
define LIBLINEAR_INSTALL_STATIC
26
    $(INSTALL) -m 0644 -D $(@D)/liblinear.a $(1)/usr/lib/liblinear.a
27
endef
28
endif
29
​
30
define LIBLINEAR_BUILD_CMDS
31
    $(MAKE) $(TARGET_CONFIGURE_OPTS) CFLAGS="$(LIBLINEAR_CFLAGS)" -C $(@D) \
32
        $(if $(BR2_SHARED_LIBS)$(BR2_SHARED_STATIC_LIBS),lib) \
33
        $(if $(BR2_STATIC_LIBS)$(BR2_SHARED_STATIC_LIBS),static-lib)
34
endef
35
​
36
define LIBLINEAR_INSTALL_STAGING_CMDS
37
    $(INSTALL) -m 0644 -D $(@D)/linear.h $(STAGING_DIR)/usr/include/linear.h
38
    $(call LIBLINEAR_INSTALL_SHARED,$(STAGING_DIR))
39
    $(call LIBLINEAR_INSTALL_STATIC,$(STAGING_DIR))
40
endef
41
​
42
define LIBLINEAR_INSTALL_TARGET_CMDS
43
    $(call LIBLINEAR_INSTALL_SHARED,$(TARGET_DIR))
44
endef
45
​
46
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.