• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libopenh264/libopenh264.mk
Rahul BedarkarRahul Bedarkar committed 96e9480fbc730 Mar 2017
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libopenh264
4
#
5
################################################################################
6
​
7
LIBOPENH264_VERSION = v1.6.0
8
LIBOPENH264_SITE = $(call github,cisco,openh264,$(LIBOPENH264_VERSION))
9
LIBOPENH264_LICENSE = BSD-2-Clause
10
LIBOPENH264_LICENSE_FILES = LICENSE
11
LIBOPENH264_INSTALL_STAGING = YES
12
​
13
ifeq ($(BR2_aarch64),y)
14
LIBOPENH264_ARCH = aarch64
15
else ifeq ($(BR2_arm)$(BR2_armeb),y)
16
LIBOPENH264_ARCH = arm
17
else ifeq ($(BR2_i386),y)
18
LIBOPENH264_ARCH = x86
19
LIBOPENH264_DEPENDENCIES += host-nasm
20
else ifeq ($(BR2_mips)$(BR2_mipsel),y)
21
LIBOPENH264_ARCH = mips
22
else ifeq ($(BR2_mips64)$(BR2_mips64el),y)
23
LIBOPENH264_ARCH = mips64
24
else ifeq ($(BR2_x86_64),y)
25
LIBOPENH264_ARCH = x86_64
26
LIBOPENH264_DEPENDENCIES += host-nasm
27
endif
28
​
29
# ENABLE64BIT is really only used for x86-64, other 64 bits
30
# architecture don't need it.
31
LIBOPENH264_MAKE_OPTS = \
32
    ARCH=$(LIBOPENH264_ARCH) \
33
    ENABLE64BIT=$(if $(BR2_x86_64),Yes,No)
34
​
35
define LIBOPENH264_BUILD_CMDS
36
    $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
37
        $(LIBOPENH264_MAKE_OPTS)
38
endef
39
​
40
define LIBOPENH264_INSTALL_STAGING_CMDS
41
    $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
42
        $(LIBOPENH264_MAKE_OPTS) \
43
        DESTDIR=$(STAGING_DIR) PREFIX=/usr install
44
endef
45
​
46
define LIBOPENH264_INSTALL_TARGET_CMDS
47
    $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
48
        $(LIBOPENH264_MAKE_OPTS) \
49
        DESTDIR=$(TARGET_DIR) PREFIX=/usr install
50
endef
51
​
52
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.