• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libpjsip/libpjsip.mk
Adam DuskettAdam Duskett committed ed0d9d6f36d12 Mar 2018
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libpjsip
4
#
5
################################################################################
6
​
7
LIBPJSIP_VERSION = 2.7.2
8
LIBPJSIP_SOURCE = pjproject-$(LIBPJSIP_VERSION).tar.bz2
9
LIBPJSIP_SITE = http://www.pjsip.org/release/$(LIBPJSIP_VERSION)
10
LIBPJSIP_DEPENDENCIES = libsrtp
11
LIBPJSIP_LICENSE = GPL-2.0+
12
LIBPJSIP_LICENSE_FILES = COPYING
13
LIBPJSIP_INSTALL_STAGING = YES
14
LIBPJSIP_MAKE = $(MAKE1)
15
​
16
LIBPJSIP_CFLAGS = $(TARGET_CFLAGS) -DPJ_HAS_IPV6=1
17
​
18
# relocation truncated to fit: R_68K_GOT16O
19
ifeq ($(BR2_m68k_cf),y)
20
LIBPJSIP_CFLAGS += -mxgot
21
endif
22
​
23
LIBPJSIP_CONF_ENV = \
24
    LD="$(TARGET_CC)" \
25
    CFLAGS="$(LIBPJSIP_CFLAGS)"
26
​
27
LIBPJSIP_CONF_OPTS = \
28
    --disable-sound \
29
    --disable-gsm-codec \
30
    --disable-speex-codec \
31
    --disable-speex-aec \
32
    --disable-resample \
33
    --disable-video \
34
    --disable-opencore-amr \
35
    --disable-g7221-codec \
36
    --disable-ilbc-codec \
37
    --disable-libwebrtc \
38
    --disable-opus \
39
    --disable-oss \
40
    --disable-ext-sound \
41
    --disable-g711-codec \
42
    --disable-l16-codec \
43
    --disable-g722-codec \
44
    --disable-libsamplerate \
45
    --disable-sdl \
46
    --disable-ffmpeg \
47
    --disable-v4l2 \
48
    --disable-openh264 \
49
    --disable-libyuv \
50
    --disable-ipp \
51
    --disable-silk \
52
    --with-external-srtp
53
​
54
# Note: aconfigure.ac is broken: --enable-epoll or --disable-epoll will
55
# both enable it. But that's OK, epoll is better than the alternative,
56
# so we want to use it.
57
LIBPJSIP_CONF_OPTS += --enable-epoll
58
​
59
ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
60
LIBPJSIP_DEPENDENCIES += libopenssl
61
LIBPJSIP_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
62
else
63
LIBPJSIP_CONF_OPTS += --disable-ssl
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.