• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libqrencode/libqrencode.mk
Rahul BedarkarRahul Bedarkar committed 30a3e8d108d30 Mar 2017
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# libqrencode
4
#
5
################################################################################
6
​
7
LIBQRENCODE_VERSION = 3.4.2
8
LIBQRENCODE_SOURCE = qrencode-$(LIBQRENCODE_VERSION).tar.gz
9
LIBQRENCODE_SITE = http://fukuchi.org/works/qrencode
10
LIBQRENCODE_DEPENDENCIES = host-pkgconf
11
LIBQRENCODE_INSTALL_STAGING = YES
12
LIBQRENCODE_LICENSE = LGPL-2.1+
13
LIBQRENCODE_LICENSE_FILES = COPYING
14
​
15
ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
16
LIBQRENCODE_CONF_ENV += LIBS='-pthread'
17
else
18
LIBQRENCODE_CONF_OPTS += --disable-thread-safety
19
endif
20
​
21
ifeq ($(BR2_PACKAGE_LIBQRENCODE_TOOLS),y)
22
LIBQRENCODE_CONF_OPTS += --with-tools=yes
23
LIBQRENCODE_DEPENDENCIES += libpng
24
else
25
LIBQRENCODE_CONF_OPTS += --with-tools=no
26
endif
27
​
28
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.