• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libsquish/libsquish.mk
Bernd KuhlsBernd Kuhls committed df88cdfe44622 Jul 2015
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libsquish
4
#
5
################################################################################
6
​
7
LIBSQUISH_VERSION = 1.13
8
LIBSQUISH_SOURCE = libsquish-$(LIBSQUISH_VERSION).tgz
9
LIBSQUISH_SITE = http://downloads.sourceforge.net/project/libsquish
10
LIBSQUISH_INSTALL_STAGING = YES
11
LIBSQUISH_STRIP_COMPONENTS = 0
12
LIBSQUISH_LICENSE = MIT
13
LIBSQUISH_LICENSE_FILES = README
14
​
15
define LIBSQUISH_BUILD_CMDS
16
    $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
17
endef
18
​
19
define LIBSQUISH_INSTALL_STAGING_CMDS
20
    mkdir -p $(STAGING_DIR)/usr/include
21
    mkdir -p $(STAGING_DIR)/usr/lib
22
    $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
23
        install PREFIX=/usr INSTALL_DIR=$(STAGING_DIR)/usr
24
    $(INSTALL) -D -m 644 $(@D)/squish.pc $(STAGING_DIR)/usr/lib/pkgconfig/squish.pc
25
    ln -sf libsquish.so.0.0 $(STAGING_DIR)/usr/lib/libsquish.so
26
    ln -sf libsquish.so.0.0 $(STAGING_DIR)/usr/lib/libsquish.so.0
27
endef
28
​
29
define LIBSQUISH_INSTALL_TARGET_CMDS
30
    mkdir -p $(TARGET_DIR)/usr/include
31
    mkdir -p $(TARGET_DIR)/usr/lib
32
    $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
33
        install PREFIX=/usr INSTALL_DIR=$(TARGET_DIR)/usr
34
    ln -sf libsquish.so.0.0 $(TARGET_DIR)/usr/lib/libsquish.so.0
35
endef
36
​
37
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.