• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/libvips/libvips.mk
Waldemar BrodkorbWaldemar Brodkorb committed c4486e8c94723 Nov 2015
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# libvips
4
#
5
################################################################################
6
​
7
LIBVIPS_VERSION_MAJOR = 7.42
8
LIBVIPS_VERSION = $(LIBVIPS_VERSION_MAJOR).2
9
LIBVIPS_SOURCE = vips-$(LIBVIPS_VERSION).tar.gz
10
LIBVIPS_SITE = http://www.vips.ecs.soton.ac.uk/supported/$(LIBVIPS_VERSION_MAJOR)
11
LIBVIPS_LICENSE = LGPLv2.1+
12
LIBVIPS_LICENSE_FILES = COPYING
13
# We're patching gtk-doc.make, so need to autoreconf
14
LIBVIPS_AUTORECONF = YES
15
​
16
# Sparc64 compile fails, for all optimization levels except -O0. To
17
# fix the problem, use -O0 with no optimization instead. Bug reported
18
# upstream at https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69038.
19
ifeq ($(BR2_sparc64),y)
20
LIBVIPS_CXXFLAGS += -O0
21
endif
22
​
23
LIBVIPS_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) $(LIBVIPS_CXXFLAGS)"
24
​
25
LIBVIPS_CONF_OPTS = \
26
    --disable-introspection \
27
    --without-dmalloc \
28
    --without-gsf \
29
    --without-magick \
30
    --without-orc \
31
    --without-lcms \
32
    --without-OpenEXR \
33
    --without-openslide \
34
    --without-matio \
35
    --without-cfitsio \
36
    --without-libwebp \
37
    --without-pangoft2 \
38
    --without-x \
39
    --without-zip \
40
    --without-python
41
LIBVIPS_INSTALL_STAGING = YES
42
LIBVIPS_DEPENDENCIES = \
43
    host-pkgconf libglib2 \
44
    libxml2 $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
45
​
46
# --disable-cxx is broken upstream
47
# https://github.com/jcupitt/libvips/issues/231
48
LIBVIPS_CONF_OPTS += --enable-cxx
49
​
50
ifeq ($(BR2_PACKAGE_JPEG),y)
51
LIBVIPS_CONF_OPTS += --with-jpeg
52
LIBVIPS_DEPENDENCIES += jpeg
53
else
54
LIBVIPS_CONF_OPTS += --without-jpeg
55
endif
56
​
57
ifeq ($(BR2_PACKAGE_LIBPNG),y)
58
LIBVIPS_CONF_OPTS += --with-png
59
LIBVIPS_DEPENDENCIES += libpng
60
else
61
LIBVIPS_CONF_OPTS += --without-png
62
endif
63
​
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.