• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/linknx/linknx.mk
Rahul BedarkarRahul Bedarkar committed af31c309e7330 Mar 2017
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
################################################################################
#
# linknx
#
################################################################################
​
LINKNX_VERSION = 0.0.1.32
LINKNX_SITE = http://downloads.sourceforge.net/project/linknx/linknx/linknx-$(LINKNX_VERSION)
LINKNX_LICENSE = GPL-2.0+
LINKNX_INSTALL_STAGING = YES
# Patching acinclude.m4
LINKNX_AUTORECONF = YES
LINKNX_CONF_OPTS = \
    --without-lua \
    --without-log4cpp \
    --without-pth-test \
    --with-pth=$(STAGING_DIR)/usr \
    --disable-smtp \
    --with-libcurl=$(STAGING_DIR)/usr/bin/curl-config
​
LINKNX_DEPENDENCIES = libpthsem libcurl \
    $(if $(BR2_PACKAGE_ARGP_STANDALONE),argp-standalone)
​
# This is needed to make autoreconf happy
define LINKNX_CREATE_MISSING_FILES
    touch $(@D)/NEWS $(@D)/AUTHORS $(@D)/README
endef
LINKNX_POST_EXTRACT_HOOKS += LINKNX_CREATE_MISSING_FILES
​
ifeq ($(BR2_PACKAGE_MYSQL),y)
LINKNX_CONF_OPTS += --with-mysql=$(STAGING_DIR)/usr/bin/mysql_config
LINKNX_DEPENDENCIES += mysql
else
LINKNX_CONF_OPTS += --without-mysql
endif
​
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.