• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/linux-fusion/linux-fusion.mk
Yann E. MORINYann E. MORIN committed e7aa4b269e110 Dec 2015
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# linux-fusion
4
#
5
################################################################################
6
​
7
LINUX_FUSION_VERSION = 9.0.3
8
LINUX_FUSION_SITE = http://directfb.org/downloads/Core/linux-fusion
9
LINUX_FUSION_SOURCE = linux-fusion-$(LINUX_FUSION_VERSION).tar.xz
10
LINUX_FUSION_INSTALL_STAGING = YES
11
LINUX_FUSION_DEPENDENCIES = linux
12
LINUX_FUSION_LICENSE = GPLv2+
13
LINUX_FUSION_LICENSE_FILES = debian/copyright
14
​
15
LINUX_FUSION_ETC_DIR = $(TARGET_DIR)/etc/udev/rules.d
16
​
17
LINUX_FUSION_MAKE_OPTS = \
18
    KERNEL_VERSION=$(LINUX_VERSION_PROBED) \
19
    KERNEL_BUILD=$(LINUX_DIR) \
20
    KERNEL_SOURCE=$(LINUX_DIR) \
21
    SYSROOT=$(TARGET_DIR) \
22
    ARCH=$(KERNEL_ARCH) \
23
    CROSS_COMPILE=$(TARGET_CROSS) \
24
    KERNEL_MODLIB=/lib/modules/$(LINUX_VERSION_PROBED)/kernel
25
​
26
define LINUX_FUSION_BUILD_CMDS
27
    $(TARGET_CONFIGURE_OPTS) $(MAKE) $(LINUX_FUSION_MAKE_OPTS) -C $(@D)
28
endef
29
​
30
define LINUX_FUSION_INSTALL_STAGING_CMDS
31
    $(TARGET_CONFIGURE_OPTS) $(MAKE) $(LINUX_FUSION_MAKE_OPTS) INSTALL_MOD_PATH=$(STAGING_DIR) -C $(@D) headers_install
32
endef
33
​
34
define LINUX_FUSION_INSTALL_TARGET_CMDS
35
    $(TARGET_CONFIGURE_OPTS) $(MAKE) \
36
        $(LINUX_FUSION_MAKE_OPTS) \
37
        INSTALL_MOD_PATH=$(TARGET_DIR) \
38
        -C $(@D) install
39
    $(INSTALL) -D -m 644 package/linux-fusion/40-fusion.rules \
40
        $(LINUX_FUSION_ETC_DIR)/40-fusion.rules
41
endef
42
​
43
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.