• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/linux-tools/linux-tool-gpio.mk.in
Yann E. MORINYann E. MORIN committed 4a03d1ac29f30 Aug 2017
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# gpio
4
#
5
################################################################################
6
​
7
LINUX_TOOLS += gpio
8
​
9
GPIO_MAKE_OPTS = $(LINUX_MAKE_FLAGS)
10
​
11
define GPIO_BUILD_CMDS
12
    $(Q)if ! grep install $(LINUX_DIR)/tools/gpio/Makefile >/dev/null 2>&1 ; then \
13
        echo "Your kernel version is too old and does not have the gpio tools." ; \
14
        echo "At least kernel 4.8 must be used." ; \
15
        exit 1 ; \
16
    fi
17
​
18
    $(TARGET_MAKE_ENV) $(MAKE1) -C $(LINUX_DIR)/tools \
19
        $(GPIO_MAKE_OPTS) \
20
        gpio
21
endef
22
​
23
define GPIO_INSTALL_TARGET_CMDS
24
    $(TARGET_MAKE_ENV) $(MAKE1) -C $(LINUX_DIR)/tools \
25
        $(GPIO_MAKE_OPTS) \
26
        DESTDIR=$(TARGET_DIR) \
27
        gpio_install
28
endef
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.