• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/makedevs/makedevs.mk
Thomas PetazzoniThomas Petazzoni committed 6268be239aa03 Jul 2016
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# makedevs
4
#
5
################################################################################
6
​
7
MAKEDEVS_LICENSE = GPLv2
8
​
9
HOST_MAKEDEVS_CFLAGS = $(HOST_CFLAGS)
10
HOST_MAKEDEVS_LDFLAGS = $(HOST_LDFLAGS)
11
​
12
ifeq ($(BR2_ROOTFS_DEVICE_TABLE_SUPPORTS_EXTENDED_ATTRIBUTES),y)
13
HOST_MAKEDEVS_DEPENDENCIES += host-libcap
14
HOST_MAKEDEVS_CFLAGS += -DEXTENDED_ATTRIBUTES
15
HOST_MAKEDEVS_LDFLAGS += -lcap
16
endif
17
​
18
define MAKEDEVS_BUILD_CMDS
19
    $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) \
20
        package/makedevs/makedevs.c -o $(@D)/makedevs
21
endef
22
​
23
define MAKEDEVS_INSTALL_TARGET_CMDS
24
    $(INSTALL) -D -m 755 $(@D)/makedevs $(TARGET_DIR)/usr/sbin/makedevs
25
endef
26
​
27
define HOST_MAKEDEVS_BUILD_CMDS
28
    $(HOSTCC) $(HOST_MAKEDEVS_CFLAGS) package/makedevs/makedevs.c \
29
        -o $(@D)/makedevs $(HOST_MAKEDEVS_LDFLAGS)
30
endef
31
​
32
define HOST_MAKEDEVS_INSTALL_CMDS
33
    $(INSTALL) -D -m 755 $(@D)/makedevs $(HOST_DIR)/usr/bin/makedevs
34
endef
35
​
36
$(eval $(generic-package))
37
$(eval $(host-generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.