• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/mesa3d-demos/mesa3d-demos.mk
Bernd KuhlsBernd Kuhls committed 8f239e783fb18 Dec 2015
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# mesa3d-demos
4
#
5
################################################################################
6
​
7
MESA3D_DEMOS_VERSION = 8.3.0
8
MESA3D_DEMOS_SOURCE = mesa-demos-$(MESA3D_DEMOS_VERSION).tar.bz2
9
MESA3D_DEMOS_SITE = ftp://ftp.freedesktop.org/pub/mesa/demos/$(MESA3D_DEMOS_VERSION)
10
MESA3D_DEMOS_AUTORECONF = YES
11
MESA3D_DEMOS_DEPENDENCIES = host-pkgconf
12
MESA3D_DEMOS_LICENSE = MIT
13
​
14
MESA3D_DEMOS_CONF_OPTS += \
15
    --disable-osmesa \
16
    --disable-gles1
17
​
18
ifeq ($(BR2_PACKAGE_XORG7)$(BR2_PACKAGE_HAS_LIBGL),yy)
19
MESA3D_DEMOS_DEPENDENCIES += libgl libglew libglu xlib_libX11 xlib_libXext
20
MESA3D_DEMOS_CONF_OPTS += --enable-gl --enable-x11
21
else
22
MESA3D_DEMOS_CONF_OPTS += --disable-gl --disable-x11
23
endif
24
​
25
ifeq ($(BR2_PACKAGE_HAS_LIBEGL),y)
26
MESA3D_DEMOS_DEPENDENCIES += libegl
27
MESA3D_DEMOS_CONF_OPTS += --enable-egl
28
else
29
MESA3D_DEMOS_CONF_OPTS += --disable-egl
30
endif
31
​
32
ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
33
MESA3D_DEMOS_DEPENDENCIES += libgles
34
MESA3D_DEMOS_CONF_OPTS += --enable-gles2
35
else
36
MESA3D_DEMOS_CONF_OPTS += --disable-gles2
37
endif
38
​
39
ifeq ($(BR2_PACKAGE_HAS_LIBOPENVG),y)
40
MESA3D_DEMOS_DEPENDENCIES += libopenvg
41
MESA3D_DEMOS_CONF_OPTS += --enable-vg
42
else
43
MESA3D_DEMOS_CONF_OPTS += --disable-vg
44
endif
45
​
46
ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL),y)
47
MESA3D_DEMOS_DEPENDENCIES += mesa3d
48
MESA3D_DEMOS_CONF_OPTS += --enable-gbm
49
else
50
MESA3D_DEMOS_CONF_OPTS += --disable-gbm
51
endif
52
​
53
ifeq ($(BR2_PACKAGE_FREETYPE),y)
54
MESA3D_DEMOS_DEPENDENCIES += freetype
55
MESA3D_DEMOS_CONF_OPTS += --enable-freetype2
56
else
57
MESA3D_DEMOS_CONF_OPTS += --disable-freetype2
58
endif
59
​
60
ifeq ($(BR2_PACKAGE_LIBFREEGLUT),y)
61
MESA3D_DEMOS_DEPENDENCIES += libfreeglut
62
MESA3D_DEMOS_CONF_OPTS += --with-glut=$(STAGING_DIR)/usr
63
# osmesa support depends on glut
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.