• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/mesa3d/mesa3d.mk
Bernd KuhlsBernd Kuhls committed efe465b0fd517 Jul 2016
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# mesa3d
4
#
5
################################################################################
6
​
7
# When updating the version, please also update mesa3d-headers
8
MESA3D_VERSION = 12.0.1
9
MESA3D_SOURCE = mesa-$(MESA3D_VERSION).tar.xz
10
MESA3D_SITE = ftp://ftp.freedesktop.org/pub/mesa/$(MESA3D_VERSION)
11
MESA3D_LICENSE = MIT, SGI, Khronos
12
MESA3D_LICENSE_FILES = docs/license.html
13
MESA3D_AUTORECONF = YES
14
​
15
MESA3D_INSTALL_STAGING = YES
16
​
17
MESA3D_PROVIDES =
18
​
19
MESA3D_DEPENDENCIES = \
20
    host-bison \
21
    host-flex \
22
    expat \
23
    libdrm
24
​
25
# The Sourcery MIPS toolchain has a special (non-upstream) feature to
26
# have "compact exception handling", which unfortunately breaks with
27
# mesa3d, so we disable it here by passing -mno-compact-eh.
28
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS),y)
29
MESA3D_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mno-compact-eh"
30
MESA3D_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -mno-compact-eh"
31
endif
32
​
33
ifeq ($(BR2_PACKAGE_OPENSSL),y)
34
MESA3D_DEPENDENCIES += openssl
35
MESA3D_CONF_OPTS += --with-sha1=libcrypto
36
else ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
37
MESA3D_DEPENDENCIES += libgcrypt
38
MESA3D_CONF_OPTS += --with-sha1=libgcrypt
39
else ifeq ($(BR2_PACKAGE_LIBSHA1),y)
40
MESA3D_DEPENDENCIES += libsha1
41
MESA3D_CONF_OPTS += --with-sha1=libsha1
42
endif
43
​
44
ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
45
MESA3D_DEPENDENCIES += udev
46
MESA3D_CONF_OPTS += --disable-sysfs
47
else
48
MESA3D_CONF_OPTS += --enable-sysfs
49
endif
50
​
51
ifeq ($(BR2_PACKAGE_XORG7),y)
52
MESA3D_DEPENDENCIES += \
53
    xproto_xf86driproto \
54
    xproto_dri2proto \
55
    xproto_glproto \
56
    xlib_libX11 \
57
    xlib_libXext \
58
    xlib_libXdamage \
59
    xlib_libXfixes \
60
    libxcb
61
MESA3D_CONF_OPTS += --enable-glx --disable-mangling
62
# quote from mesa3d configure "Building xa requires at least one non swrast gallium driver."
63
ifeq ($(BR2_PACKAGE_MESA3D_NEEDS_XA),y)
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.