• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/microperl/microperl.mk
Peter KorsgaardPeter Korsgaard committed 062cebb08fa27 May 2010
Raw file
Source viewDiff to previous
xxxxxxxxxx
     for i in $(patsubst %,$(TARGET_DIR)/$(MICROPERL_MODS_DIR)/%,$(dir $(MICROPERL_MODS))); do \
 
1
#############################################################
2
#
3
# microperl
4
#
5
#############################################################
6
MICROPERL_MAJ=5
7
MICROPERL_VERSION=$(MICROPERL_MAJ).8.8
8
MICROPERL_SOURCE=perl-$(MICROPERL_VERSION).tar.bz2
9
MICROPERL_CAT:=$(BZCAT)
10
MICROPERL_SITE=ftp://ftp.cpan.org/pub/CPAN/src/5.0
11
MICROPERL_DIR=$(BUILD_DIR)/perl-$(MICROPERL_VERSION)
12
​
13
MICROPERL_MODS_DIR=/usr/lib/perl$(MICROPERL_MAJ)/$(MICROPERL_VERSION)
14
MICROPERL_MODS=$(call qstrip,$(BR2_PACKAGE_MICROPERL_MODULES))
15
ifeq ($(BR2_PACKAGE_AUTOMAKE),y)
16
MICROPERL_MODS+=File/Basename.pm Errno.pm Config.pm IO/File.pm Symbol.pm \
17
    SelectSaver.pm IO/Seekable.pm IO/Handle.pm IO.pm XSLoader.pm \
18
    DynaLoader.pm AutoLoader.pm Carp/Heavy.pm
19
endif
20
$(DL_DIR)/$(MICROPERL_SOURCE):
21
    $(call DOWNLOAD,$(MICROPERL_SITE),$(MICROPERL_SOURCE))
22
​
23
$(MICROPERL_DIR)/.source: $(DL_DIR)/$(MICROPERL_SOURCE)
24
    $(MICROPERL_CAT) $(DL_DIR)/$(MICROPERL_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
25
    # makedepend contains bashisms
26
    $(SED) 's~sh ./makedepend~bash ./makedepend~' \
27
        $(MICROPERL_DIR)/Makefile.SH \
28
        $(MICROPERL_DIR)/x2p/Makefile.SH \
29
        $(MICROPERL_DIR)/pod/Makefile.SH
30
    chmod -R u+w $(MICROPERL_DIR)
31
    touch $@
32
​
33
$(MICROPERL_DIR)/.host_configured: $(MICROPERL_DIR)/.source
34
    # we need to build a perl for the host just for Errno.pm
35
    (cd $(MICROPERL_DIR); ./Configure -Dcc=$(HOSTCC) -de  )
36
    touch $@
37
​
38
​
39
$(MICROPERL_DIR)/.host_configured_and_fixed: $(MICROPERL_DIR)/.host_configured
40
    $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/Makefile
41
    $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/x2p/Makefile
42
    $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/makefile
43
    $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/x2p/makefile
44
    touch $@
45
​
46
$(MICROPERL_DIR)/.host_make: $(MICROPERL_DIR)/.host_configured_and_fixed
47
    $(MAKE) -C $(MICROPERL_DIR)     || echo "An error is expected on make"
48
    touch $@
49
​
50
$(MICROPERL_DIR)/.host_make_fixed: $(MICROPERL_DIR)/.host_make
51
    $(MAKE) -C $(MICROPERL_DIR) test    || echo "An error is expected on make test"
52
    touch $@
53
​
54
$(MICROPERL_DIR)/.configured: $(MICROPERL_DIR)/.host_make_fixed
55
    # we need to build a perl for the host just for Errno.pm
56
    (cd $(MICROPERL_DIR); \
57
     chmod a+x ext/util/make_ext; \
58
     ext/util/make_ext nonxs Errno MAKE="$(firstword $(MAKE))" \
59
    )
60
    (cd $(MICROPERL_DIR); \
61
     chmod u+w uconfig.h; ./uconfig.sh; \
62
     $(MAKE) -f $(MICROPERL_DIR)/Makefile.micro regen_uconfig; \
63
     $(SED) 's,PRIVLIB ".*,PRIVLIB "/$(MICROPERL_MODS_DIR)",' \
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.