• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/mysql/mysql.mk
Arnout VandecappelleArnout Vandecappelle committed 7b9c5d65e0d14 Dec 2015
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# mysql
4
#
5
################################################################################
6
​
7
MYSQL_VERSION_MAJOR = 5.1
8
MYSQL_VERSION = $(MYSQL_VERSION_MAJOR).73
9
MYSQL_SOURCE = mysql-$(MYSQL_VERSION).tar.gz
10
MYSQL_SITE = http://downloads.skysql.com/archives/mysql-$(MYSQL_VERSION_MAJOR)
11
MYSQL_INSTALL_STAGING = YES
12
MYSQL_DEPENDENCIES = readline ncurses
13
MYSQL_AUTORECONF = YES
14
MYSQL_LICENSE = GPLv2
15
MYSQL_LICENSE_FILES = README COPYING
16
​
17
MYSQL_CONF_ENV = \
18
    ac_cv_sys_restartable_syscalls=yes \
19
    ac_cv_path_PS=/bin/ps \
20
    ac_cv_FIND_PROC="/bin/ps p \$\$PID | grep -v grep | grep mysqld > /dev/null" \
21
    ac_cv_have_decl_HAVE_IB_ATOMIC_PTHREAD_T_GCC=yes \
22
    ac_cv_have_decl_HAVE_IB_ATOMIC_PTHREAD_T_SOLARIS=no \
23
    ac_cv_have_decl_HAVE_IB_GCC_ATOMIC_BUILTINS=yes \
24
    mysql_cv_new_rl_interface=yes
25
​
26
MYSQL_CONF_OPTS = \
27
    --without-ndb-binlog \
28
    --without-docs \
29
    --without-man \
30
    --without-libedit \
31
    --without-readline \
32
    --with-low-memory \
33
    --enable-thread-safe-client \
34
    --disable-mysql-maintainer-mode
35
​
36
# host-mysql only installs what is needed to build mysql, i.e. the
37
# gen_lex_hash tool, and it only builds the parts that are needed to
38
# create this tool
39
HOST_MYSQL_DEPENDENCIES = host-zlib host-ncurses
40
​
41
HOST_MYSQL_CONF_OPTS = \
42
    --with-embedded-server \
43
    --disable-mysql-maintainer-mode
44
​
45
define HOST_MYSQL_BUILD_CMDS
46
    $(MAKE) -C $(@D)/include my_config.h
47
    $(MAKE) -C $(@D)/mysys libmysys.a
48
    $(MAKE) -C $(@D)/strings libmystrings.a
49
    $(MAKE) -C $(@D)/vio libvio.a
50
    $(MAKE) -C $(@D)/dbug libdbug.a
51
    $(MAKE) -C $(@D)/regex libregex.a
52
    $(MAKE) -C $(@D)/sql gen_lex_hash
53
endef
54
​
55
define HOST_MYSQL_INSTALL_CMDS
56
    $(INSTALL) -m 0755  $(@D)/sql/gen_lex_hash $(HOST_DIR)/usr/bin/
57
endef
58
​
59
ifeq ($(BR2_PACKAGE_OPENSSL),y)
60
MYSQL_DEPENDENCIES += openssl
61
endif
62
​
63
ifeq ($(BR2_PACKAGE_ZLIB),y)
64
MYSQL_DEPENDENCIES += zlib
65
endif
66
​
67
ifeq ($(BR2_PACKAGE_MYSQL_SERVER),y)
68
MYSQL_DEPENDENCIES += host-mysql host-bison
69
​
70
MYSQL_CONF_OPTS += \
71
    --localstatedir=/var/mysql \
72
    --with-atomic-ops=up \
73
    --with-embedded-server \
74
    --without-query-cache \
75
    --without-plugin-partition \
76
    --without-plugin-daemon_example \
77
    --without-plugin-ftexample \
78
    --without-plugin-archive \
79
    --without-plugin-blackhole \
80
    --without-plugin-example \
81
    --without-plugin-federated \
82
    --without-plugin-ibmdb2i \
83
    --without-plugin-innobase \
84
    --without-plugin-innodb_plugin \
85
    --without-plugin-ndbcluster
86
​
87
# Debugging is only available for the server, so no need for
88
# this if-block outside of the server if-block
89
ifeq ($(BR2_ENABLE_DEBUG),y)
90
MYSQL_CONF_OPTS += --with-debug=full
91
else
92
MYSQL_CONF_OPTS += --without-debug
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.